Aller au contenu

Filament ABS

32 bits Ma Tevo Tarantula Pro avec une SKR Pro V1.1 ...... je seiche


Messages recommandés

j'ai acheté il y a quelque mois un Tevo Tarantula pro, j'en était plutôt satisfait.
J'ai fait un test d'impression avec un filament ABS et a ma surprise, ce fut un échec et en plus le lit chauffant a été voilé, il ressemblai plus a une baignoire ensuite.
J'ai viré l'ancien lit et acheté une plaque d'alu Aplan de 5mm d'épaisseur, de 235 x 235 mm, un coussin chauffant en silicone de Keenovo.
et une carte BigTreeTech SKR Pro V1.1 avec un écran TFT 35 V2.0.
et je me suis dit que ce serait bien de passer à la dernière version de Marlin, soit la 2.0.7.2.

J'ai configuré Marlin avec le paramètres de ma Tevo Pro et le problèmes sont apparus....

Je m'explique :
on peux tester le déplacements de chaque axes indépendamment, là pas de soucis, tout va dans la bonne direction.

on peux aussi faire le homing de chaque axes indépendamment, et c'est là que ça se complique; l'axe X c'est bon, l'axe Y part en sens inverse, et le Z aussi.
Ca fait une semaine que je seiche sur ce problème et j'ai pas encore trouvé..... et j'ai bientôt plus de cheveux.

C'est pourquoi je fais appel à cette communauté de grands metteurs au point que vous êtes tous pour tenter de trouver une solution à mon problème.
quel paramètre dois-je vérifier dans Marlin ?

J'ai joint a ce message les 2 fichiers de configuration, au cas ou....

Merci d'avance et a tout bientot

JiJi

 

Configuration.h Configuration_adv.h

Lien à poster
Partager sur d’autres sites

Salut,

Dans l'ordre:

  • La direction du home doit etre en MIN sur X, Y et Z ( grande majorite des cas sur les cartesiennes) dans le firmware Marlin
  • Tester le Home, si le moteur tourne dans le mauvais sens il faut changer le parametre de direction
#define INVERT_X_DIR true/false
  • Tester le deplacement via l'ecran TFT, si le deplacement est dans le mauvais sens il faut mettre a jour le firmware de l'ecran TFT (fichier config.ini) github
#### Inverted Axes For Move Menu
# Invert axis button function in Move menu in order it matches the actual axis
#
# Format: [X<option> Y<option> Z<option> E<option>]
#
# Options: [enable: 1, disable: 0]
#
invert_axis:X0 Y0 Z0

Cdt

SoM

Lien à poster
Partager sur d’autres sites

Merci bien pour ta réponse, je teste tout cela ce soir et te redis.

JiJi

 

Hello SoM

Comme je l'ai décris dans mon premier post, les déplacements des 3 axes vont dans le bon sens, c'est quand je fait le homing des axes séparément que ça se gâte.
L'axe X se déplace dans le bon sens, mais le Y se déplace en sens contraire, au lieu d'aller vers l'inter de fin de course, il part dans l'autre sens et va buter contre le moteur.
Si tu as une autre idée, je suis preneur.

Merci et bonne soirée

JiJi

Lien à poster
Partager sur d’autres sites

Salut SoM

Alors j'ai modifié le firmware de l'écran TFT 35 V2.0 comme tu me l'a montré.
Le problème persiste toujours ......
La seul différence que j'ai remarqué c'est dans les options pour inverser ou non le sens de rotation sur l'écran; en applicant la modif que tu propose, l'option pour inverser le sens de l'axe Y est activé (non activée avant la modiff) et quand je fait le homing de l'axe Y, le plateau part en butéé, mais pas vers l'inter de fin de course de l'axe Y.

Si tu as une autre idée, je suis encore preneur.

Merci d'avance
JiJi

PS : je précise que j'ai installé sur ma Tevo Tarantula Pro un axe double pour le z, des drivers 2208 de BTT, le BLTouch et j'ai remplacé l'alimentation par une MeanWell 24V 350W

Lien à poster
Partager sur d’autres sites
Il y a 13 heures, miserovitch a dit :

Tu as modifie le firmware de l'imprimante pour inverser le sens de rotation du moteur Y?

Oui, aussi; et j'ai le même comportement, les déplacement se font correctement en fonction des paramètres mis dans Marlin, mais le homing se fait en sens contraire !!!!

je comprend plus trop là.

Si tu as d'autres idées ?

Cordialement

JiJI

Lien à poster
Partager sur d’autres sites

Salut,

Tu as du oublier ou mélanger quelque chose.

Pour le moment tu oublies les fleches de deplacement, tu ne les utilises pas.

Pour etre certain envoies un G28 9home0 via ton pc ou cree un fichier gcode avec uniquement G28 dedans (fichier texte qui contient G28 et une extension en .gcode).

En modifiant le parametre  de direction dans le firmware de la carte mere ca modifiera le sens du homing.

// Invert the stepper direction. Change (or reverse the motor connector) if an axis goes the wrong way.
#define INVERT_X_DIR true
#define INVERT_Y_DIR false
#define INVERT_Z_DIR false

Une fois le firmware mis a jour il faut penser a faire un M502 pour etre certain que l'eeprom est mise a jour.

 

Une fois le sens du homing corrige on verra pour le sens des fleches.

Cd

SoM

Lien à poster
Partager sur d’autres sites
Il y a 8 heures, miserovitch a dit :

Une fois le firmware mis a jour il faut penser a faire un M502 pour etre certain que l'eeprom est mise a jour.

Ne pas oublier le M500 après le M502 😉

🙂

  • J'aime 1
Lien à poster
Partager sur d’autres sites
Le 18/12/2020 at 03:34, miserovitch a dit :

En modifiant le parametre  de direction dans le firmware de la carte mere ca modifiera le sens du homing

He bien non, ca n'a rien changé, le mouvement de l'axe Y et le homing sont toujours inversé,

 

Si quelqu'un a une autre idée je suis preneur

 

Merci

Lien à poster
Partager sur d’autres sites

Salut,

C'est juste pas possible, il y a quelque chose qui cloche dans ta procedure. Un changement de paramètre direction dans le firmware inverse le sens de rotation du moteur donc le sens du homing. Vient le moment où aider a distance atteint sa limite. C'est typiquement le genre de problème qui se règle en 3 minutes en face de la machine et en 3 jours via le forum.

Bon c'est pas grave en soi car on va y arriver mais j'imagine ta frustration.

Fais un changement du sens de rotation d'un des moteurs et mets ici toutes les étapes que tu suis (morceau de code modifier dans le firmware, comment tu charges le firmware, comment tu l'initialises...). On va finir par trouver.

Cdt

SoM

Envoyé de mon OnePlus 7
 

Modifié (le) par miserovitch
Lien à poster
Partager sur d’autres sites

Salut,

A vous lire, je me demande si le problème ne viendrait pas du branchement (ou du positionnement) du endstop Y : est-ce qu'il ne serait pas en Y Max plutôt qu'en Y Min.

@Jean-Jacques Praz, est-ce que tu as essayé cette modif dans la section Homing de ton Marlin ? Ou, autre question selon la même hypothèse : est-ce que le endstop Y est branché au bon endroit sur la carte ?

A vous lire, je  ne vois que ça.

A+

Lien à poster
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez poster un message et vous inscrire plus tard. Si vous avez déjà un compte, connectez-vous afin de poster avec.

Invité
Répondre à ce sujet…

×   Vous avez copié du contenu avec formatage.   Supprimer le formatage

  Only 75 emoji are allowed.

×   Votre lien a été automatiquement intégré.   Afficher en tant que lien à la place

×   Le contenu sauvegardé a été restauré.   Effacer l'éditeur

×   You cannot paste images directly. Upload or insert images from URL.

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

  • YouTube / Les Imprimantes 3D .fr

×
×
  • Créer...