Aller au contenu

Filament ABS

  • 0

probleme tmc2208 moteur qui saute


Question

Bonjour,

10eme jour non stop que je passe sur mon imprimante... je suis au bout ...

Pour faire court, j'ai une zonestar p802Q depuis 3 ans qui fonctionnait parfaitement

La carte mere m'as lâché je l'ai donc remplacer par une BTT SKR 1.4 turbo et 4 driver BBT TMC2208.

Apres configuration et reglage des driver, je lance l'impression test et tres vite je constate que Y et E saute en permanence ( je precise que rien n'as ete touché de se coté la et tout fonctionnait) (voir photo exemple de Y qui saute)

Je pense donc que cela vient des driver car les caractéristique de mes moteur sont introuvable avec la référence (42H-22012L-23BD pour X Y Z et 42H-22012L-16BD pour E)

Pour regler les driver j'ai donc mesurer le Vref de ma carte precedente (A44988 et R100), puis j'ai calculer la puissance RMS et a partir de cela la Vref a regler sur les TMC2208 (voir photo)

Les moteur ne chauffe pas (meme pas tiède) j'ai donc progressivement augmenter la Vref

Les saut on diminué mais sont toujours present et je suis au MAX de la Vref des TMC2208 (2,4V) et les moteur son legerement tiède) 

j'ai mesurer la consommation des moteur, j'ai des PIC a 0,765A avec la Vref a 2,4V

Apres autant de temps passé sur la machine, Je ne sait plus quoi faire et je n'ai plus d'idée si ce n'est mettre en cause le materiel.

 

Mais vous etes surement plus expert que moi 😉

Merci et bonne fete a toussss

IMG_2010.jpg

IMG_2011.jpg

IMG_2012.jpg

IMG_2008.jpg

Modifié (le) par djbouns
Lien à poster
Partager sur d’autres sites

5 réponses à cette question

Messages recommandés

  • 0
Lien à poster
Partager sur d’autres sites
  • 0
Il y a 4 heures, pafpaf a dit :

Merci

J'utilise des 2208, non evoquer dans ces article mais j'ai deja parcouru des dizaine de site sur le reglage, les calcul étant identique mais mon cas n'est pas evoqué 

 

Il y a 4 heures, ixi a dit :

@djbouns

Bonjour,

La Vref est vraiment très haute.

Tu es sur que cela ne vient pas d'un probleme de courroie trop lache ou quelque chose qui bloque le déplacement du lit ?

Oui la Vref est au MAX et pourtant ni le driver ni le moteur ne chauffe vraiment, se qui est tres étrange ... et le fait d'avoir la Vref au MAX et des pic a seulement 0,765A ne confirme pas que le driver ne delivre pas assez de puissance ?

Je n'ai pas touché la partie mécanique et cela fonctionnait tres bien, ce n'est pas la courroie qui saute de la poulie, ni la poulie qui est mal fixé mais bien l'axe sur le moteur qui saute faute de force. il n'y a rien qui touche le plateau pendant le deplacement.

Lien à poster
Partager sur d’autres sites
  • 0
il y a 48 minutes, pafpaf a dit :

Merci, j'ai les BTT tmc2208 3.0v donc aucune modif harware a faire.

Les cavalier sont instaler conformement au instruction de BTT et de se post

Le firmware egalement.

 

J'ai réussi a faire des test sur mon ancien carte et le moteur Y fait des pic a 1,1A alors qu'avec les TMC2208 elle ne monte qu'a 0,7A

Mise a par des driver défaillant je sèche ... 

Lien à poster
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez poster un message et vous inscrire plus tard. Si vous avez déjà un compte, connectez-vous afin de poster avec.

Invité
Répondre à cette question…

×   Vous avez copié du contenu avec formatage.   Supprimer le formatage

  Only 75 emoji are allowed.

×   Votre lien a été automatiquement intégré.   Afficher en tant que lien à la place

×   Le contenu sauvegardé a été restauré.   Effacer l'éditeur

×   You cannot paste images directly. Upload or insert images from URL.

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

  • YouTube / Les Imprimantes 3D .fr

×
×
  • Créer...