Aller au contenu

Filament ABS

  • 0

Mise en sécurité de la carte 32bits avec des LED RGB ?


Flob
Go to solution Solved by Flob,

Question

Bonjour,

Je sollicite encore l'aide de ce forum qui m'a déjà été bien utile précédemment.

Voici mon problème :

Lorsque je démarre l'imprimante (mise sous tension) avec les LED branchées, la carte se met en sécurité et coupe la puissance (j'ai l'écran et la carte qui reste allumé et utilisable mais pas de moteurs, de hotend ou de plateau chauffant). J'ai déjà eu le même problème lorsqu'un Endstop était branché malencontreusement à l'envers (++ pour les système de sécurité de la carte !). Par contre, si de débranche les LEDs, j'allume la carte et je rebranche les LEDs je peux modifier la couleur en Gcode depuis mon pc ! 🤨 Donc tout fonctionne correctement ? J'ai l'impression d'avoir raté une étape. 🤔

Est-ce que quelqu'un a déjà rencontré ce problème ? Est-ce que quelqu'un qui a déjà essayé des LED RGB sur du 32bits voit quelque chose que j'ai oublié ? 👃

Mes pistes :

Sur Marlin 2.0, est-ce qu'il ne faudrait pas déclarer ces pins RGB comme des servos à part entière ? Est-ce qu'il existe un timer/delay (env. 1s) pour s'assurer que la carte est pleinement démarrée avant de vérifier les pin servos ? Comme il est possible de faire fonctionner les LED en branchant manuellement après l'allumage de la carte (et tout le reste fonctionne) il me parait peu probable que ce soit un problème électrique (ou d'état électrique transitoire).

 

Merci de m'offrir vos suggestions, conseils, et (peut-être 😉) solutions.

🎉 Bonnes fêtes de fin d'années à tous ! 🥳

 

 

Pour la configuration complète :

J'ai une carte MKS Sgen V1.0 sous Marlin 2.0. Ayant récupéré un ventilateur 12V RGB, je me suis dis que ce serait une bonne idée de brancher le RGB sur les 3 servos restants : P2.12, P2.11, P4.28 🤔. Le servo 0 (P1.23) étant réservé au BLtouch. Les pins sont en 5V et les leds en 12V donc, pas fou, je réalise un petit circuits avec des MOSFETs IRL540L (exprès pilotable en 5V). 🤯

Pour le connecteur à gauche, les pins RGB 5V vont sur la carte. Le 12V et le GND sont directement sur l'alimentation. A droite, tout est sur le ventilateur. Là comme ça, je ne voit pas de court-circuit possible. Le courant n'est pas sensé passer les grilles des MOSFETs, est régulé la la résistance de 1k Ohm. Pour le montage, il faut me faudra me croire sur paroles mais je n'ai rien remarqué d'anormal avec les tests de conduction au multimètre (en plus, en branchant manuellement, ça fonctionne !?).

image.thumb.png.3dde718128d9d57dba396b3f05126dd6.png

La pinmap de la carte avec les servos en J8 en haut à gauche.

 image.png.50c8978a6ab8d7092bb0fc3869f446a5.png

La doc marlin sur l'affectation des servos par pin

image.png.6b3b40698a6a9dbadcf5363dfeb180c0.png

Je joint en plus le Configuration.h, sachant que le paramétrage des LEDs est à la toute fin. (j'utilise Platformio comme IDE)

Configuration.h

Modifié (le) par Flob
Lien à poster
Partager sur d’autres sites

1 réponse à cette question

Messages recommandés

  • 0
  • Solution

Bonjour à tous,

Bon. Pour infos ou la postérité, j'ai réussi à trouver à force de chercher. Voici la solution :

J'ai trouvé l'image suivante et j'ai réalisé mon erreur. J'ai rebranché mes broches sur les P2.13 (Bleu) P3.25 (Rouge) et P3.26 (Vert). Toutes ces broches sont PWM.

Sbase/Smoothieware - Use a Free PWM Pin and Power Expander or SSR to  Control Fans. : 3 Steps (with Pictures) - Instructables

Le seul petit soucis, c'est qu'au démarrage, tout est éteint. Le rouge et vert ne fonctionnement pas. Il faut effectuer la procédure suivante : Allumage bleu, Allumage rouge, Allumage vert. Après tout est possible.

Donc maintenant je cherche le moyen d'initialiser l'éclairage au démarrage de l'imprimante directement sur le firmware sans passer par le slicer. Peut-être avec un fichier auto0.g ? Je cherche toujours...

Lien à poster
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez poster un message et vous inscrire plus tard. Si vous avez déjà un compte, connectez-vous afin de poster avec.

Invité
Répondre à cette question…

×   Vous avez copié du contenu avec formatage.   Supprimer le formatage

  Only 75 emoji are allowed.

×   Votre lien a été automatiquement intégré.   Afficher en tant que lien à la place

×   Le contenu sauvegardé a été restauré.   Effacer l'éditeur

×   You cannot paste images directly. Upload or insert images from URL.

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

  • YouTube / Les Imprimantes 3D .fr

×
×
  • Créer...