Aller au contenu

Filament ABS

je n'arrive pas a regler le Z offset


Messages recommandés

Bonjour toujours aussi débutant donc suite a l’installation du BL Touch  (qui ne s’est pas fait sans ma j’ai dû essayer avec 5 câbles USB diffèrent pour en trouver un qui fonctionne )

Maintenant j’ai de gros soucis pour régler le Z offset j’ai essayé de faire la méthode de cette vidéo https://www.youtube.com/watch?v=h1DoS6_vepY a plusieurs reprise suivant la méthodologie suivante

Depuis quand je fais un Auto Home la buse est à 275 mm du plateau

Dans le menu de l’imprimante j’ai fais la séquence suivante

Prépare => Move axis => Move Z

Sur Move Z (je suis à 000.0)

Je descends la tète

10/10 mm => - 250 mm

Puis 1/1 mm => -1mm

Puis 0.1/0.1 => - 0.5 mm

Soit au total -251.5 mm  deja cela ne correspond pas au +275 mm mesuré

De là je passe dans le menu a control => initialize EEPROM pour valider ma hauteur Z

Ce qui donne sur l’écran de l’imprimante un Z a -51.5 par contre je suis toujours en Z Offset 000.0

Je cherche a comprendre ou je me suis pris les pieds dans le tapis je tourne en rond et je ni arrive pas d’où mon post

Si quelqu'un a deja fait la manipulation et qui soit capable de l'expliquer ce qui toujours évidant a faire je lui dis merci d'avance

Lien à poster
Partager sur d’autres sites

Un reset eeprom efface la mémoire de l'imprimante donc il faudra refaire ton mesh leveling.

Du coup se reconnecter avec pronterface ou autre et relancer le G29 en premier lieu.

Je procède ainsi si as le menu z-offset:

1- on descend le z a 0 (mettre le z-offset a 0 si il n'y est pas)

2- on va dans le menu z-offset et on descend jusqu'à frotter la buse

3- Store setting

Et c'est fini

Modifié (le) par Idealnight
Lien à poster
Partager sur d’autres sites

Bonjour idealnigth je viens de relire ta reponse d'apres toi peut on le faire a partir du menu de l'imprimante

ou je suis obligé de passer  par pronterface?

j'ai fais un move Z de -334.7 le calibrage avec la feuille de papier est bon

menu Control => Z offset a 000.00

Store setting pour enregistrer  a l'ecran d'accueil de l'imprimante j'ai  un  Z de -34.7  

Je pense qu'il y a quelque chose qui cloche ou je m'y prend comme une brele

Modifié (le) par jj224
modif
Lien à poster
Partager sur d’autres sites

Hello , j'ai le même soucis que toi enfin presque sur une ender 5 pro avec bl touch , j'ai changé ma buse et du coup j'ai refait un reglage de l'offset en Z mais cela ne change rien j'ai suivi cette procédure  mais peu importe la valeur que je met dans l'offset cela ne change rien la buse est toujours a la même distance du plateau . J'y comprend plus rien

Modifié (le) par Rafi57
Lien à poster
Partager sur d’autres sites

Je précise:

- on chauffe la buse et le plateau a température d'impression (on attend 10 minutes)

- On fait un Home

- Control -> Motion -> vérifier que le Z-offset soit à 0

- Move Axis Z on se met a 0

- Control -> Motion -> on descend pour frotter sa feuille de papier

- STORE SETTINGS

Lien à poster
Partager sur d’autres sites

Au début quand j'ai installé le bl touch j'ai suivi cette vidéo  cela a fonctionné sans soucis , les pb c'est lors d'un changement de buse la hauteur n'est jamais la même du coup faut refaire un reglage de l'offset Z , mais bon cela ne fonctionne pas . en plus dans la vidéo ils ne parlent pas de modifier le Gcode de démarrage donc ....

Lien à poster
Partager sur d’autres sites

idealnigth j'ai chauffer la bete en PLA 

puis dans le menu : Prepare => auto Home la la buse monte a +362 mm du plateau

je me suis tromper ou j'ai loupe quelque chose ?

precision dans control => motion le Z offset est a 000..00

sur l'ecran de l'imprimante j'ai X 103   Y 150  et Z 10

 

idealnigth ce que je ne comprend pas c'est que je me retrouve en faisant un auto home a + 362 mm et je ne vois pas comment ramener a 0.3 du plateau.

je sais que je te sollicite beaucoup merci

Modifié (le) par jj224
Lien à poster
Partager sur d’autres sites

Fais un reset eeprom tu as du enregistré un nouveau truc normalement en Home il est a +5.00.

Controles que ton home est redevenu normal, puis refais le mesh leveling vi pronterface ou autre puis la procédure du z-offset

Ne mets pas de fil de PLA dans le tube car ça va suinter au niveau de la buse et pour le nivellement la buse doit être clean 😉

Modifié (le) par Idealnight
Lien à poster
Partager sur d’autres sites

dans le menu j'ai initialyse eeprom et load settings

donc je vais dessus el je clic et cela fait une raz

setting.jpg

 

J"ai lancer initialize eeprom la tete s'est deplacé a peut pres a +105 et a Z +30 mm du bed et a l'affichage j'ai Z +10

je me demande si c'est pas le firmware de creality qui a un bug

Modifié (le) par jj224
Lien à poster
Partager sur d’autres sites

Alors comme je ne connais pas ta machine ni le firmware je ne vais pas pouvoir te dire ce que tu devrais avoir à la base :(.

Moi ma buse en home se place a +5mm peut-être que toi il est normal que tu sois a +10 cela ne change rien au moins là il t'est plus aisé de te mettre a 0 🙂

  • +1 1
Lien à poster
Partager sur d’autres sites

Moi  ,j'ai le même soucis j'ai même refait toute la procédure que dans la vidéo de créality pour l'installation du bl touch  , mon réglage Z offset fonctionne une fois après avoir fait toute la procédure mais des que je change de buse et qu'il faut de nouveau régler le Z offset cela ne fonctionne plus , comme si l'imprimante ne prennais plus en compte la correction et même après un reset eeprom , je me demande si c'est pas le bl touch qui fou la merde , faudrait peut être le virer et faire un bed leveling a l'ancienne 😰

Lien à poster
Partager sur d’autres sites

Bonjour,

D'après ce je lis, son soucis est qu'il a un affichage sur son écran du Z à 10mm alors que la position réelle du-dit Z est à 30mm ??

Ou alors je n'ai rien compris (ça m'arrive souvent .... ces temps ci, étrange ...) Ce qui est étrange, c'est que ça monte aussi haut pour redescendre ensuite..

Lien à poster
Partager sur d’autres sites

Bonjour papaone je refais un topo de mon problème  car moi aussi je vais finir par m'embrouiller

le  BLTouch est un officiel  Creality specifique CR10-V2  pas une copie le cablage est donné avec donc pas d'erreur la dessus du moins je l'espere

J'ai réussi a injecter le firmware CR-10 V2TF1.1.6.0BLTouchV3 donnée sur le site Creality BLTouch, l’écran d'accueil de l'imprimante indique "CR-10 V2BLTouch ready". la version firmware indiqué sur l'imprimante est 1.1.6 V2BL Touch

Reglage du Z offset par étape

Prepare=> Motion axis=>Move Z=>Valeur Z (-001.6)( calage a l'epaisseur du papier)=> Control=Store setting=>Control=>Motion=>Z Offset (000.00) Reglage du Z Offset ( -01.61)=> Store setting => Menu Accueil=<Prepare Auto Home

La tete se deplace au mlieu du bed et a +20 mm du plateau

JE vais devenir fou avec cette imprimante.

Modifié (le) par jj224
Lien à poster
Partager sur d’autres sites

@jj224

Bonjour,

Tu as pris le kit Creality pour la CR10-V2. Tu as suivi la vidéo de Creality pour le monter et le connecter sur le PCB sous l'extrudeur ?

Tu peux tester si tu penses que le firmware de Creality pourrait être en cause celui que j'ai réalisé à partir d'un Marlin 2 (à jour et dans la dernière version stable 2.0.7.2) :

 

Si tu ne veux / peux pas compiler par toi même (ce que je préfère plutôt que livrer le firmware compilé directement à flasher 😉 ), en cherchant un peu tu devrais pouvoir le trouver 😄

Please_click_here_11.gif.5dbd30940e611697afdf73ddb92f5b2c.gif

Révélation

Après avoir flashé un nouveau firmware, il est plus que conseillé de toujours procéder à une remise à zéro de l'EEPROM (option de l'écran ou M502 puis M500 (c'est la même chose 😉 ).

Pour procéder au réglage du décalage, il est préférable de passer par un logiciel une fois l'imprimante reliée à l'ordinateur via le câble USB (Pronterface, Repetier, Octoprint, Termite, …) même si c'est réalisable via l'écran :

Citation

Instructions de réglage du décalage Z:
1. Effectuer la mise à l'origine des axes de l'imprimante via G28
2. M851 Z0 - Initialiser le décalage en Z à 0 (remise à 0 du Zoffset s'il y en avait un)
3. M500 - Stocker ce réglage en EEPROM
4. M501 - Récupérer les paramètres de l'EEPROM pour les rendre actifs
5. M503 - Afficher les paramètres en cours pour vérifier qu'ils ont bien été pris en compte
6. G28 Z - Mettre à l'origine l'axe Z
7. G1 F60 Z0 - Déplacer la buse au 0 Z
8. M211 S0 - Désactiver les contacteurs de fin de course (pour pouvoir descendre sous le 0)
9. Descendre doucement (pas de 0,01mm) l'axe Z jusqu'à frotter  la feuille de papier (ou la cale utilisée)
10. Noter la valeur affichée de la position du Z sur l'écran du boitier (additionner cette valeur (sans tenir compte du signe négatif) à l'épaisseur de la cale utilisée)
11. M851 Z X.XX (X.XX étant le décalage en Z calculé au point 10 (valeur négative))
12. M211 S1 - Réactiver les limites des contacteurs de fin de course
13. M500 - Sauvegarder ce réglages en EEPROM
14. M501 - Récupérer les paramètres de l'EEPROM pour les rendre actifs
15. M503 -Vérifier une dernière fois que tout a bien été pris en compte

🙂

  • Merci ! 1
Lien à poster
Partager sur d’autres sites
Il y a 23 heures, Rafi57 a dit :

Moi  ,j'ai le même soucis j'ai même refait toute la procédure que dans la vidéo de créality pour l'installation du bl touch  , mon réglage Z offset fonctionne une fois après avoir fait toute la procédure mais des que je change de buse et qu'il faut de nouveau régler le Z offset cela ne fonctionne plus , comme si l'imprimante ne prennais plus en compte la correction et même après un reset eeprom , je me demande si c'est pas le bl touch qui fou la merde , faudrait peut être le virer et faire un bed leveling a l'ancienne 😰

@Rafi57 tu fais store setting ?

Il y a 23 heures, jj224 a dit :

Prepare=> Motion axis=>Move Z=>Valeur Z (-001.6)( calage a l'epaisseur du papier)=> Control=Store setting=>Control=>Motion=>Z Offset (000.00) Reglage du Z Offset ( -01.61)=> Store setting => Menu Accueil=<Prepare Auto Home

@jj224 (Par précaution on met le Z-offset à 0 dans control motion) puis Avant toute manip on fait un auto home, Prepare=> Motion axis=>Move Z=>Valeur Z (là tu dois être dans une position de +5mm)=> On se met à 0 => Control => Motion => Z Offset (là on descend jusqu'à la feuille de papier) => Store setting

Ensuite tu peux imprimer, en cours d'impression si tu trouves la première couche trop ou pas assez collée tu peux retourner (toujours en cours d'impression) réajuster le z-offset 1 cran à la fois hein ;))

Modifié (le) par Idealnight
Lien à poster
Partager sur d’autres sites

Oui oui , j'arrête pas de le faire le store settings , ça imprime mieux y a juste quand je j'imprime la première couche de mon adhérence plateau en général je fait un radeau , quand la buse arrive a la fin de la première couche du radeau elle se déplace au dessus de celle ci et frotte méchament  mais après ça va , pourtant la première couche est bien "écrasée" sur le plateau pour une bonne adhérence . Enfin y a des trucs que je comprend pas toujours lol .

Modifié (le) par Rafi57
Lien à poster
Partager sur d’autres sites

Merci a tous de répondre a nos problèmes

Fran6p ce que tu donne dans "Instructions de réglage du décalage Z:" c'est a rentrer et a renseigner dans Pronterface colonne de droite  au dessus de send ?

Je ne me suis jamais servi de Pronterface, mais je vais apprendre 😢

 Le firmware.exe que tu composé et mis dans le post est bien avec un BL Touch Je comprend que tu préfère compiler (faut il savoir le faire) plutôt que de prendre du tout prêt car en cas de soucis tu es dans la M...

2 lignes m'interpelle 8. M211 S0 - Désactiver les contacteurs de fin de course (pour pouvoir descendre sous le 0)

                                   12. M211 S1 - Réactiver les limites des contacteurs de fin de course

Car je pensais qu'il fallait supprimer physiquement le Fin de course mécanique d'origine

J'ai reflashé avec le firmware d'origine car j'étais completement bloqué , mais grace a vous je vais re attaquer

MERCI

Lien à poster
Partager sur d’autres sites
Le 20/01/2021 at 18:56, jj224 a dit :

c'est a rentrer et a renseigner dans Pronterface colonne de droite  au dessus de send ?

Oui

Le 20/01/2021 at 18:56, jj224 a dit :

Le firmware.exe.bin que tu composé et mis dans le post est bien avec un BL Touch

Oui, il gère le BLT quand il est connecté sur le PCB sous l'extrudeur. D'origine Creality a pré-câblé le BLT sur le Zmax 😉

Donc tu peux le flasher sur ta carte, ton écran sera alors en français 😉, le babystep est actif (double clic sur le bouton de l'écran pour y accéder), et d'autres options encore.

Le fichiers ayant servis à cette compilation (le firmware.bin) sont disponibles sur mon dépôt Github si tu veux compiler toi-même (le lien est dans mon «tuto»).

Le 20/01/2021 at 18:56, jj224 a dit :

2 lignes m'interpelle 8. M211 S0 - Désactiver les contacteurs de fin de course (pour pouvoir descendre sous le 0)

                                   12. M211 S1 - Réactiver les limites des contacteurs de fin de course

Par défaut, un fois la mise à l'origine faite, on ne peut descendre sous le zéro (0) sauf si on désactive les contacteurs de fin de course qu'ils soient classiques ou celui utilisé par le BLT (le connecteur deux fils, blanc / noir).

🙂

  • J'aime 1
Lien à poster
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez poster un message et vous inscrire plus tard. Si vous avez déjà un compte, connectez-vous afin de poster avec.

Invité
Répondre à ce sujet…

×   Vous avez copié du contenu avec formatage.   Supprimer le formatage

  Only 75 emoji are allowed.

×   Votre lien a été automatiquement intégré.   Afficher en tant que lien à la place

×   Le contenu sauvegardé a été restauré.   Effacer l'éditeur

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Créer...