Aller au contenu

Filament ABS

marlin Installation et réglages BLTouch sur Ender 5


Messages recommandés

Bonjour à tous,

Sur les conseils de Idealnight, je créé un sujet sur mes problèmes. Ayant du mal à bien régler la hauteur de ma buse, j'ai acheté un Creality BLTouch. Pas de soucis particulier jusqu'au moment où rien n'est apparu sur mon PC (pas de progist). Je donc téléchargé sur le site celui-ci : Ender-51.1.6.3BLTouchV3.1PowerLossContinueEnglish. J'ai fait le Zoffset et lancer BLTouch et là il est sorti du plateau à gauche et la buse a écrasé le plateau...  J'ai lu tout un week end des trucs sur internet, j'ai flashé un autre firmware : BL probe out of the heatbedEnder-51.1.6XFBLTouchPowerLossContinueEnglish. Ce coup, ça marchait, mais il n'y avait pas beaucoup de point sur le plateau et la plupart sur la partie gauche du plateau. Bref, je n'étais pas satisfait, j'ai téléchargé Pronterface pour essayer les tutos de réglage que je voyais à propos du recentrage du BLTouch sur le plateau et G29 au final. Cela aurait trop facile, car les réglages ne se chargent pas sur mon imprimante. M500, M501 n'ont aucun effet. 

Je ne suis pas développeur, je pensais pouvoir passer par des solutions "utilisateur". Je ne trouve nulle part comment "enable l'EEPROM".

Je squatte la table à manger parce qu'à la cave ça caille et ma femme commence à me trouver lourd avec ma machine bruyante dont rien ne sort...

Des suggestions ? 

Lien à poster
Partager sur d’autres sites

Si tu change ton offset et la diminue, la buse est toujours écrasée ?

De mon coté je cherche a savoir si c'est possible de régler l'offset a 0.01 car il me propose que a 0.1 (je cherche a être le plus précis possible).
Autrement tu peu également vérifier la version de ton lb touch, si c'est bien la 3.1

(Et pour la solution de la machine bruyante, je suis passé sur la carte 4.2.7 (les moteurs ne font absolument plus aucun bruit c'est juste génial, il ne reste que les ventilateurs que tu peux remplacer par des noctua si besoins.)

Modifié (le) par boodinet
Lien à poster
Partager sur d’autres sites
Il y a 14 heures, Korzybski a dit :

Je ne trouve nulle part comment "enable l'EEPROM".

C'est une option qui pour fonctionner doit avoir été activée lors de la configuration du firmware (configuration.h de Marlin).

Quand elle n'est pas active, on peut «contourner» le problème en ajoutant les différentes commandes de réglages via des G-code dans la section «start_gcode» du trancheur.

Exemple:

Après avoir effectué la calibration des pas de l'extrudeur, tu utilises un M92 Enouvelle_valeur dans le start_gcode, ligne que tu mets évidemment avant celles qui demanderont une extrusion.

Exemple avec ma CR10 qui ne permet pas de «Store settings» (M500) :

Citation

; parametres du "Creawsome mod" inclus dans Cura v4.2.1 (specifiques Creality)

M201 X500.00 Y500.00 Z100.00 E5000.00 ;Setup machine max acceleration

M203 X500.00 Y500.00 Z10.00 E50.00 ;Setup machine max feedrate

M204 P500.00 R1000.00 T500.00 ;Setup Print/Retract/Travel acceleration

M205 X8.00 Y8.00 Z0.40 E5.00 ;Setup Jerk

M220 S100 ;Reset Feedrate

M221 S100 ;Reset Flowrate

 

; Parametres spécifiques de ma machine

; Estep extrudeur (Titan) et Z (un seul moteur mais accouplement

; des deux tiges filetées via courroie fermée et poulies de 60 dents)

M92 E419 Z1200

; Max feedrate Extrudeur (def creality=25, creawsome = 50)

M203 E70.00

; PID hotend

; Firmware: M301 P21.73 I1.54 D76.55

; Après un M303 S230 C8

M301 P23.68 I1.84 D76.05

; fin parametres spécifiques

 

; mode absolu sinon probleme lors du depot 1ere ligne (extrudeur recule!)

G90 ; axes

M82 ; extrudeur

 

; Reglages des temperatures pour eviter suintement

; pour la première couche, la variable Cura doit comporter à la fin _layer_0

; {material_bed_temperature} pour les couches

; {material_bed_temperature_layer_0} pour la première couche du plateau

; idem pour {material_print_temperature} et {material_print_temperature_layer_0}

M140 S{material_bed_temperature_layer_0} ; Chauffe du lit sans attendre (1ere couche)

M104 S160 ; Buse à 160C sans attendre

M190 S{material_bed_temperature_layer_0} ; Attente chauffage du lit première couche

 

G28 ;Home

 

🙂

Lien à poster
Partager sur d’autres sites

Merci Boodinet et fran6p, je ne me sens pas trop de bidouiller dans le code, parce que je n'y connais rien. Mais si vous pouvez m'indiquer des tutos d'apprentissage, je suis preneur. Je viens ici pour apprendre. 

Lien à poster
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez poster un message et vous inscrire plus tard. Si vous avez déjà un compte, connectez-vous afin de poster avec.

Invité
Répondre à ce sujet…

×   Vous avez copié du contenu avec formatage.   Supprimer le formatage

  Only 75 emoji are allowed.

×   Votre lien a été automatiquement intégré.   Afficher en tant que lien à la place

×   Le contenu sauvegardé a été restauré.   Effacer l'éditeur

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Créer...