Aller au contenu

Filament ABS

- autre - Arrêt moteur skr turbo 1. 4


Messages recommandés

Bonsoir à tous 

J'ai un nouveau problème avec ma skr turbo 1.4 (+ tmc2209) 

Sans rien avoir changer, elle se met à avoir un décalage. 

Je m'explique, pendant impression, je me suis aperçu d'un décalage de couche bien prononcé. 

J'arrête l'impression pour vérifie le réglage de tmc... 1000 pour chaque axe. 

Je relance une impression et la le homing se passe sans problème mais le autobed leveling déconne. Au lieu de palper mes 4 coins, il se fait à la moitié du plateau. J'arrête et je relance et la tous se passe bien. J'arrête et fait différents test et voilà ce qu'il se passe. 

Quand je me déplace en x, il arrive des fois que le déplacement s'arrête. Pour info j'ai une cordexy, alors le déplacement du x se fait avec 2 moteurs. 

J'ai vérifié la console et quand je demande x 250, la tête de déplace de 110 (exemple). 

Il n'y a pas de saut de pas car je n'entend pas de bruit venant des moteurs. On dirait que le carte se met en sécurité. 

 

Si quelqu'un a déjà eu ce phénomène,je suis à l'écoute

Merci de votre aide 

Lien à poster
Partager sur d’autres sites

salut 

c'est difficile de donner un diag , ta description est un peu confuse et manque de précision 

il faut procéder par élimination 

déjà est ce que ta carte est bien ventilée ?

si oui , est ce que les steppers sont eux aussi bien refroidis avec les radiateurs bien collés ?

après je dirais que tu peux essayer de mettre des steppers différents pour éliminer le doute des steppers 

est ce que les câbles qui relient les moteurs a la cm sont corrects , il existe différents types de câbles avec des brochages différents  

en dernier recours essaie de changer la carte skr 

cordialement

  Jean-Marie

Lien à poster
Partager sur d’autres sites

Merci pour ton retour. 

Oui je sais, c'est compliqué à expliquer. J'ai de gros soupçon sur la carte car si c'était un problème de drive ça ne couperait pas le déplacement du x. Un de deux moteur devrait continuer à tourner..

Bon demain je vais voir avec une autre carte 

Merci de ton aide 

Lien à poster
Partager sur d’autres sites

quand on a par exemple un décalage en x 

on cherche sur le x et ca limite les recherches 

mais dans ton cas on ne sait pas trop par quoi commencer 

il faut être méthodique et procéder par élimination c'est la meilleure solution 

en math quand tu as une équation a 3 inconnues , tu commences par éliminer une inconnue et ensuite tu as 2 inconnues et puis après une , c'est le même principe 

Lien à poster
Partager sur d’autres sites

salut

faudrait peut etre aussi regarder du coté du soft 

tu es en marlin 2 ?

tu utilises vstudio ?

essaie avec une config stable 

peut etre que tes paramètres sont inadaptés 

il faudrait revoir tes fichiers de config 

Lien à poster
Partager sur d’autres sites

je vais regarder

 

je passe sur la partie thermal settings et PID parceque a priori ca n'est pas la qu'est le probleme 

je passe aussi sur la partie endstops et homing parceque j'imagine que tes fins de course sont bien reglés et fonctionnent 

ensuite dans la rubrique mecanichal settings 

#define X_DRIVER_TYPE  TMC2209
#define Y_DRIVER_TYPE  TMC2209
#define Z_DRIVER_TYPE  TMC2209

ca normalement c'est bon si tes steppers sont bien des 2209 

tu peux aussi essayer en mettant // devant chaque , je sais que c'est pas logique mais quelquefois la logique ..

je pense que ton problème est surtout dans la rubrique - motion -

sur ta carte mère tu as réglé comment tes cavaliers paracerque je te conseille de faire un essai en normal et après tu devras changer la ligne suivante
voici la mienne 

 #define DEFAULT_AXIS_STEPS_PER_UNIT   { 80, 80, 400, 95 }

voici ma ligne max feedrate pour info 
#define DEFAULT_MAX_FEEDRATE          { 300, 300, 5, 25 }

 
y a aussi le paramètre accélération qui est très important 

voici le mien 
#define DEFAULT_MAX_ACCELERATION      { 300, 300, 100, 5000 }

je pense que déjà tu dois jouer sur ces trois lignes avant de voir autre chose 

il faut aussi faire des mesures pour être sur de l'échelle 
par exemple tu fais déplacer ton x de 100 et tu mesures avec une règle si tu as bien 100 
pareil pour Y et Z 

mais encore une fois remets tes cavaliers en mode normal et si ca fonctionne tu pourras essayer de passer en 1/2 puis en 1/4 mais n'oublie pas que c'est en mode full que tu as le meilleur couple 

voila en espérant que ca t'aidera 
de toutes façons c'est souvent laborieux mais tu vas y arriver 

cordialement
  Jean-Marie

Lien à poster
Partager sur d’autres sites

bah je n'ai pas de steppers TMC , moi j'ai des A4988 

sur la photo tu as la position des cavaliers 

avec les TMC je crois que le reglage se fait dans le fichier config 

je regarde et je te confirme

Capture d’écran (13).png

Lien à poster
Partager sur d’autres sites

voila le paragraphe 

c'est dans le fichier config-adv

---

//#define MICROSTEP1 LOW,LOW,LOW
//#define MICROSTEP2 HIGH,LOW,LOW
//#define MICROSTEP4 LOW,HIGH,LOW
//#define MICROSTEP8 HIGH,HIGH,LOW
//#define MICROSTEP16 LOW,LOW,HIGH
//#define MICROSTEP32 HIGH,LOW,HIGH

// Microstep setting (Only functional when stepper driver microstep pins are connected to MCU.
#define MICROSTEP_MODES {1,1,1,1,1,1} // [1,2,4,8,16]

/**
---

donc là je lui demande de regler en full step - cad 1/1 =1 

en fait c'est comme si on changeait les cavaliers mais ca se fait par logiciel 

par contre la question c'est comment on doit paramètre la carte pour qu'elle soit gérée par le fichier config et comme je n'ai pas pratiqué les TMC je ne sais pas 

je pense qu'il faut juste mettre le jumper du bas mais je n'en suis pas sur 

comme je n'ai pas pratiqué cette partie je ne peux pas être plus précis 

si quelqu'un a pratiqué le réglage des TMC par ce biais qu'il se manifeste , ca m'intéresse aussi paracerque j'y viendrai certainement même si pour le moment mes A4988 sont assez fiables 

Modifié (le) par heriat
Lien à poster
Partager sur d’autres sites

Alors je viens d'essayer avec tes réglages, je le même phénomène. Je viens même d'essais avec une vielle mks gen avec le nouveau marlin et je le même problème. Je vais essayer de reprendre pro mon marlin, j'ai peut être copié une erreur 

Lien à poster
Partager sur d’autres sites

est ce que tu as controlé les cables qui relient la CM aux moteurs ?

par exemple le cable du moteur X

Lien à poster
Partager sur d’autres sites

oui alors j'avais un jeu de câble et j'ai testé ...même probleme

J'ai contrôlé avec la console les endstops également et tout va bien 

mais je me suis dis qu'en ayant tout changé sauf l'alimentation et les endstop , le problème devrait un peu varié mais même pas.

alors j'ai directement relier le endstop x au multimetre et la il s'est mis a biper pendant le déplacement .

donc il est peut être mort , je vais le changer pour voir 

je re pour donner des nouvelles

Lien à poster
Partager sur d’autres sites

normalement le endstop du xmin ne doit plus intervenir une fois l'impression lancée 

ce que je veux dire c'est que lorsque tu as une impression en cours , si tu appuies par inadvertance sur un endstop ca ne doit rien faire ou alors ca peut mettre la machine en pause selon les cas 

donc peut être que ta machine détecte des contacts sur le end stop x et ca la perturbe c'est possible 

il y a des paramètres qui font office de (anti-rebonds , leur but est de ne pas tenir compte de petites impulsions 

je crois que c'est les noise filter mais je n'y ait pas touché 

essaie de remplacer ton endstop 

Lien à poster
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez poster un message et vous inscrire plus tard. Si vous avez déjà un compte, connectez-vous afin de poster avec.

Invité
Répondre à ce sujet…

×   Vous avez copié du contenu avec formatage.   Supprimer le formatage

  Only 75 emoji are allowed.

×   Votre lien a été automatiquement intégré.   Afficher en tant que lien à la place

×   Le contenu sauvegardé a été restauré.   Effacer l'éditeur

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Créer...