Aller au contenu

Filament ABS

Extruder Moteur blocage file ne coule pas


Messages recommandés

Bonjour à tous, je viens désespérément ici chercher de l'aide car je lache prise à ne pas trouver réponse à mon problème.

Je développe le tout et m'explique:

J'utilise
arduino Mega
ramps 1.4
micro steps A4988 1/16.
Moteur Nema 17 1.8°.

Extrudeur MK8 0.4 comme celui-ci MK8 Extruder Nozzle

Fiament ABS 1.75

bref tout les éléments qui se rapporte à une imprimante Prusa I3

Programme : Marlin dernière version trouver sur la toile. Printrun/Repetier et Slicer Feb2015


Mon problème : Tout fonctionne à merveille, les axes bouges correctement, bonne distance, l'impression se lance après chauffe de buse "230" et lit "90" mais au moment de faire couler le filament bim problème, 
le moteur clap, alors comment expliquer cela, il avance d'un cran et recule d'un cran et cela non stop, donc il fait du sur place, en gros le filament ne peux donc pas avancer, j'ai regarder sur internet et beaucoup de forum à propos de cela mais rien n'a fonctionner : 

par exemple mettre cela en true étant donné que si j'ai bien compris mon extruder est un Extrudeur à entrainement direct: 
 

#define INVERT_E0_DIR true   // for direct drive extruder v9 set to true, for geared extruder set to false
#define INVERT_E1_DIR true    // for direct drive extruder v9 set to true, for geared extruder set to false


calculer et changer les valeur suivante : 
 

//// MOVEMENT SETTINGS
#define NUM_AXIS 4 // The axis order in all axis related arrays is X, Y, Z, E
#define HOMING_FEEDRATE {2000, 2000, 150, 0}  // set the homing speeds (mm/min)

// default settings

#define DEFAULT_AXIS_STEPS_PER_UNIT   {100, 100, 4000, 100}  //550 default steps per unit for Ultimaker
#define DEFAULT_MAX_FEEDRATE          {500, 500, 3, 25}    //25 (mm/sec)
#define DEFAULT_MAX_ACCELERATION      {3000,3000,100,1000}    // X, Y, Z, E maximum start speed for accelerated moves. E default values are good for Skeinforge 40+, for older versions raise them a lot.

#define DEFAULT_ACCELERATION          2000    // X, Y, Z and E max acceleration in mm/s^2 for printing moves
#define DEFAULT_RETRACT_ACCELERATION  2000   // X, Y, Z and E max acceleration in mm/s^2 for retracts


J'ai aussi revu mes pololu par rapport aux voltage et pour l'extruder je suis entre 0.90V et 1.1V : exactement à 1V 

J'ai aussi voulu tester le moteur afin de savoir si le souci c'était lui, j'ai donc brancher l'extrudeur sur X et faire déplacement manuelle et il tourne s'en problème, idem teste buse savoir si c'était boucher ou non etc….

Je me demande si le souci ne viendrais pas de la config marlin et du Axis steps ou du Max feedrate mais la étant débutant je m'y perd un peu malgrès tout les calcules fait et refait, même avec l'utilisation de print calculator.

Donc voilà pourquoi je viens vous voir et me faire conseiller afin de résoudre se souci et faire enfin ma premiere impression :p.

Merci pour votre aide en esperant que j'ai été le plus clair possible.


PS : j'ai tester de pousser à la main le file et il coule, j'ai retirer le file et tester le moteur à vide et pareil il patine "un cran en bas un cran en haut et ça non stop" :

Lien vers le commentaire
Partager sur d’autres sites

@aniema Tu as testé ce moteur sur un autre emplacement mais est ce que tu as testé un autre moteur branché à son emplacement à lui ?
Et intervertir des polulus en gardant les branchements corrects ?

Je ne m'y connais pas plus que toi mais ça pourrait affiner le diagnostique ou donner d'autres pistes de recherche ^_^

Modifié (le) par Silverglade
Lien vers le commentaire
Partager sur d’autres sites

Je vais essaye en rentrant ce soir de mettre le moteur de l'axe X a la place de l'extrudeur !

j'avais essayé deja d'inverser poir savoir si le moteur extruder fonctionner je l'avais mis sur X est il tournee correctement 

merci de vos reponse je teste et je reviens tres rapidement vers vous 

Lien vers le commentaire
Partager sur d’autres sites

Je vais essaye en rentrant ce soir de mettre le moteur de l'axe X a la place de l'extrudeur !

j'avais essayé deja d'inverser poir savoir si le moteur extruder fonctionner je l'avais mis sur X est il tournee correctement 

merci de vos reponse je teste et je reviens tres rapidement vers vous 

Lien vers le commentaire
Partager sur d’autres sites

des le debut, en sommes j'allume l'imprimante, la buse chauffe, le lit aussi une fois temperature desirer atteinte la machine demarre l'impression et fait le chemin demander, l'extruder lui demarre une fois l'impression qui debute mais niveau moteur clap, comme une trotteuse de montre qui n'a plus de pile lol 

Modifié (le) par aniema
Lien vers le commentaire
Partager sur d’autres sites

Me revoilà, désolé pour les mots transformés, c'est la correction auto du téléphone :S … 

 

Donc j'ai inversé les moteurs Extruder et X donc l'extruder sur X tourne correctement, par contre le X en extruder ne bouge pas du tout. Pour te répondre niphore, le file coule correctement quand je pousse moi même le file dans la buse. Je me demande si ce n'est pas un mauvais parametrage de programme ou de marlin lui même mais la je ne sais pas du tout par quoi commencer :S 

Lien vers le commentaire
Partager sur d’autres sites

Pour mes câblages, chaque moteur est identique niveau couleurs et sens, le moteur de l'extruder je n'ai pas fait les cosses, elle était déjà relié dans le sens identique de mes autres moteurs, donc soit je ne comprend pas, dite en moi plus de comment faire et le pourquoi ? je ne comprend pas bien pourquoi 1 moteur devrais avoir ses cables totalement inversé par rapport au 3 autres… surtout niveau branchement de la ramp

Merci !!

 

PS : Dans ce cas cela voudrait t'il dire que tout mes moteurs ne sont pas correctement brancher ? pour chaque moteur en partant du coté alimentation j'ai : Noir Vert Rouge Bleu et cela pour les 4 "peu etre un ajout inutile de le dire mais si cela peu m'éclairé alors c'est bonne chose" Si le sens des files n'est pas bon et qu'il devrait être par exemple Rouge bleu vert noir, pourquoi mes autres moteurs tournerais t'il ou fonctionnerais t'il correctement pour le X Y et les Z ? Mon but n'est pas d'avoir une solutions toute cuite même si ça aiderais a faire fonctionner mais j'aimerais comprendre aussi, j'ai construit cette imprimante 3D de A à Z s'en acheter de kit pour justement apprendre et comprendre et la je suis face à une colle que je voudrais surtout comprendre :) 

Modifié (le) par aniema
Lien vers le commentaire
Partager sur d’autres sites

Alors j'ai tester la polarite du moteur et tout est bon, dailleur si je le branche en X il tourne. 

Je vais donc tester l'option de changer le pololu comme dit et tester cela si c'est pas sa je ne vois que le programme mais je vois pas ou

Lien vers le commentaire
Partager sur d’autres sites

Ayé le moteur tourne xD yupii bon bah a voir c'était du au pololu, je ne sais pour quel raison, je l'ai changer "heureusement j'en ai 2 d'avance" et quand je lui dit 1mm il tourne s'en clap, alors serte il ne fait pas 1 mm est il est très lent mais la je pense que c'est du au parametre marlin ? une idée de comment le regler ? calcule mm/s ?

 

Merci en tout cas de votre aide , j'espere que sa va duré sinon je reviens ici même mdr

Lien vers le commentaire
Partager sur d’autres sites

Sur un extruder mk8 j'ai fait 200*16/7*3,1415 = 145 mais je ne sais pas si c'est juste en tout cas cela n'a pas l'air je vais prendre mon temps sur sa poir mieux comprendre c'est le seul ou j'ai du mal a bien comprendre le calcule

Lien vers le commentaire
Partager sur d’autres sites

Sur un extruder mk8 j'ai fait 200*16/7*3,1415 = 145 mais je ne sais pas si c'est juste en tout cas cela n'a pas l'air je vais prendre mon temps sur sa poir mieux comprendre c'est le seul ou j'ai du mal a bien comprendre le calcule

Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...