Aller au contenu

Filament ABS

[RÉSOLU] Mettre à jour Marlin sur ENDER 5 PRO


Messages recommandés

Bonjour à tous

 

Voila je viens vers vous pour m'éviter une fois de plus de faire des bétises.

Je possède depuis 3 mois une "Ender 5 Pro" et j'ai voulu mettre à jour marlin, mais suite à une mauvaise manip j'aurais apparemment virer le bootloader, et sans trouver de solution à mon problème j'ai depuis racheter une autre carte mère (4.2.2) et plus récemment j'ai acheter un BLTOUCH original mais j'ai cru comprendre qu'il me fallait mettre à jour marlin qui est en 1.0.1

Donc si quelqu'un pouvait m'expliquer les étapes à suivre, et quel firmware utiliser, car apparament on peu soit prendre ceux de marlin ou ceux de TH3D, mais ya t'il une différence entre les 2 ? dois je compiler le firmware moi meme ? bref je comprend pas grand chose à tout ce foutoir malgré les nombreuses vidéos et tuto que j'ai pu voir j'ai toujours l'impression que DD contredit GG lol, donc avec sa j'ai toujours peur de me lancer et de faire des erreurs.

 

Merci d'avance 😉

 

zalman91

Lien à poster
Partager sur d’autres sites
Posté(e) (modifié)

Merci beaucoup pour cette réponse rapide ^^ je testerais sa demain, j'ai encore certaines choses à finir avant de m'occuper du BLtouch.

Mais j'ai absolument rien à faire ? je place tout simplement le .bin sur ma SD que je place ensuite dans l'imprimante et je la démarre ?

Modifié (le) par zalman91
Lien à poster
Partager sur d’autres sites
  • 2 weeks later...
Le 06/03/2021 at 16:22, SevenSam a dit :

Quand tu parle de l'adaptateur, tu parle du petit circuit qui ce branche entre la carte mère et l'écran LCD ? (c'est ce que j'ai fais)

Bon sinon, j'ai enfin trouver le temps d'avancer sur mon imprimante ^^

Alors j'ai installer le BLtouch puis j'ai fais la MAJ de marlin sans problème, puis j'ai voulu faire un Z-Home et mon plateau est rester bloquer sur la buse avec le moteur qui tournait (tactactactac...), donc j'ai éteind l'imprimante pour annuler la commande.

J'imagine que la MAJ de marlin à réinitialiser les reglages et donc le Z-offset est est revenu au reglage par default ? (je l'avais dérégler pour installer un plateau en verre)

Merci d'avance.

Lien à poster
Partager sur d’autres sites

oui c'est ca le petit circuit.

 

prochaine fois ne laisse pas descendre ta buse jusqu'au plateau, touche le bltouch(faire rentré la tige), s'il ne s'arrête pas coupe la machine et donc c'est que soit tu a mal branché ton bltouch(inversion de fil) ou tu utilise le mauvais firmware.

Car selon le firmware il utilise les pins du Z end stop(si tu utilise la version avec l'adaptateur ou si tu a brancher directement toi même le noir et blanc a la place du Z end stop, soit le port du Bltouch, celui a cinq pin et de memoire Brun rouge orange noir blanc(valable avec l'original Antclabs ou 3dtouch)

dans les menu il y a la possibilité de faire un test du bltouch pour voir s'il fonctionne correctement

Lien à poster
Partager sur d’autres sites

Alors j'ai fais la MAJ avec "V4.2.2-Ender-5-Pro-32bit-Mainboard-Marlin2.0.1-V1.3.1-BLTouch" puis j'ai brancher le circuit (l'adaptateur) entre la prise de la carte mère et la prise de l'écran, ensuite j'ai brancher les fils brun, rouge et jaune du BL touch sur l'adaptateur puis j'ai brancher les fils noir et blanc sur le Z end stop.

Demain je posterais une photo, sa sera probablement plus parlant que mon explication lol ^^

Lien à poster
Partager sur d’autres sites

Bon finalement je posterais pas de photo, je pense qu'il s'agit plus d'une erreur de manipulation que d'un problème lié a l'imprimante elle même.

Alors je pense avoir réussit mon installation même si je suis pas sure d'avoir fait comme il faut pour le réglage du BLTOUCH.

Après 50 essaies lol, j'ai finis par faire un "G28" puis j'ai deplacer mon axe Z jusqu'a 0 ensuite je suis aller dans "Probe Z offset" puis j'ai fais le reglage avec une feuille (valeur actuel : 350) , j'ai ensuite fais un G29 suivit d'un M500.

1ère impression satisfaisante même si je suis pas convaincu par le refroidissement du filament (pas d'amélioration avec mon nouveau support et nouveau ventilateur noctua), je pense essayer un sunon toujours en 12v mais avec un meilleur débit.

Par contre quand je rentre M500 dans le terminal il me renvoie :

Citation

 

Send: M500

Recv: echo:No EEPROM.

Recv: ok

 

Est ce normal ?

Pour rappel j'ai une "ender 5 pro 4.2.2" avec "ender 5 pro marlin 32bits 2.0.1 v1.3.1 BLTOUCH"

Lien à poster
Partager sur d’autres sites
Posté(e) (modifié)

Oui je confirme bien qu'il s'agit du même problème, en la démarrant tout à l'heure je me suis aperçu que les reglages du probe Z offset était à 0, mais comment ce fait il que le systeme est capable de garder en mémoire quand je fesait "SET OFFSET" et la il en serait pas capable 😕

Etant donner que j'utilise octoprint il ne serait pas possible d'utiliser la carte SD comme mémoire ? sinon je vais devoir crier à l'aide 😅 car je comprend pas grand chose à ces histoire de compilation bien que j'ai quelques compilation de hip hop 😂

Modifié (le) par zalman91
Lien à poster
Partager sur d’autres sites

Est-ce que tu peux nous dire quelle lettre est écrite au feutre sur le lecteur de carte µSD? tu as le choix entre A,B,C,E et H (voir ici).

il y a 22 minutes, zalman91 a dit :

il ne serait pas possible d'utiliser la carte SD comme mémoire ?

C'est pas vraiment fait pour ça, déjà qu'elle sert à la sauvegarde en cas de coupure d'alimentation. Et comme l'eeprom est dans le microcontrôleur, ce sera plus rapide et pratique.

Modifié (le) par remibora
  • J'aime 1
Lien à poster
Partager sur d’autres sites

Je pourrais pas regarder sa ce soir, j'ai un print en cours, mais je crois que sa doit etre A, j'avais déja chercher et il me semble que c'est "TMC2208" mais je confirmerais demain pour etre sure.

il y a 4 minutes, remibora a dit :

C'est pas vraiment fait pour ça, déjà quelle sert à la sauvegarde en cas de coupure d'alimentation. Et comme l'eeprom est dans le microcontrôleur, ce sera plus rapide et pratique.

Ce qui sous entend que je devrais laisser la SD dans l'imprimante ? depuis que j'ai flasher le firmware j'ai retirer la SD.

Lien à poster
Partager sur d’autres sites

Si tu confirmes que c'est bien la lettre A, tu pourras essayer ce firmware. J'ai activé la reprise après coupure d'alimentation, ce qui nécessite de laisser une carte SD dans le lecteur. Il est fort probable que Creality ne l'ait pas fait dans leur firmware🤔...

Au début, il faut y aller tout doux = ne pas faire de prise d'origine (POM = Home/AutoHome):

1- tester le sens de déplacement positif (pas négatif puisque la POM n'est pas faite)

2- tester le BLtouch (voir ce message, étape 1)

3- enchainer avec le décalage du BLtouch si le point 2 est OK

4- mettre à jour les valeurs spécifiques de la machine (pas/mm pour chaque moteur,...). Comme j'ai activé le PID pour le plateau, il faudra le régler (voir la fin de ce message) et celui de la buse pendant que tu y es 😉.

 

firmware_Ender5ProV4.2.2_BLTouch.bin

Modifié (le) par remibora
  • J'aime 1
Lien à poster
Partager sur d’autres sites
Posté(e) (modifié)

ouffff, à force de tout lire (tuto...) je commence à comprendre certaine chose ^^ merci pour ces infos et je reviendrais demain pour confirmer la lettre sur lecteur SD 😉

 

ps : j'ai vu dernièrement que passer d'un firmware à un autre ayant la même version de marlin peu faire échoué le flash, dans ce cas ci il me faut éditer le .bin avec un éditeur de texte et changer la version manuellement si je dis pas de bétise ?

Modifié (le) par zalman91
Lien à poster
Partager sur d’autres sites
il y a 12 minutes, zalman91 a dit :

si je dis pas de bétise ?

Ben, comment dire, je veux pas te vexer, alors je vais te répondre que c'est pas tout à fait vrai 🤣... la seule contrainte qu'il y a, c'est que tu ne peux pas flasher 2 firmwares à la suite lorsqu'ils ont le même nom. C'est une sécurité pour ne pas flasher à chaque démarrage si on a oublié la carte dans le lecteur avec le firmware dessus.

PS: par contre, après le flash, il faudra effacer l'eeprom (normalement tu auras un message ou alors tu envoies un M502) suivi d'un enregistrement (via le menu ou M500).

Modifié (le) par remibora
Lien à poster
Partager sur d’autres sites

lol pas de problème je suis pas vexer je veu juste apprendre et pas faire de bétise, et puis j'ai bien fais de demander visiblement j'ai encore appris quelque chose 😁

merci

Lien à poster
Partager sur d’autres sites

Bonjour

Alors je confirme qu'il s'agit bien de la lettre A (TMC2208), je m'occuperais de sa demain à default d'avoir le temps ce soir ^^ et sa me laissera plus de temps pour déchiffrer 2/3 choses dans le tuto 😅

Lien à poster
Partager sur d’autres sites

aie ! sa commence bien lol

Désoler pour mon ignorance mais je bloque déja 🙄

Citation

Tu envoies M43 S et lorsque tu vois ce message "Please trigger probe within 30 sec" : tu as 30s pour appuyer légèrement sur la touche qui doit se rétracter automatiquement.

De quel touche s'agit il ? j'ai bien fais une petite traduction de "Please trigger probe within 30 sec" (non je suis pas bilingue ^^)qui ce traduit par "Veuillez déclencher la sonde dans les 30 secondes" donc comme tu parle de touche qui ce retracte j'ai penser justement a la petite tige du BLTOUCH et que je devrait donc appuyé dessus pour qu'elle ce retracte mais elle descend pas donc j'en déduit que c'est pas ce qu'il faut faire lol

Lien à poster
Partager sur d’autres sites

Salut,

il y a une heure, zalman91 a dit :

mais elle descend pas

Ça, c'était pas prévu 😖... pour le BLTouch, tu n'utilises pas le connecteur spécifique à 5 broches sur la carte-mère?

Modifié (le) par remibora
Lien à poster
Partager sur d’autres sites
Posté(e) (modifié)

Ha alors je suis pas si bête lol

Non j'ai fais l'autre méthode avec l'adaptateur

Le 16/03/2021 at 23:00, zalman91 a dit :

Alors j'ai fais la MAJ avec "V4.2.2-Ender-5-Pro-32bit-Mainboard-Marlin2.0.1-V1.3.1-BLTouch" puis j'ai brancher le circuit (l'adaptateur) entre la prise de la carte mère et la prise de l'écran, ensuite j'ai brancher les fils brun, rouge et jaune du BL touch sur l'adaptateur puis j'ai brancher les fils noir et blanc sur le Z end stop.

Modifié (le) par zalman91
Lien à poster
Partager sur d’autres sites

Et tu veux pas changer? Y parait qu' y'a que les imbéciles qui changent pas d'avis 🤣!

Plus sérieusement, tu récupèrerais le buzzer en le câblant sur le connecteur 5 broches (comme ici). Au pire, tu peux laisser le connecteur 2 fils (blanc et noir) sur le Zmin. Dans ce cas, je te fournirai le firmware qui correspond.

  • J'aime 1
Lien à poster
Partager sur d’autres sites

Hooo le cochon qui a cabler sa avec la prise 2PIN direct dans le slot 😂

Non sa me dérange pas de faire ce branchement mais j'avais cru comprendre qu'il me fallait brancher l'adaptateur avec le firmware qu'ont m'avait conseiller plus haut dans ce meme post.

Bon je reviendrais probablement plus tard, j'ai pas finis de vous embêter 😛

Merci encore remibora pour tous tes conseils.... 😉

Lien à poster
Partager sur d’autres sites
Posté(e) (modifié)

Bon nouveau firmware installer, BLTOUCH initialiser et configurer (correctement je crois), mise à jour des PID de la buse et du plateau OK.

Et donc la j'ai imprimer le cube pour régler les pas des axes mais je me retrouve avec un decollement sur 3 des 4 angles, donc j'imagine qu'il me suffit de corriger le nivellement mais je me demande si vaut mieux que je continue de regler les pas des axes ou bien résoudre avant mon nivellement ?


Photos :

(j'ai un plateau en verre de la marque creality)

Citation

 

Sans titre-1 copie.jpg

Sans titre-2 copie.jpg

Sans titre-3 copie.jpg

 

Modifié (le) par zalman91
Lien à poster
Partager sur d’autres sites

Salut,

il y a 54 minutes, zalman91 a dit :

je me demande si vaut mieux que je continue de regler les pas des axes ou bien résoudre avant mon nivellement ?

Les 2 mon capitaine 🤣!  pour le pas des axes, tu peux appliquer ce tuto, en imprimant tes pièces avec une bordure pour éviter le warping.

Pour l'adhérence, je ne te l'ai pas dit, mais en "double-cliquant" sur le bouton du pupitre, tu accèdes directement au réglage Z de la buse (Zoffset du BLtouch), ce qui te permet de bien écraser la couche initiale (voir cette vidéo pour une démonstration).

Pour appliquer le nivellement, il ne faut pas oublier de modifier le GCode de démarrage (G29 ou M420 S voire M420 S1 Z2 par exemple).

Je te joints un nouveau firmware où j'ai ajouté le linear advanced (voir cette vidéo).

firmware_Ender5ProV4.2.2_BLTouchZminLAdv.bin

Lien à poster
Partager sur d’autres sites
Posté(e) (modifié)

Ok, donc faudra que je recommence tout.

Petite question :

M420 S1 Z2, si je capte bien M420 désigne le BLTOUCH, Z2 désigne le réglage du Z offset mais S sa désigne quoi ?

ps : j'ai mal au crane c'est normal doc ? 😂

Modifié (le) par zalman91
Lien à poster
Partager sur d’autres sites
  • fran6p changed the title to [RÉSOLU] Mettre à jour Marlin sur ENDER 5 PRO

Rejoindre la conversation

Vous pouvez poster un message et vous inscrire plus tard. Si vous avez déjà un compte, connectez-vous afin de poster avec.

Invité
Répondre à ce sujet…

×   Vous avez copié du contenu avec formatage.   Supprimer le formatage

  Only 75 emoji are allowed.

×   Votre lien a été automatiquement intégré.   Afficher en tant que lien à la place

×   Le contenu sauvegardé a été restauré.   Effacer l'éditeur

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Créer...