Aller au contenu

Filament ABS

Installation BLTouch sur CREALITY CR-10 carte 8bit


Messages recommandés

Bonjour a tous.

j'ai une petite question

J'essaye depuis 2 jours d'installer  ce BLTOUCH si :

https://www.amazon.fr/gp/product/B082VSB9VP/ref=ppx_yo_dt_b_asin_title_o02_s00?ie=UTF8&th=1

sur ma Creality CR10 carte version 8 bit

Tout va pour le mieux, même si j'ai galéré au possible pour trouver progisp.exe

j'ai upgradé le firmware de l'imprimante avec cette version ci : 

CR-10 1.1.5 silent mainboard firmware(8bit).zip

Trouvé sur le site de Creality

Le montage ok, l'installation des cables et carte mere ok

ca s'allume, dans le menu About Printer, ca affiche

               Marlin

           Creality 3D

                1.1.9

Mais apres ..... ca devient nettement moins clair ......

je ne comprend pas ce qu'il faut faire

j'ai fais un auto home comme il est demandé, le plateau revient en x=0, y=0, le plateau descend mais butte contre la plaque de maintien du capteur Z et un méchant bruit de claquage survient (logique)

dans la doc, on me dit de faire un prepare / move axis / move Z / 0.1 mm /

et de le mettre à -002.1 mais je ne peux pas descendre en dessous de 0 ??????

Apres il faut aller dans control / Motion / Zoffset => mais ca n'existe pas dans le menu, j'ai

     - Velocity

     - Accélération

     - Jerk

     - Steps/mm

 

Enfin pige rien, si une âme charitable veux bien m'aider avant que l'imprimante de se fasse enterré dans le jardin, ca serait cool 🙂 🙂🙂 

 

Merci d'avance et bonne fin de dimanche

Lien à poster
Partager sur d’autres sites

Salut,

Tu peux faire toutes ces manip via USB avec Pronterface par exemple. Mais avant, il faudrait tester le fonctionnement du BLTouch comme ceci:

1- touche rentrée la led est rouge fixe (si elle clignote, c'est qu'il y a un défaut)
2- tu sors la touche M280 P0 S10
3- la led doit être bleue
4- tu tapes M119 pour voir l'état des fins de course.
5- tu enfonces la touche avec le doigt (normalement, la led passe rouge ou s'éteint)
6- tu retapes M119 (l'état du fin de course Zmin a dû changer)
7- tu rentres la touche M280 P0 S90

pour le réglage du décalage du BLtouch:
1. Faire chauffer la buse et le plateau aux températures d'utilisation
2. Effectuer la mise à l'origine des axes de l'imprimante via G28 puis charger les valeurs de l'eeprom M501
3. M851 Z0 - Initialiser le décalage en Z à 0 (remise à 0 du Zoffset s'il y en avait un)
4. M500 - Stocker ce réglage en EEPROM
5. M501 - Récupérer les paramètres de l'EEPROM pour les rendre actifs
6. M503 - Afficher les paramètres en cours pour vérifier qu'ils ont bien été pris en compte
7. G28 Z - Mettre à l'origine l'axe Z
8. G1 F60 Z0 - Déplacer la buse au 0 Z
9. M211 S0 - Désactiver les contacteurs de fin de course (pour pouvoir descendre sous le 0)
10. Descendre doucement en envoyant: G0 Z-z.zz jusqu'à frotter sur la feuille de papier (ou la cale utilisée)
11. M851 Xx.xx Yy.yy Zz.zz (x.xx et y.yy étant les décalages de ton BLTouch / buse, z.zz étant le décalage en Z calculé au point 10 (valeur négative))
si ton BLTouch est à gauche, avancé par rapport à ta buse x.xx et y.yy sont négatifs. A l'inverse, si ton BLTouch est à droite, reculé par rapport à ta buse x.xx et y.yy sont positifs (pas de signe)
12. M211 S1 - Réactiver les limites des contacteurs de fin de course
13. M500 - Sauvegarder ce réglages en EEPROM
14. M501 - Récupérer les paramètres de l'EEPROM pour les rendre actifs
15. M503 -Vérifier une dernière fois que tout a bien été pris en compte

Pour appliquer la correction, il faudra modifier le GCode de démarrage dans le logiciel de tranchage (CURA,...). Tu as 2 solutions:
1- palper ton plateau à chaque début d'impression (long et probablement inutile): après le G28 de ton GCode de démarrage tu tapes G29
2- tu palpes ton plateau et tu enregistres le résultat (préférable et à refaire en cas de nivellement suspect): avant d'imprimer, tu envoies: G28 puis G29. Tu sauvegardes le nivellement avec la commande M500. Dans le Gcode de démarrage, après la ligne G28, tu tapes M420 S1. Si tu veux que le nivellement s'estompe après 1mm de haut, tu tapes M420 S1 Z1

Pour envoyer et recevoir des informations entre l'ordinateur et l'imprimante, tu peux installer le logiciel Pronterface disponible ici. Voici une vue qui décrit rapidement le fonctionnement: tu choisis le port (autre que 1), la vitesse sera de 115200 et tu cliques sur le bouton Connect (juste à droite de la vitesse de communication)

Citation

Pronterface.png.79416f9852616258c3b78c89b4914cea.png

Dérouler  
Lien à poster
Partager sur d’autres sites
Il y a 13 heures, Idealnight a dit :

Attention si tu as mis le firmware pour carte mère silencieuse 1.1.5 si la tienne c'est une 1.1.4 ca va pas trop le faire je pense 😉 

Question bête .... c'est marqué sur la carte mère ?

je vais réouvrir l'UC pour voir

 

Il y a 14 heures, remibora a dit :

Salut,

Tu peux faire toutes ces manip via USB avec Pronterface par exemple. Mais avant, il faudrait tester le fonctionnement du BLTouch comme ceci:

.....

Super merci beaucoup

je vais tester cela ....

pourquoi c'est jamais simple 🙂🙂🙂 

je vais recup Pronterface pour voir ca 🙂

merci beaucoup

Lien à poster
Partager sur d’autres sites

Il me semble que le seul risque c'est que le sens de déplacement des moteurs soient inversés puisque la différence entre les 2 cartes, c'est les drivers de moteur. Si tu as déjà bougé dans le bon sens les axes avec les menus de l'écran, alors tout devrait bien aller.

PS: les modérateurs apprécient moyennement les multi-posts (commentaires consécutifs de la même personne). Tu peux modifier ton commentaire pendant 12h en cliquant sur l'icone "..." en haut à droite puis sur Editer.

Modifié (le) par remibora
Lien à poster
Partager sur d’autres sites

@Kulgran

Quelle est la carte mère de ta CR10 (modèle inscrit sur le PCB de celle-ci) ? Comment as-tu connecté le BLT sur celle-ci ? Quelle documentation as-tu suivi ?

Beaucoup de questions, peu de réponses 😞

Quelques photos de ton montage serait un gros plus.

PS: si c'est la  carte d'origine, le processeur étant un Atmega 1284p, sa mémoire est faible et nécessitera des compromis pour le firmware (disparition de quelques options du menu pour que ça tienne (au chausse-pieds).

🙂

Lien à poster
Partager sur d’autres sites

Hello

Alors j'ai re ouvert mon boitier, mais je n'ai trouvé aucune information qui m'indique si c'est une 1.1.4 ou une 1.1.5

Voici la doc et le schema de montage que j'ai suivi

https://ibb.co/Lx8JkFZ

https://ibb.co/X7YGsyK

https://ibb.co/2MTrc71

https://ibb.co/6mvJFLM

Apres, si il faut changer de carte mère pour que ça marche mieux, pas de soucis, faut juste me dire le modèle qu'il est préférable de prendre (du moment qu'il y est pas de soudure)

Lien à poster
Partager sur d’autres sites
Il y a 1 heure, Kulgran a dit :

mais je n'ai trouvé aucune information qui m'indique si c'est une 1.1.4 ou une 1.1.5

Une photo ?

C'est bien une CR10 et pas une CR10S ? La CR10 pouvait suivant sa date de fabrication être équipée de trois séries de cartes (celle de ma CR10 est la plus ancienne, le PCB est noir, il y a un cavalier à déplacer sur la carte pour passer en mode 5V ou USB et il me semble qu'aucune sérigraphie n'indiquait le modèle): v1.1.0/1 , v1.1.2, v1.1.3 (PCB vert pour ces deux dernières):

cr10-orginelle-pcb-noir.jpg.6857c22488118df4cb5c474b856ea431.jpg  cr10-orginelle-pcb-vert.jpg.679cf51dbaf50342007d4a6b8641e916.jpg  v1.1.2.jpg.e9a67951a0ee8767a2e21e10cdd1c284.jpg

V1.1.0                                                                    V1.1.1                                                                       V1.1.2

Aucune de ces cartes ne possède de chargeur de démarrage (bootloader), pour flasher, c'est ce que tu as fait, il faut utiliser la clé USBASP connectée sur l'emplacement ICSP (6 broches). Tu as mis le «dérivateur» écran dans la prise écran et l'écran branché ensuite dessus. Le câble avec deux fils (noir / blanc) est bien connecté sur l'emplacement détecteur fin de course du Z ?

Normalement ce dernier câble est muni d'un détrompeur mais parfois les deux fils sont inversés. Avant d'utiliser le «dérivateur» écran, on coupait un câble de la nappe écran (signal 27) et on procédait au branchement comme ci-dessous (ne tient pas compte de la partie connexion du servo BLT (câble avec trois fils (brun, jaune, rouge)), vérifie la connexion sur le Zendstop :

558194248_BLT-CR10-CM1.1.x-sans-module-drivation-cran.jpg.0c6cab64d7bcf0bce70679138029e5b1.jpg

🙂

Lien à poster
Partager sur d’autres sites

La mienne date elle aussi (juin 2017), elle est toujours équipée de sa vieille carte «sasfépu» (Melzi, PCB noir) et son Marlin antédiluvien (v1.0) ET elle fonctionne toujours (il faudrait tout de même que je remplace le ventilateur du boitier qui extrait l'air car il fait un bruit terrible).

Le firmware que tu as récupéré n'est pas adapté à ta carte, il vaudrait mieux essayer l'un des deux suivants (en fonction de la version de ton BLT) :

1981151685_CR-10FirmwareFiles-Creality3DPrintingResourcesForum.thumb.jpg.8e59dfb894cf27a35c2436972066cc35.jpg

🙂

Modifié (le) par fran6p
Lien à poster
Partager sur d’autres sites

Hello

Pareil que toi, la mienne date du mois d’août 2017

 

Moi qui pensais que ça allait être simple 🙂🙂🙂 

pour le moment je suis avec Remibora qui m'aide beaucoup en mp sur mon problème

 

mais apres on ne peut pas changer de carte mère pour que ce soit plus simple ?

ou bien l'imprimante est trop ancienne ?

Lien à poster
Partager sur d’autres sites
Il y a 8 heures, Kulgran a dit :

mais apres on ne peut pas changer de carte mère pour que ce soit plus simple ?

Pas aussi simple 😉 mais toutefois faisable.

Changer par une autre carte c'est ce qu'il y a de plus facile, la difficulté vient du facteur de forme (dimensions de la carte, emplacement des vis de maintien sur le fond du boitier, emplacement de la carte SD / µSD, du connecteur USB (miniUSB / µUSB)) qui nécessite parfois l'utilisation d'une Dremel ou d'huile de coude.

En restant sur les cartes Creality, on doit pouvoir y installer une carte récente comme la V4.2.7 (éviter la v4.2.2). En partant chez d'autres fabricants, le choix est vaste (the sky is the limit 😉 ) Bigtreetech (SKR miniE3, SKR 1.4, SKR Pro,…), Makerbase (Robin E3 ou autre), Fysetc Cheetah, …

Si tu devais / voulais changer de CM, il vaudrait mieux partir sur une carte récente à base de processeur STM (32bits): plus de mémoire (donc plus d'options possibles 😄 ), facilité de flashage (via le dépôt du firmware sur carte SD puis allumage de la machine), Firmware (Marlin, ou autre) plus à jour.

La mécanique de cette imprimante, bien que «vieille», reste d'actualité quand elle est régulièrement entretenue. Par contre d'origine, elle n'avait qu'un seul axe Z, pas de détecteur de fin de filament et son plus gros inconvénient est son alimentation en 12V qui nécessite le Mosfet externe pour alimenter le lit chauffant. C'est surtout ce point qui peut poser problème lors du changement de la CM (même si la plupart peut fonctionner en 12V) car les pilotes «silencieux» TMC fonctionnent mieux en 24V. Le simple remplacement de l'alimentation par une 24V entraine de nombreux frais supplémentaires (lit chauffant, cartouche de chauffe de la tête, ventilateurs (4 minimum)).

🙂

Modifié (le) par fran6p
Lien à poster
Partager sur d’autres sites

Merci beaucoup pour ta réponse fran6p, je regarderai si jamais on n'avance pas avec Remibora et pourquoi pas, partir sur une carte mère plus récente , elle le mérite bien cette imprimante 🙂🙂 

Lien à poster
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez poster un message et vous inscrire plus tard. Si vous avez déjà un compte, connectez-vous afin de poster avec.

Invité
Répondre à ce sujet…

×   Vous avez copié du contenu avec formatage.   Supprimer le formatage

  Only 75 emoji are allowed.

×   Votre lien a été automatiquement intégré.   Afficher en tant que lien à la place

×   Le contenu sauvegardé a été restauré.   Effacer l'éditeur

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Créer...