Aller au contenu

Calibration 2ème extrudeur et axer X2


methylene67

Messages recommandés

Bonjour,

Petite question, comment on peut réaliser la cxalibration des steps/mm du deuxième axe X2 ainsi que le Z2 et le E2 ?

Le E2, je n'arrive pas à le déclencher via prontefrface M83, G1 E100 F100, M92 E??? ?

Peut-être G2 ? Et ensuite pour le rentrer pour la machine ?

Pareil pour la calibration des axes Z (est-ce qu'il faut les calibré étant donné qu'ils sont synchronisés ?

Et puis, les valeurs d'origine pour E2 et X2 je ne comprends pas les valeurs. Et enfin pourquoi un Y2 alors que Y et Y2 sont les même non ?

IMG_2318.thumb.jpg.67d49435346a30264d690f253a78c904.jpg

Lien vers le commentaire
Partager sur d’autres sites

Salut,

Je ne connais pas ta machine mais pour calibrer l'extrudeur 2, il suffit de changer d'outil: si tu envoies le Gcode T1, suivi d'un G1 E10 F1500, l'extrudeur de la 2nd tête va faire défiler 10mm de filament (si la température de la buse permet l'extrusion). Du coup, pour définir les pas/mm de l'extrudeur 2, il suffira d'envoyer T1 puis M92 Eee.eee. T0 fait la même chose pour la tête 1.

J'imagine qu'un T1 suivi d'un M92 Xxx.xxx définira les pas/mm du moteur X2, à tester.

Par contre, pour Z2, je n'ai pas d'idée.

Il y a 3 heures, methylene67 a dit :

Et enfin pourquoi un Y2 alors que Y et Y2 sont les même non ?

Logique chinoise, on ne peut pas comprendre 🤣...

Modifié (le) par remibora
Lien vers le commentaire
Partager sur d’autres sites

Merci de ta réponse.

J'ai bien compris l'idée, donc si je ne précise pas de T., d'office cela prends l'extrudeur 1. Donc pas besoin de T0. Je testerai T1 ce soir voir si cela marche.

Pour les valeurs bizarres dans les settings, il s'agit en fait du décalage d'offset de la tête 2 par rapport à la tête 1 si j'ai bien compris, qui se règle en imprimant une pièce en dual matériau (mais là je n'ai pas encore tout compris à la manipulation malgré la vidéo sur le site de Tenlog).

Lien vers le commentaire
Partager sur d’autres sites

Il y a 8 heures, remibora a dit :
Il y a 12 heures, methylene67 a dit :

Et enfin pourquoi un Y2 alors que Y et Y2 sont les même non ?

Logique chinoise, on ne peut pas comprendre 🤣...

Non pas du tout logique "chinoise" ! c'est une logique logique !

La valeur Y2 est un décalage Y entre la tête 1 et la tête 2 comme X2 et Z2. Donc logique d'avoir nommé ce paramètre Y2.

Son effet est que lorsque tu prends la tête 2 ton plateau va se déplacer en Y pour que ton impression tête E2 soit bien centrée sur ton impression E1. Il faut donc bien un moyen de régler ce décalage.

En fait je pense que vous confondez la première colonne de paramètre (qui sont les step/mm X Y Z E) et la seconde colonne de paramètres qui sont les décalages de la tête E2 par rapport à E1 en X Y Z. Ca n'a rien à voir !

Lien vers le commentaire
Partager sur d’autres sites

Salut,

Les réglages de X2 et Y2 se font via l'impression en mode 2 couleurs d'un objet test qui permet de bien régler l'extrudeur 2 par rapport à l'extrudeur 1, afin qu'il n'y est pas de décalage entre les impressions en mode 2 couleurs.

Voir sur internet video de calibration pour régler X2 et Y2.

@+ 

Lien vers le commentaire
Partager sur d’autres sites

Salut @merlinxet @hcl28, comme dit plus haut, il me semblait et vous confirmez bien que ces valeurs sont un décalage de la tête 2 par rapport à la 1.

J'ai visionné la vidéo de Tenlog je n'ai pas vraiment tout compris, surtout qu'avec le cube d'origine on ne voit pas grand chose.

Je vais chercher un autre fichier et faire des tests.

Par contre, si les X1, Y1 et Z1 sont bien les valeurs des steps moteurs, que l'on peut donc calibrer par exemple en imprimant un objet avec la tête 1 de dimensions communes et avec un petit calcul à l'aide de la valeur actuelle recalibrer ces steps, comment je fait la calibration des steps moteur de la deuxième tête (c'était le but de ma question, même si j'avais en effet confondu les valeurs X2, Y2 dans le screen précédent).

Parce qu'en rentrant les steps calculés avec une impression de la tête 1, je vais modifier les steps des moteurs propres à la tête 1 (sauf pour Y qui est commun aux deux têtes).

Pourtant la tête 2 a bien des moteurs indépendant (sur l'axe X, l'axe Z, et l'extrudeur), seul l'axe Y est communs aux deux.

Après peut-être que je ne comprends pas tout, mais vu qu'on a 7 moteurs en tout on devrait pouvoir régler les steps des 7 moteurs (et non des 4 via X, Y, Z et E).

En gros tel quel, si je comprends bien, les valeurs des steps X, Y, Z et E s'appliquent aux deux moteurs X, aux deux moteurs E, aux deux moteurs Z et au moteur Y ?

Sauf que le l’étalonnage (pièce imprimé pour X, Y et Z, bout de filament avec feutre pour le E) est réalisé pour une seule pièce.

Mais bon appliquer la même valeur alors que physiquement ce sont deux entités différentes, il y a quelque chose qui ne me semble pas logique.

A titre d'exemple, avec un G1 E100 F100, sur E1 (T0) j'extrude 105 mm et sur E2 (T1) j'extrude 97.5 mm.

Modifié (le) par methylene67
Lien vers le commentaire
Partager sur d’autres sites

Sur la carte SD, il y a le cube de test pour le réglage de X2 et X2 dans le mode 2 couleurs, après concernant le réglage des steps sur E1 etE2, voir peut être au niveau du code du firmware, si il es possible de régler individuellement ceux-ci.

@+

Lien vers le commentaire
Partager sur d’autres sites

Exemple de deux cubes de dimensions 40x40x40 imprimé en mode duplication avec deux filaments différents (même fournisseur même température en PLA, seule la couleur change) :

Cube sur E1 : Y 40.02 // X 40.10 // Z 39.60

Cube sur E2 : Y 40.05 // X 40.07 // Z 39.80

On voit bien que pour X et Y c'est quand même assez propre, par contre pour Z, il faudrait régler les deux steps indépendamment (ou peut-être que la différence vient de l'extrudeur E2 que je n'ai pas pu régler).

Lien vers le commentaire
Partager sur d’autres sites

il y a une heure, methylene67 a dit :

On voit bien que pour X et Y c'est quand même assez propre, par contre pour Z, il faudrait régler les deux steps indépendamment (ou peut-être que la différence vient de l'extrudeur E2 que je n'ai pas pu régler).

Tu fais comment en mode copie ou miroir avec deux Z différents ? 😄 

Le 39.80 peut effectivement venir d'un mauvais réglage de E2, il ne faut pas oublier de dévisser la petite vis en dessous avant de régler la hauteur de E2 (je me fais avoir une fois sur 3) 

Lien vers le commentaire
Partager sur d’autres sites

il y a 40 minutes, Savate a dit :

Tu fais comment en mode copie ou miroir avec deux Z différents ? 😄 

Le 39.80 peut effectivement venir d'un mauvais réglage de E2, il ne faut pas oublier de dévisser la petite vis en dessous avant de régler la hauteur de E2 (je me fais avoir une fois sur 3) 

L'extrudeur E2 est bien réglé (en nivellement manuel, pas en décalage X et Y mais ça c'est pour le dual matériau, donc ce sera pour après). Je parlais du débit de l'extrudeur que je ne peux pas paramétrer même dans le code je n'ai pas trouvé.

En théorie le Z monte à la même vitesse vu que c'est synchronisé (c'est à dire que la carte commande en même temps de monter de 0.2 mm), mais vu qu'il s'agit de deux moteurs différents, un petit décalage de steps (moteur 1 monte de 0.2, et moteur 2 monte de 0.2002 par exemple) cumulé sur une certaine hauteur peut sans doute donner un écart de dimensions entre eux pièces identiques sur la hauteur totale (d'où mon interrogation de régler les step moteur de l'extrudeur 2).

Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...