Aller au contenu

Filament ABS

probléme installation detecteur de fin de filament sur carte mére creality 4.2.7


marcus55

Messages recommandés

DSC_0010.thumb.JPG.606738024c3b52470feed0a9067c55bc.JPGDSC_0011.thumb.JPG.be8bcd99448e413b082bc409f3e27196.JPGBonjour,

 

J'ai téléchargé le fichier suivant Marlin2.0.1-V1.2.1-filament-detection-firmwareTMC2225.zip. Je l'ai dézipper et j'ai formater ma mini carte SD et j'ai mis le fichier dessus.

J'ai mis ma mini carte SD dans l'imprimante et je l'ai allumer. Au bout de quelque secondes le logo ENDER est apparu et la version V1.2.1 est installer sur mon ENDER.

Je pensais que tout aller bien mais quand j'ai coupé mon filament lors d'un essai d'impression l'imprimante ne s'est jamais arrêter continuant l'impression comme si il n'y avais pas de capteur de fin de filament.

Quelqu'un pourrais me dire ce qui ne vas pas?

Marlin2.0.1-V1.2.1-filament-detection-firmwareTMC2225.zip

Lien vers le commentaire
Partager sur d’autres sites

Salutation !

N'y a t'il pas dans le menu de la machine, une nouvelle entré pour activer/désactiver le capteur de fin de filament ?

Sinon, si tu arrive a ouvrir une connexion a l'imprimante via un câble USB avec un programme comme Pronterface https://www.pronterface.com/ ou Repetier Host https://www.repetier.com/download-now/ , il existe la commande g-code M119 ( https://marlinfw.org/docs/gcode/M119.html ) pour avoir le statue des capteurs de fin de courses et capteur de fin de filament.

Modifié (le) par PPAC
Lien vers le commentaire
Partager sur d’autres sites

Bonjour,

J'ai fait le tour des différents menus et j'ai rien trouvé pour l'activation ou désactivation.

 

Pour ce qui est de Pronterface, je n’arrive pas à me connecté. Il reste sur connecting... J'ai essayer à 115200 baud et ensuite à 250000 mais rien n'y fait...

Si quelqu'un à une petite idée. Sachant que je n'ai pas souvent utiliser Pronterface.

Lien vers le commentaire
Partager sur d’autres sites

Bonjour !

Si tu es sous Windows, il faut vérifier que tu n'a pas besoins d'un driver pour la connexion USB. Pour cela, il faut allez dans le "gestionnaire de périphériques" et regarder si quand tu connecte la carte mère de l'imprimante en USB tu a un nouveau "Port COM" ex Port COM 4  ou un nouveau "périphérique inconnu" avec un "!"

Dans le cas d'un "périphérique inconnu", il te faudra installer un driver tu trouvera des explications et le driver via cette page https://www.geeetech.com/forum/viewtopic.php?t=60612 

Je pense que c'est le CH340SER ou CH341SER. Si ça ne fonctionne pas, essaie le FT232.
http://www.wch.cn/download/CH341SER_EXE.html
http://www.wch.cn/downloads/CH341SER_ZIP.html

Aussi, une seul application peut utiliser le port COM en même temps, il faut la fermer pour quelle le libère pour une autre ...

(normalement il y a une led qui s'allume sur la carte ou l’écran (si la machine est débranché du secteur cf les 5V de l'usb) qd on la branche en usb ... a tu une led qui s'allume ou rien ?)

(de temps en temps il faut redémarrer Windows si le port COM n'est pas libre alors qu'il n'y a pas d'application qui l'utilise.)
 

Modifié (le) par PPAC
Lien vers le commentaire
Partager sur d’autres sites

J'ai essayer d’installer le pilote pour le CH340SER( sur le composant électronique c'est écris CH340G).

Je pense avoir réussi mais je ne vois toujours pas l'imprimante 3D dans le gestionnaire de périphérique. Par contre j'ai bien une led sur la carte électronique qui s'allume  ainsi que l’écran de l'imprimante quand je branche le câble.

Est se que ça peut venir du câble? Tout les câbles sont branché de la même manière ou faut il un câble USB-> mini USB spéciale?

Lien vers le commentaire
Partager sur d’autres sites

à l’instant, marcus55 a dit :

je ne vois toujours pas l'imprimante 3D dans le gestionnaire de périphérique

Le seul "truc" que tu va voir dans le gestionnaire de périphériques, c'est un nouveau port com

L'imprimante sera gérée à l'aide de ce port com sous cura ou un autre slicer.

  • Merci ! 1
Lien vers le commentaire
Partager sur d’autres sites

il y a 9 minutes, marcus55 a dit :

je ne vois toujours pas l'imprimante 3D dans le gestionnaire de périphérique.

Pas de nouveau Port COM ? (comme le dit Savate, on cherche un Port COM ...)

file.php?id=5597&sid=8cfc22aeaddb87bce6e

Sinon oui peut être tester avec un autre câble USB ... tu a peut être pris un câble qui ne fournis pas les connexion DATA et qui ne peut que "charger"/"alimenter en +5V" un périphérique ... (il lui manque des fils ...)

Modifié (le) par PPAC
Lien vers le commentaire
Partager sur d’autres sites

il y a 6 minutes, marcus55 a dit :

ou faut il un câble USB-> mini USB spéciale

Non un câble avec connexion des données va très bien (attention un câble de recharge uniquement ne fonctionnera pas)

Modifié (le) par Savate
  • Merci ! 1
Lien vers le commentaire
Partager sur d’autres sites

Bonsoir,

@higgins91

A priori, d’après sa photo, il en a un, branché sur la prise dédiée (blanc, noir, rouge) , CM 4.2.7.

Sauf si j'ai mal vu.

Lien vers le commentaire
Partager sur d’autres sites

Avec le bon câble çà fonctionne mieux. Donc Pronterface détecte bien mon imprimante. Avant tout essai j'ai débranché le capteur de fin de filament de la carte.

Donc sur Pronterface j'ai fait une commande M119. Et dans la fenêtre Pronteface, j'ai vu l’état des 3 capteurs de fin de course. 

Donc ensuite j'ai branché mon capteur de fin de filament et là plus rien erreur communication et l’écran de l'imprimante s'éteint.

Je débranche le capteur de fin de filament et j'inverse le fil rouge (alim) et le fil blanc. Je le rebranche et là miracle l’écran s’allume. Je reconnecte l'imprimante au PC et je la connecte. Ça fonctionne bien.

Je refait une commande M119 et là en plus des 3 états de capteur de fin de course apparait le fin de filament. L'état avec filament dans le capteur est OPEN et l’état sans filament est TRIGGERED.

Du coup comme Pronterface reconnait l'état du capteur, je pense que ça fonctionne. Il me reste plus qu'à couper le filament pour essayer. 

 

Merci pour votre aide . Je vous tient au courant dés que j'ai fait l'essai.

 

Je reviens vers vous car j'ai lancé une impression en coupant le filament. Problème l'imprimante continu de tourner dans le vide.

Auriez vous une idée du problème?

Lien vers le commentaire
Partager sur d’autres sites

Salutation !

Peut etre que la commande M600 (https://marlinfw.org/docs/gcode/M600.html ) n'est pas activé ?

ou alors tu a un mode d'affichage qui ne permet pas des interaction de l'utilisateur et donc la commande M600 est ignoré ? ( cf https://www.lesimprimantes3d.fr/forum/topic/40625-gcode-m600-ne-fonctionne-pas-avec-la-d12230/?tab=comments#comment-426237 )

 

https://marlinfw.org/docs/configuration/configuration.html#filament-runout-sensor

https://marlinfw.org/docs/gcode/M600.html

Pour des pistes sur M600 et/ou la mise a jour d'un firmware :

Mais, il peut aussi y avoir dans le menu de l'imprimante, un menu pour activer/désactiver l’arrêt sur un événement du capteur de fin de filament ...

Modifié (le) par PPAC
Lien vers le commentaire
Partager sur d’autres sites

@marcus55

Bonjour,

Sur ce forum, comme sur la plupart des fora, il est mal vu et rarement toléré de faire du multipost (plusieurs posts à la suite sans réponse d'autres intervenants). J'ai donc regroupé tes multiples interventions en une seule.

En haut de chaque post, se trouve un bouton « … ». Quand on clique dessus, un menu déroulant apparait dans lequel se trouve l'option ÉDITER. Cette option comme son nom l'indique, permet de modifier, corriger, compléter son propos durant une période de 12 heures après parution.

editer-un-post-maj-forum-octobre2020.jpg.a4938c7846d94f5686804e7139409771.jpg

En tant que débutant, tu ne le savais peut-être pas. Désormais tu es au courant et je te demande donc de l'utiliser .

Merci d'avance

🙂

Lien vers le commentaire
Partager sur d’autres sites

  • 3 weeks later...

Bonjour,

je suis dans la même situation.

Mais qui est cet intrus?... Mais comment résoudre ce problème

 

Non Fran6p, ce n'est pas après toi, mais après la configuration pour l'impression

Modifié (le) par Jeanpinou
  • Confus 1
Lien vers le commentaire
Partager sur d’autres sites

Tu aurais dû / pu mettre en application la recommandation que je donnais un message plus haut 😉 . J'ai donc regroupé en un seul message tes deux précédents.

Pour citer / notifier un utilisateur dans ta réponse: tape l'arobase (@) puis commence à saisir son pseudo, au fur et à mesure de ta frappe tu pourras cliquer sur son pseudo (par exemple: @Jeanpinou si tout s'est bien passé, le pseudo apparait dans un cartouche.

Il reçoit alors une notification et peut y répondre (ou pas 😉),  il est prévenu, quoi 😄

🙂

  • +1 1
Lien vers le commentaire
Partager sur d’autres sites

Il y a 3 heures, Jeanpinou a dit :

je suis dans la même situation.

Donc pas exactement (suivie, il me semble de la solution ...)

 

Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...