Aller au contenu

Filament ABS

  • 0

Erreurs Include Visual Studio Code


papaone

Question

Bonjour,

 

A tous ceux qui compilent leur firmware avec Visual Studio, avez vous eu ce genre d' erreur?

" Erreurs #include détectées. Mettez à jour includePath. Les tildes sont désactivés pour cette unité de traduction (E:\Ender_3 v2\Firmware\Marlin\Marlin\src\MarlinCore.cpp). "

Comment résoudre ?

J'ai parcouru quelques sites sur le web, mais sans résultats probants. (peut être aussi que je n'ai pas tout compris 😏 )

Bref, si quelqu'un a la solution, je lui en serais très reconnaissant.

Merci.

Lien vers le commentaire
Partager sur d’autres sites

5 réponses à cette question

Messages recommandés

  • 0

Salutation !

Version de marlin ? (cf https://marlinfw.org/docs/basics/install.html#build-and-install ... exemple pour un marlin 1.1 il te faudra Arduino IDE v1.0.6 https://www.arduino.cc/en/main/OldSoftwareReleases )?

Marlin bugfix ou non ?

A tu bien mis PlatformIO car cela ressemble a un truc de compilateur qui n'est pas le bon pour du "bon vieux" langage C ... ou alors il n'y a pas l'index des autre fichiers du projet de correctement créer / a jour par platformIO ...

Où alors tu a mis ton projet dans un chemin avec des caractères spéciaux ? essai en "C:/monProjMarlin/" ?

Modifié (le) par PPAC
  • Merci ! 1
Lien vers le commentaire
Partager sur d’autres sites

  • 0

Salutations @PPAC

Merci pour les pistes à suivre.

Comme tu peux le constater sur la copie d'écran, tout le nécessaire est installé "normalement". ( à priori ...).

J'ai compilé plusieurs fois des firmwares sans aucun problèmes; mais il arrive quelques fois, sans que je comprenne pourquoi, j'ai cette  'Erreurs #include détectées. Mettez à jour includePath ' . Et puis, une ou deux compil + tard, rien, tout nickel, papa dans maman.

Comme j'ai horreur de ne pas comprendre, d'où ma question.

Pour répondre à ta question, le FW est à base du bugfix il me semble ( https://github.com/tititopher68/Marlin)

Et je n'ai jamais eu de problèmes avec ce FW, au contraire .

 

Dois-je faire venir un exorciste à la maison ?

 

VSC.png

  • J'aime 1
Lien vers le commentaire
Partager sur d’autres sites

  • 0

Un fantôme dans la machine ! Semble une bonne explication 🙂 

Ou alors ... fait tu attention a cela : laisser le temps au machin ...

image.png.5ccf398e1cdf9125c58d1176b564cfe5.png

Car juste après, il y a le "InteliScan ou je sais plus quoi" qui semble être se qui créé l'index des fichiers pour les dépendances et "include".

Mais je peux aussi être compétente a coté ...

Sinon je n'ai pas d'adresse d'exorciste de machine ... va falloir demander a notre pote bill gates ... (Edit : vérifier la mémoire vive avec un memtest ?)

Modifié (le) par PPAC
  • J'aime 1
Lien vers le commentaire
Partager sur d’autres sites

  • 0
Il y a 2 heures, PPAC a dit :

va falloir demander a notre pote bill gates

Il a des soucis de ménage en ce moment, 😉

Mais ta piste de "intellisence" est à creuser, effectivement. (j'ai vu pas mal de sites qui en parlaient, sans trop y croire réellement, mais à voir effectivement.

Merci de ta patience.

Lien vers le commentaire
Partager sur d’autres sites

  • 0

«intellisense» pose régulièrement des problèmes. En gros (je simplifie énormément 😉 ), ça sert à créer une BDD des différentes dépendances et parfois ça s'emmêle les pinceaux 😄

Généralement quand ça se produit, le plus simple est de fermer VSC puis de le relancer et la plupart du temps le problème disparait ou bien attendre un peu de temps que la BDD soit mise à jour avant de lancer une compilation.

🙂

Modifié (le) par fran6p
  • Merci ! 1
Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...