Aller au contenu

Filament ABS

[TUTO] En finir une bonne fois pour toutes avec les problèmes de connexions Wifi sur Raspberry pi 4 !


Messages recommandés

Salut à tous...

Ce tuto s'adresse aux utilisateurs du RPI4... qui souffrent depuis toujours d'un énorme défaut... qui n'a jamais été corrigé !

Je parle de la gestion de la connexion wifi qui n'en fait qu'à sa tête !!!

Je possède 3 rpi4... et ils ont tous le même défaut... principalement dû au gestionnaire de connexions de raspiOS...

Si on se connecte sur un seul et unique réseau wifi... pas de soucis ça fonctionne...

Par contre si comme moi, vous basculez sur différents réseaux wifi... les ennuis commencent...

Et quand cela arrive... il n'y a rien a faire... le wifi refuse de se connecter... même en ligne de commande !!!

Ce tuto est valable pour ceux utilisant une interface graphique... mais comme qui peut le plus... peut le moins... cette solution a l'avantage de déboguer aussi les lignes de commande 😉

 

Cette solution est très simple... mais il m a fallu un certain temps pour la trouver...

Il s'agit tout simplement d'installer un gestionnaire de connexions digne de ce nom ... c'est à dire network-manager !!!

Pour cela on commence par un petit 

sudo apt update
sudo apt install network-manager

Puis on configure dhcpcd pour ignorer l interface wlan0 :

sudo nano /etc/dhcpcd.conf

Et on y insère cette ligne :

denyinterfaces wlan0

 

On édite la configuration de network manager :

sudo nano /etc/NetworkManager/NetworkManager.conf

Avec :

[main]
plugins=ifupdown,keyfile
dhcp=internal

[ifupdown]
managed=true

 

Et enfin... un petit 

sudo reboot

 

Et voilà !!!

Vous pouvez virer l'icone d'origine dans la barre de tâches... et utiliser celle de network-manager qui est apparue pour vous connecter 

Ou bien aller dans le menu déroulant...

Et bien entendu... les commandes dans un terminal sont déboguées et plus aucune galère pour passer d'un réseau à un autre !!! 😉

Modifié (le) par fran6p
Lien à poster
Partager sur d’autres sites
  • akoirium changed the title to [TUTO] En finir une bonne fois pour toute avec les problèmes de connections wifi sur raspberry pi4 !
il y a 58 minutes, akoirium a dit :

cette solution a l'avantage de déboguer aussi les lignes de commande

??? C'est à dire ? Tu pourrais être plus explicite car je ne vois pas ?

N'utilisant pas d'interface graphique (sauf sur mon RPi400), NetworkManager est parfaitement utilisable en ligne de commande (man nmcli pour plus d’informations) 😉

nmcli <options> <section> <action>

En général, je préfère câbler en dur (Ethernet) quand c'est possible. Si une caméra est connectée sur la Pi, en Wifi, la latence est visible (quelques secondes à bien plus). Dans ta péniche où il doit y avoir pas mal de «barres» métalliques, la transmission / réception d'un signal radio est peut-être perturbée ?

J'espère que tu ne m'en voudras pas (trop) d'avoir passé un coup de correcteur 😉 . Ton clavier fonctionne bien? Des touches non fonctionnelles (l'apostrophe par exemple) ?

🙂

Lien à poster
Partager sur d’autres sites
  • fran6p changed the title to [TUTO] En finir une bonne fois pour toutes avec les problèmes de connexions Wifi sur Raspberry pi 4 !
Posté(e) (modifié)

Je parle des commandes ifup et ifdown qui ne fonctionnent pas sur raspios...

Ni tout le reste d ailleurs !...

Quand ca plante... aucunes commandes ne fonctionnent !...

Et cela ne viens pas de perturbations wifi ou autres dû à l effet cage de faraday du bateau... car il n y a que sur raspios que j ai le problème...

Bref network manager est bien plus efficace et plus puissant et ça résout pas mal de problèmes...

Les apostrophes... DSL ... c est pas le clavier...

J ai fait le tuto sur le tel et il est super chiant à aller chercher ce fichus apostrophe !!!

Oui je sais je suis une grosse feignasse...!... 😄

Modifié (le) par akoirium
Lien à poster
Partager sur d’autres sites
Il y a 5 heures, akoirium a dit :

Si on se connecte sur un seul et unique réseau wifi... pas de soucis ça fonctionne...

Par contre si comme moi, vous basculez sur différents réseaux wifi... les ennuis commencent...

La vraie question c'est pourquoi passer son temps à changer de réseau wifi ? 🙂 

  • Haha 1
Lien à poster
Partager sur d’autres sites
il y a 10 minutes, Savate a dit :

La vraie question c'est pourquoi passer son temps à changer de réseau wifi ? 🙂 

Il promène son imprimante à travers les rues de Paris pour lui faire prendre l'air ??   ou pour magasiner son filament ??   🤣

  • Haha 1
Lien à poster
Partager sur d’autres sites
Posté(e) (modifié)

La raison c est surtout quand le gamin a bouffé les 100go du forfait du bateau... et que j ai plus rien pour faire des mise a jours sur l imprimante ou le rpi4 qui gère la domotique... ou bien sur le mediacenter et qu il y a rien à la tv !...

Du coup je doit basculer sur le forfait de mon téléphone...

Et quand j ai bouffé tout mon forfait... je bascule sur celui de ma femme... 😄

 

du coup je suis bien content d avoir résolu ce probleme récurent du rpi4  😉

Modifié (le) par akoirium
Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...