Aller au contenu

Filament ABS

32 bits SKR 1.3 et sonde de température


Cedvano

Messages recommandés

Bonjour,

Ma SKR 1.3 m'affiche dès le démarrage 150° puis fluctue en montant parfois jusqu'à 200. Et le tout sans aucune sonde branchée dessus.

Je soupçonne (et même suis quasi sûr) que j'ai fait un mauvais contact et bousillé un composant sur la carte.

Cependant, je ne sais pas lequel. Pouvez-vous m'aider ?

Merci

Lien vers le commentaire
Partager sur d’autres sites

Salutation !

Sans sonde connecté avoir une valeur de température au plafond semble (edit : anormal  normal ...  mes excuse voir mon message suivant je me suis encore mélangé les pinceaux ... )

Se serai si quand tu a une sonde de branché et que la température fluctue sans raison ou qu'elle n'est pas cohérente alors là oui y aurai un problème ...

Tu peux aussi triché et mettre une résistance de 100K Ohm pour tester ...

Si tu a un multimètre tu peux tester la thermistance

Si cela viens de la carte , vérifier les soudures , teste de continuité ...il faudrait trouver un schéma de cette carte mais bien souvent il n'y a pas bcp de composant entre le connecteur de la sonde et le microcontrôleur (suivre les pistes sur le PCB ...) ... une petit résistance CMS et un petit condensateur CMS donc pas simple a tester / réparer ... mais pas impossible !

Sinon si tu a un autre connecteur de sonde thermique disponible, il reste possible de modifier un marlin pour l'utiliser a la place de celui qui pose problème.

Modifié (le) par PPAC
Lien vers le commentaire
Partager sur d’autres sites

Merci pour ta réponse,

Sans sonde, il affiche normalement -14°, avec sonde, j'ai dans les 20° habituellement.

Mais la, avec ou sans sonde, j'ai 150 dès le départ. J'ai testé avec plusieurs thermistances, mais rien n'y fait.

J'ai réinstallé le fw, sait on jamais, mais sans succès.

C'est a mon avis, bien un composant hs de la carte. Je vais faire comme tu dis et tester la continuité du circuit.

Merci pour ton aide.

Lien vers le commentaire
Partager sur d’autres sites

il y a 8 minutes, Cedvano a dit :

Sans sonde, il affiche normalement -14°

Mes excuse j'ai encore inversé le truc je me suis trompé dans mon message précédant ...

la résistance d'une thermistance diminue plus la température augment donc +200°C affiché peut indiquer un court circuit ... !

oui tu a raison il y a bien un truc qui ne va pas ! peut être un court circuit sur la carte ou au niveau du connecteur de la carte ...

Modifié (le) par PPAC
Lien vers le commentaire
Partager sur d’autres sites

il y a 42 minutes, Cedvano a dit :

comment changer les numéro de pin dans marlin, je voudrais inverser les pin du th0 en th1.

Il faut aller trouver le / les .h de la carte définie dans le configuration.h et y modifier les attribution des PIN.

ex modifier se genre de fichier attention pris au pif : https://github.com/MarlinFirmware/Marlin/blob/2.0.x/Marlin/src/pins/stm32f1/pins_BTT_SKR_MINI_E3_common.h

Aussi, si tu a le "PINS_DEBUGGING" activé dans le marlin il existe la commande g-code M43 https://marlinfw.org/docs/gcode/M043.html pour avoir le listing des PIN et donc les attribution actuel.

Modifié (le) par PPAC
  • J'aime 1
Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...