Aller au contenu

Filament ABS

Klipper : Cura -> PrusaSlicer


Messages recommandés

Bonjour,

 

Ayant stopper les print depuis quelques temps, j'ai remis a jour ma bestiole en passant de octoprint a Fluidd.

J'aimerai en profiter poru passer de Cura à PrusaSlicer, mais j'ai un petit soucis quand au gcode de demarrage.

J'utilise un Gcode de demarrage et de fin dans mon printer.cfg, Gcode repris de celui de @fran6p.


 

Révélation

 

[gcode_macro START_PRINT]

##variable_T_BED: 60

##variable_T_EXTRUDER: 200

gcode:

    # Check filament true or cancel print

    CHECK_FILAMENT

    # Use absolute coordinates

    G90

    # Reset the G-Code Z offset (adjust Z offset if needed)

    SET_GCODE_OFFSET Z=0.0

    # Start bed heating and continue

    M140 S{T_BED}

    {% if printer.heater_bed.temperature < params.T_BED|float*0.85 %}

    M190 S{params.T_BED|float*0.85} # wait till 0.85 of bed temp is reached, then continue  

    {% endif %}

    M140 S{T_BED}

    M190 S{T_BED}

    # Home all axes

    G28

    # Use the bed mesh

    # G29

    BED_MESH_PROFILE LOAD=cr10v3

    # Move the nozzle near the bed

    G1 X2 Y20 Z10 F6000

    # Wait nozzle temp

    M109 S{T_EXTRUDER}

    # Prime line

    PURGE

 

Malheureusement quand je met:

  START_PRINT T_BED={material_bed_temperature_layer_0} T_EXTRUDER={material_print_temperature_layer_0}

dans PrusaSlicer, il ne l'accepte pas...

 

Si quelqu'un à une solution, je suis preneur.

 

Merci d'avance.

Modifié (le) par Stef67
Lien vers le commentaire
Partager sur d’autres sites

Salutation je n'utilise pas PrusaSlicer mais peut être aura tu des pistes avec cela

https://help.prusa3d.com/en/article/list-of-placeholders_205643

Citation

Useful place holders

bed_temperature

M140 S[bed_temperature]

note: It will always take the value of the filament loaded in extruder_0

current_extruder

M104 S[first_layer_temperature_[current_extruder]]

note: this will not work in start gcode as the [current_extruder] placeholder is filled with the number of the last used extruder, which is nothing at startup and random at any other slicing job

first_layer_temperature

M104 S[first_layer_temperature_0] M104 S[first_layer_temperature_[next_extruder]]

first_layer_bed_temperature

M140 S[first_layer_bed_temperature]

note: It will always take the value of the filament loaded in extruder_0

Donc sous prusa pas de { } sauf pour des macros / conditionnel ? https://help.prusa3d.com/en/article/macros_1775

mais des [ ] ?

  • Merci ! 1
Lien vers le commentaire
Partager sur d’autres sites

Posté(e) (modifié)

J'arrive donc a un resultat qui va marcher je pense (pas encore testé) mais ce qui m'interresse c'est d'ajouter les variables :

variable_T_BED: 60

variable_T_EXTRUDER: 200

 

en attendant voila ce que j'ai reussi a faire :

[gcode_macro START_PRINT_PRUSASLICER]
gcode:
    # Check filament true or cancel print
    CHECK_FILAMENT
    # Use absolute coordinates
    G90
    # Reset the G-Code Z offset (adjust Z offset if needed)
    SET_GCODE_OFFSET Z=0.0
    # Start bed heating and continue
    M140 S[first_layer_bed_temperature]
    M104 S[first_layer_temperature]
    M190 R[first_layer_bed_temperature]
    # Home all axes
    G28
    # Use the bed mesh
    # G29
    BED_MESH_PROFILE LOAD=cr10v3
    # Move the nozzle near the bed
    G1 X2 Y20 Z10 F6000
    # Wait nozzle temp
    M109 S[first_layer_temperature]
    # Prime line
    PURGE

 

 

Marche pas...

ca chauffe le bed puis ca me dit :

!! Error on 'M104 S[first_layer_temperature]': unable to parse [

Modifié (le) par Stef67
Lien vers le commentaire
Partager sur d’autres sites

hello 

si ça peu t'aider :

dans super slicer start gcode : START_PRINT BED_TEMP="M140 S[first_layer_bed_temperature]" EXTRUDER_TEMP="M104 S[first_layer_temperature]" ;

et dans client_macros.cfg 

Citation
# Do nozzle priming
[gcode_macro PRIME_EXTRUDER]
gcode:
    M117 Priming
    G92 E0
    #G1 X10.1 Y20 Z2.0 F2000
    G1 X10.1 Y200 Z0.24 F2000.0 E15; Draw the first line
    G1 X10.4 Y200 Z0.24 F5000.0; Move to the side a little
    G1 X10.4 Y20.0 Z0.24 F2000.0 E30; Draw the second line
    G92 E0 
    G1 F2400 E-0.7 # Small retract to remove pressure
    G1 Z2.0 F3000 ;Move Z Axis up
 
[gcode_macro START_PRINT]
default_parameter_BED_TEMP60
default_parameter_EXTRUDER_TEMP195
gcode:
    G28 ;Home
    G29 ;Load Mesh Bed Level
 
    # Start bed heating
    M117 Heating bed
    M140 S{BED_TEMP}
    # Use absolute coordinates
    G90
    # Reset the G-Code Z offset (adjust Z offset if needed)
    #SET_GCODE_OFFSET Z=-0.16
    # Home the printer
    #G28
    # Move the nozzle near the bed
    G1 Z5 F3000
    # Move the nozzle very close to the bed
    G1 X10.1 Y20 Z2.0 F2000
    G1 Z0.15 F300
    # Wait for bed to reach temperature
    M190 S{BED_TEMP}
    # Start nozzle heating
    M117 Heating nozzle
    M104 S{EXTRUDER_TEMP}
    # Set and wait for nozzle to reach temperature
    M109 S{EXTRUDER_TEMP}
    # Prime line
    PRIME_EXTRUDER
    M117 Printing
 
[gcode_macro END_PRINT]
gcode:
    # Move nozzle away from print while retracting
    G91
    # Raise nozzle and retract
    G1 E-5 F1800
    G1 Z5 F3000
    # Move to absolute position
    G90
    G1 X10 Y200 F2000
    # Turn off bed, extruder, and fan
    M140 S0
    M104 S0
    M106 S0
    # Disable steppers
    M84
    M117 Print complete

pour info , quand j'ai essayé de reprendre des modéles sur des topic qui dater un peu (quelques mois) je n'ai eu que des erreurs 

  • Merci ! 1
Lien vers le commentaire
Partager sur d’autres sites

Voici ce qui est saisi dans Prusaslicer pour ma CR10-V2 sous Klipper :

cr10v2-klipper-gcodes.jpg.a08df6db152dd4c4816a60b5f54366ad.jpg

Avec l'extrait de mon macros.cfg :

Citation

######################################################################
# Start Print and End Print
######################################################################

# Replace the slicer's custom start and end g-code scripts with
# START_PRINT and END_PRINT.

[gcode_macro START_PRINT]
variable_T_BED: 60
variable_T_EXTRUDER: 200
gcode:
    M117 Homing
    # Use absolute coordinates
    G90
    # Reset the G-Code Z offset (adjust Z offset if needed)
    SET_GCODE_OFFSET Z=0.0
    # Home the printer
    G28
    # Use the bed mesh
    #G29
    BED_MESH_PROFILE LOAD=cr10v2
    # Move the nozzle near the bed
    G1 X15 Y20 Z5 F6000
    
    M117 Waiting for temperature
    # Start bed heating and continue
    M140 S{T_BED}
    {% if printer.heater_bed.temperature < params.T_BED|float*0.85 %}
        M190 S{params.T_BED|float*0.85} # wait till 0.85 of bed temp is reached, then continue  
    {% endif %}
    
    M140 S{T_BED}
    M104 S170
    M190 S{T_BED}
    M109 S{T_EXTRUDER}
    
    # Prime line
    PURGE
    M117 Printing...

[gcode_macro END_PRINT]
gcode:
    M117 Done printing 🙂
    # move z up
    G91
    G1 E-2 Z+10 F3000
    # absolute xy
    G90
    G1 X5 Y295 F2000
    #disable hotend and heated bed
    M104 S0
    M140 S0
    # disable steppers
    M84
    BED_MESH_CLEAR

# prime the nozzle
[gcode_macro PURGE]
gcode:
    M117 Prime Line
    G92 E0 ;Reset Extruder
    # move z axis
    G1 Z2.0 F3000 ;Move Z Axis up
    # move to prime position
    G1 X2 Y30 Z0.28 F5000.0 ;Move to start position
    G1 X2 Y200.0 Z0.28 F1500.0 E15 ;Draw the first line
    G1 X3 Y200.0 Z0.28 F5000.0 ;Move to side a little
    G1 X3 Y50 Z0.28 F1500.0 E30 ;Draw the second line
    G92 E0 ;Reset Extruder
    G1 Z2.0 F3000 ;Move Z Axis up

Et ça fonctionne 😉 (pour Cura le start gcode est un poil différent et utilise les «placeholders» de Cura (noms différents ET accolades ({}) au lieu de crochets ([]) pour Prusaslicer / Superslicer).

Il y a 5 heures, maccoa a dit :

pour info , quand j'ai essayé de reprendre des modéles sur des topic qui dater un peu (quelques mois) je n'ai eu que des erreurs 

Tu aurais le / les lien(s) de sujets pour lesquels tu rencontres «que» des erreurs. L'as-tu signalé à ceux qui ont faits ce / ces sujet(s) ?

🙂

Modifié (le) par fran6p
  • Merci ! 2
Lien vers le commentaire
Partager sur d’autres sites

Posté(e) (modifié)

Merci pour tout Fran6p.

Si je comprends bien, pas besoin de changer le macros.cfg, c'est uniquement l'appel dans le slicer qui est différent.

Modifié (le) par Stef67
  • Merci ! 1
Lien vers le commentaire
Partager sur d’autres sites

il y a 38 minutes, fran6p a dit :

Tu aurais le / les lien(s) de sujets pour lesquels tu rencontres «que» des erreurs. L'as-tu signalé à ceux qui ont faits ce / ces sujet(s) ?

je ne l'ai pas signaler puisque chez eux ça fonctionne . 

sur le moment , j'ai mis ça sur le dos de mon inexpérience et ou différence de version . 

je vais essayer le tiens pour voir . 

Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...