Aller au contenu

Filament ABS

BL Touch 3.1 buse trop haute.


Messages recommandés

Pour toutes les opérations que j’ai réalisés, je me suis référé au mode d’emploi fournis avec le BLTOUCH.


Imprimante : Ender 3   Carte de mère: 4.2.2


Bonjour, à tous, j’ai soucis pour la configuration de mon BLTOUCH 3.1

L’installation de la sonde sur la machine c’est dérouler sans aucun souci. Le câblage avec le câble 5 pins aucun souci (de plus il y a des détrompeurs). Et fin de course Z a était déconnecter.


Pour la partie logiciel, j’ai mis à jour firmware via le site de creality.
Au démarrage de la machine la capture s’allume et réagis.


Pour configuration :
j'ai fais un auto home et une fois terminé je pense que le problème est la mon axe Z n’est sur 0 mais 10.
Étant novice, je pensais contourner le souci en réaliser un move axis et remettre mon Z sur 0.
Ensuite, j’ai été dans CONTROL  BED LEVELING  PROBE Z OFFSET. Le manuel me dit de mettre la valeur 0.200 mais la buse était encore trop haute donc j’ai ajusté jusqu’à ce que la buse frotte la feuille. La valeur éteint donc les -2.500 (de mémoire).
Apres, il faut retourner dans CONTROL / BED LEVELING / LEVEL BED. Mon imprimante commence le nivelage sur 9 points. 

Pendant le test, la buse reste a +/- 5 mm du plateau. Je me suis donc dit que c’est normal pour le test…

Dans Cura, j’ai modifié les paramètres pour l’imprimante et changé G28 EN G2829.

Je me prépare un petit fichier test, et je lance l’impression et je pense cela n’est pas une surprise l’impression démarre avec la buse a 5 mm du plateau.

Pouvez-vous m’aider a trouver le problème. Merci

 

PJ: Scan du mode d'emploi fourni. 

IMAG0011.PDF IMAG0012.PDF

Lien à poster
Partager sur d’autres sites

Salut,

La règle d'or, c'est un Gcode par ligne. Du coup G28G29 devient:

G28

G29

Si tu as la possibilité de sauvegarder les paramètres dans l'eeprom, tu peux palper ton plateau et tu enregistres le résultat via le menu (préférable et à refaire en cas de nivellement suspect): avant d'imprimer, tu envoies: G28 puis G29 ou avec les menus de l'écran. Tu sauvegardes le nivellement avec la commande M500 ou via le menu. Dans le Gcode de démarrage, après la ligne G28, tu tapes M420 S1. Si tu veux que le nivellement s'estompe après 1mm de haut, tu tapes M420 S1 Z1

Modifié (le) par remibora
Lien à poster
Partager sur d’autres sites
Posté(e) (modifié)

J'ai bien compris pour le G28 ET G29 pour séquence de démarrage, mais la suite, je suis un peu perdu.


Si je fais un auto home j'obtiens  X 162 Y 11 Z 10
Je dois donc faire un move axis Y de -10mm pour le mettre a zéro et une fois sur a zéro je vais dans Probe Z offset pour  placer la buse correctement. Une fois la buse placée, j'ai -2.6 en valeur donc j'enregistre.


Mais quand je lance l'auto-nivellement, c'est toujours trop haut. Je pense que je ne comprends pas une étape.  🙁

Modifié (le) par Kevin7350
Lien à poster
Partager sur d’autres sites
il y a 18 minutes, Kevin7350 a dit :

Je dois donc faire un move axis Y de -10mm

non, pourquoi faire? tu peux rester là où tu es.

il y a 19 minutes, Kevin7350 a dit :

quand je lance l'auto-nivellement, c'est toujours trop haut

L'auto-nivellement sert à palper le plateau avec le BLtouch. En aucun cas, la buse doit être proche du plateau. A la fin de l'auto-nivellement, tu enregistres la matrice de correction via l'écran et tu modifies ton gcode de démarrage en ajoutant la ligne M420 S1 (ou M420 S1 Z...) pour appliquer la matrice de correction. Normalement, lorsque l'impression va débuter, la buse sera à la bonne hauteur (0.2 / 0.3mm, suivant ce que tu as paramétré dans le trancheur) pour imprimer.

Lien à poster
Partager sur d’autres sites
Posté(e) (modifié)

Mon G Code démarrage ressemble à cela :

; Ender 3 Custom Start G-code

G92 E0 ; Reset Extruder

G28 ; Home all axes

G29

M420 S1 Z1

G1 Z2.0 F3000 ; Move Z Axis up little to prevent scratching of Heat Bed

G1 X0.1 Y20 Z0.3 F5000.0 ; Move to start position

 Et une fois lancer je suis bien plus haut qu' 1mm , a vue d'œil je suis a 5mm. 

 

il y a 37 minutes, remibora a dit :

A la fin de l'auto-nivellement, tu enregistres la matrice de correction

C'est bien un G29 et une fois fini le m500 ?

Modifié (le) par Kevin7350
Lien à poster
Partager sur d’autres sites

On ne s'est pas compris, c'est SOIT tu palpes le plateau systématique au début de l'impression (G28 puis G29) SOIT tu rappelles la dernière matrice de correction après le G28 (G28 suivi d'un M420 S1 Z1) mais pas les 2 en même temps.

Je te propose de flasher le firmware ci-dessous, obtenu à partir de Marlin 2.0.7.2. L'avantage, en plus d'avoir les menus en français, ce sera qu'en double-cliquant sur le bouton du pupitre lors de l'impression de la couche initiale, tu accèderas directement au menu qui permet de changer la hauteur de la buse.

Pour mémoire, avant de flasher le firmware, tu notes les valeurs de l'eeprom avec M503. Après avoir flashé le firmware, tu envoies M502 (reset "usine") suivi d'un M500 (enregistrement de l'eeprom) et un M501 (applique les valeurs de l'eeprom à la SRAM) ou via les menus de la machine. Ensuite tu mets à jour les valeurs des paramètres machine (M92 = pas/mm des moteur,M301 = PID du bloc de chauffe de la buse ,M304 = PID du plateau,...)

La 1ère vérification sera de valider le sens de déplacement des moteurs puis de valider le fonctionnement du BLtouch avec un M43 S. Cette étape est détaillée dans ce message ainsi que le paramétrage à faire avec un bltouch (décalage X,Y,Z, PIDs...).

PS: N'hésite pas à ajouter le nom de ton imprimante dans ton profil. C'est très pratique pour répondre, on a pas à chercher loin.

 

firmware-V1.bin

Modifié (le) par remibora
Lien à poster
Partager sur d’autres sites

Hors la procédure de nivellement décrite part notre ami @remibora.

Pour régler le z-offset, ce n'est pas Y qu'il faut faire pour le move axis mais Z.

Donc pour le z-offset:

1) autohome

2) move axis Z -> se mettre à zéro

3) Menu Z-offset réglage sur ticket de CB

4) SAVE !

Lien à poster
Partager sur d’autres sites

J'ai relu un peu tous vos messages et je suis enfin arrivé. Et non, je n'ai pas mis à jour le firmware de l'imprimante, elle fonctionne bien pour l'instant peut-être que plus tard, je ferais la mise à jour. Merci de m'avoir aidé. 

Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...