Aller au contenu

Filament ABS

Octoprint ne se connecte pas au WIFI


Messages recommandés

Bonjour,

Cela fait déjà 1 mois que je n’ai pas utiliser mon octoprint (donc je l’avais éteint) et je voulais le redémarrer mais il ne se connecte plus à la wifi. J’ai regarder dans les fichiers de la carte SD mais j’ai rien trouver de faux. 
 

Aidez moi, s’il vous plaît 🙏 

merci

Lien vers le commentaire
Partager sur d’autres sites

Salut,

Ocroprint n'est pas toujours paramétré pour démarrer au lancement du pi il faut se connecter en ssh sur ton pi et envoyer la commande :
sudo service octoprint restart
Ou
sudo systemctl reboot

Comment est-ce que tu éteins ton raspberry ? Il faut bien faire un shutdown avant de le débrancher car ça peut le briquer de juste couper le courant.

Autre possibilité, si tu n'as pas fixé l'IP de ton pi celle ci a pu bouger tu peux vérifier ça avec l'application fing sur téléphone ou autre application qui scannent ton réseau local.

Envoyé de mon One Plus Nord en utilisant Tapatalk



Lien vers le commentaire
Partager sur d’autres sites

S'il a déjà fonctionné, je ne vois qu'une chose...     débranche le de ton imprimante, et rapproche le de ton routeur avant de le repartir...   ca devrait aider à ce qu'il se reconnecte.   ensuite tu l'éteins, et tu le rebranche...   Ca a des bonnes chances de fonctionner !!!

😉

Lien vers le commentaire
Partager sur d’autres sites

Salut,

 Comment es-tu sur que le RPI ne se connecte pas au wifi ? Tu te connectes avec octopi.localet tu ne le trouves pas ou tu ouvres les paramètres de ta box et tu ne le vois pas connecté ? 

En gros : si tu veux de l'aide soit un peu plus précis 🙂 

Lien vers le commentaire
Partager sur d’autres sites

Il y a 19 heures, PierreG a dit :

S'il a déjà fonctionné, je ne vois qu'une chose...     débranche le de ton imprimante, et rapproche le de ton routeur avant de le repartir...   ca devrait aider à ce qu'il se reconnecte.   ensuite tu l'éteins, et tu le rebranche...   Ca a des bonnes chances de fonctionner !!!

😉

Oui ça avait déjà fonctionné, mais je l’ai débranché pour l’éteindre. J’ai aussi réinstallé un nouveau octoprint mais rien.

 

Il y a 20 heures, billedeclown01 a dit :

Salut,

Ocroprint n'est pas toujours paramétré pour démarrer au lancement du pi il faut se connecter en ssh sur ton pi et envoyer la commande :
sudo service octoprint restart
Ou
sudo systemctl reboot

Comment est-ce que tu éteins ton raspberry ? Il faut bien faire un shutdown avant de le débrancher car ça peut le briquer de juste couper le courant.

Autre possibilité, si tu n'as pas fixé l'IP de ton pi celle ci a pu bouger tu peux vérifier ça avec l'application fing sur téléphone ou autre application qui scannent ton réseau local.

Envoyé de mon One Plus Nord en utilisant Tapatalk


 

Merci, mais comment  pour se connecter au ssh (je suis sur MACOSX)

Lien vers le commentaire
Partager sur d’autres sites

Salut @Surfeee,

sur la carte sd d'octopi il y a un fichier octopi-wpa-supplicant.txt

il faut l'éditer avec un editeur de texte et remplacer les infos ci-dessous

## WPA/WPA2 secured

#network={

# ssid="put SSID here"

# psk="put password here"

#}

par 

## WPA/WPA2 secured

network={

 ssid="put SSID here"

 psk="put password here"

}

un peu plus base dans le fichier texte il faut remplacer le pays d'utilisation (commenter le EN et décommenter le pays choisi.

WiFi setup and troubleshooting - Get Help / FAQ - OctoPrint Community Forum

 

Après c'est du wifi, donc ip "variable" sauf si tu fais une réservation sur le serveur dhcp (ta box par exemple) tu peux associer une adresse MAC avec une IP.

Lien vers le commentaire
Partager sur d’autres sites

Il y a 9 heures, Savate a dit :

Salut @Surfeee,

sur la carte sd d'octopi il y a un fichier octopi-wpa-supplicant.txt

il faut l'éditer avec un editeur de texte et remplacer les infos ci-dessous

## WPA/WPA2 secured

#network={

# ssid="put SSID here"

# psk="put password here"

#}

par 

## WPA/WPA2 secured

network={

 ssid="put SSID here"

 psk="put password here"

}

un peu plus base dans le fichier texte il faut remplacer le pays d'utilisation (commenter le EN et décommenter le pays choisi.

WiFi setup and troubleshooting - Get Help / FAQ - OctoPrint Community Forum

 

Après c'est du wifi, donc ip "variable" sauf si tu fais une réservation sur le serveur dhcp (ta box par exemple) tu peux associer une adresse MAC avec une IP.

Ça j’ai déjà fait. 

 

Il y a 17 heures, Rlv a dit :

Salut,

 Comment es-tu sur que le RPI ne se connecte pas au wifi ? Tu te connectes avec octopi.localet tu ne le trouves pas ou tu ouvres les paramètres de ta box et tu ne le vois pas connecté ? 

En gros : si tu veux de l'aide soit un peu plus précis 🙂 

Non je ne le vois pas connecter, il est offline.

Lien vers le commentaire
Partager sur d’autres sites

Est ce que tu peux te connecter à l'interface de ta box internet pour voir si le pi y est connecté ?
Est ce que la led verte clignote quand tu allumes le pi?
Que se passe-t-il si tu connecte un écran au pi?

Envoyé de mon One Plus Nord en utilisant Tapatalk







Lien vers le commentaire
Partager sur d’autres sites

Il y a 11 heures, Rlv a dit :

En gros : si tu veux de l'aide soit un peu plus précis 🙂 

il y a 54 minutes, Surfeee a dit :

Non je ne le vois pas connecter, il est offline.

@Surfeee : Nous ne sommes pas des devins/magiciens. Comprends bien que lorsque tu exposes un problème à des personnes qui ne sont pas chez toi, devant ton imprimante ou ton ordinateur. Nous sommes la pour donner des pistes et conseil et pas pour résoudre le problème à ta place. Donc si tu ne donnes pas des infos précises pour orienter les choses, tu risques de ne jamais avoir de réponse.

Lien vers le commentaire
Partager sur d’autres sites

Il y a 5 heures, raoullevert a dit :

@Surfeee : Nous ne sommes pas des devins/magiciens. Comprends bien que lorsque tu exposes un problème à des personnes qui ne sont pas chez toi, devant ton imprimante ou ton ordinateur. Nous sommes la pour donner des pistes et conseil et pas pour résoudre le problème à ta place. Donc si tu ne donnes pas des infos précises pour orienter les choses, tu risques de ne jamais avoir de réponse.

J’ai voulu relancer mon octoprint, mais il n’est pas connecté à la wifi, je l’ai regarder depuis ma box pourtant j’ai mis les données dans le fichier.

 

Il y a 5 heures, billedeclown01 a dit :

Est ce que tu peux te connecter à l'interface de ta box internet pour voir si le pi y est connecté ?
Est ce que la led verte clignote quand tu allumes le pi?
Que se passe-t-il si tu connecte un écran au pi?

Envoyé de mon One Plus Nord en utilisant Tapatalk






 

Oui, il clignote mais je n’ai pas d’écran donc je ne sais pas le faire.

  • Merci ! 1
Lien vers le commentaire
Partager sur d’autres sites

il y a 1 minute, Surfeee a dit :

Oui, il clignote mais je n’ai pas d’écran donc je ne sais pas le faire.

sur MacOs tu peux utiliser Terminal pour te connecter au pi en tapant ssh <ip du pi>

Lien vers le commentaire
Partager sur d’autres sites

Pour mieux régler le problème, tu devrais connecter ton pi avec un cable Ethernet, ce qui te permettra de te connecter dessus en SSH, ou mieux, le connecter avec un cable HDMI a ton écran d'ordinateur et a ton clavier-souris.    

Là au moins tu vas pour voir faire de bon diagnostic, et vérifier plus de choses....

🧐

  • J'aime 1
  • +1 1
Lien vers le commentaire
Partager sur d’autres sites

Difficile d'aider 😞

On ne sait même pas de quel RPi il s'agit.

Si l'adresse IP attribuée au RPi via Wifi fonctionnait il y a un mois ET que cette IP n'avait pas été réservée en statique sur la Box du FAI alors le bail IP a probablement été réattribué à un autre matériel.

Il est également possible que le Wifi de la box soit défaillant. D'autres matériels Wifi fonctionnent correctement ?

🙂

Lien vers le commentaire
Partager sur d’autres sites

@Surfeee : un truc que tu peux tenter déjà, pour y voir plus clair. Allumes ton raspberry attends 5 minutes  et depuis un PC connecté sur le même réseau ouvre un terminal et tapes 

sous windows : arp -av
sous Linux ou osX : arp -a

Ca va te donner la liste de tous tes périphériques vu par le réseau (même sans adresse IP). Si tu ne trouves pas ton RPI dans la liste (pas facile à lire je te l'accord), essaies de le connecter en ethernet. La tu relances la manip. Normalement ton RPI devrait apparaître. 

Il peux y avoir plusieurs problèmes

-- tu as un wifi 5ghz et ton RPI n'acceptes que le 2.4Ghz. 

-- Un soucis avec la carte SD et/ou la configuration qui empêche le RPI de booter et/ou de se connecter au wifi. 

Modifié (le) par Rlv
Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...