Aller au contenu

Filament ABS

gogogadjet17

Problèmes avec les axes x et y pour la première calibration [/RÉSOLU]

Messages recommandés

Bonjour,

Les petits tracas débutent. J'ai recherché sur le forum mais je ne trouve pas de problème correspondant aux miens, ou pas exactement pareils.

J'ai mis à jour Marlin et j'ai installé Repetier Host, qui se connecte bien à la Mega 2560.

 

Problème 1: Sur l'Axe X, le capteur fonctionne bien, mais le moteur tourne je pense à l'envers, car lorsque je fais Home X, il ammène le bloc à l'opposé et bloque. Que faire ? J'ai entendu parler d'inverser deux fils mais je préfère avoir l'avis d'ensemble, s'il n'y a pas quelque chose à faire dans Marlin.

Problème 2: Sur l'Axe Y, le plateau se déplace dans le bon sens, il touche le capteur endstop qui s'allume; mais le moteur ne s'arrete pas et force. J'ai testé le Enstop, en le branchant sur l'axe X, il fonctionne très bien. Que faire ?

 

Pour info, voila la notice que je suis: http://pobo.lt/3Dinstructions/Prusa_i3_Rework_rev1.5 - First use instructions.pdf Et je suis à la page 14. (c'est un kit qui m'a été vendu par un vendeur tiers, mais exactement le même que le kit de chez eMotionTech, Reprap)

 

Merci à tous par avance de votre aide :)

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut @gogogadjet17,

il y a 10 minutes, gogogadjet17 a dit :

Problème 1: Sur l'Axe X, le capteur fonctionne bien, mais le moteur tourne je pense à l'envers, car lorsque je fais Home X, il ammène le bloc à l'opposé et bloque. Que faire ? J'ai entendu parler d'inverser deux fils mais je préfère avoir l'avis d'ensemble, s'il n'y a pas quelque chose à faire dans Marlin

Oui dans marlin tu inverse le sens du moteurs

c'est la ligne X inverse dir,

il y a 11 minutes, gogogadjet17 a dit :

Problème 2: Sur l'Axe Y, le plateau se déplace dans le bon sens, il touche le capteur endstop qui s'allume; mais le moteur ne s'arrete pas et force. J'ai testé le Enstop, en le branchant sur l'axe X, il fonctionne très bien. Que faire

Il faut que tu contrôle sur ta carte si tu n'as pas un problème de connectique ou si tu n'a pas inverser min et max.

Si c'est bon contrôle dans marlin si le endstop Y n'est pas inverser ( false ou true).

Partager ce message


Lien à poster
Partager sur d’autres sites

Pour le problème d'inversion, si c'est une prusa, y'as un problème d'inversion sur la notice. Il suffi d'inverser le branchement.
Moi j'ai inversé et aucun problèmes
:)

.

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 34 minutes, philippem a dit :

Salut @gogogadjet17,

Oui dans marlin tu inverse le sens du moteurs

c'est la ligne X inverse dir,

Il faut que tu contrôle sur ta carte si tu n'as pas un problème de connectique ou si tu n'a pas inverser min et max.

Si c'est bon contrôle dans marlin si le endstop Y n'est pas inverser ( false ou true).

Merci pour ta réponse mais j'ai un peu de mal :P

 

Pour le 1: je ne trouve pas cette ligne, c'est dans quel onglet s'il te plait?**

Pour le 2: Pas de soucis de connectique. Du coup, même soucis, où trouver ça dans Marlin ouvert avec Arduino ?

 

**Voila le Marlin que j'utilise: http://pobo.lt/3Dinstructions/Marlin_Prusa_i3_Rework_1.5.zip 

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 2 minutes, Patdemille a dit :

Pour le problème d'inversion, si c'est une prusa, y'as un problème d'inversion sur la notice. Il suffi d'inverser le branchement.
Moi j'ai inversé et aucun problèmes
:)

.

Merci pour ta réponse. Tu as inversé complètement la prise du moteur sur la carte ? Ou tu inverses juste le rouge et le noir ? Merci :)

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 14 minutes, philippem a dit :

sinon oui c'est plus simple, dans marlin c'est configuration.h

PROBLEME 1 RESOLU ! Dans Marlin, merci ;)

 

Pour le PROBLEME 2, que dois je tenter de modifier la dedans: ? :/ 

Citation
// ENDSTOP SETTINGS:
// Sets direction of endstops when homing; 1=MAX, -1=MIN
#define X_HOME_DIR -1
#define Y_HOME_DIR -1
#define Z_HOME_DIR -1
 
#define min_software_endstops true // If true, axis won't move to coordinates less than HOME_POS.
#define max_software_endstops true  // If true, axis won't move to coordinates greater than the defined lengths below.
 
// Travel limits after homing
#define X_MAX_POS 188
#define X_MIN_POS 0
#define Y_MAX_POS 188
#define Y_MIN_POS 0
#define Z_MAX_POS 190
#define Z_MIN_POS 0
 
#define X_MAX_LENGTH (X_MAX_POS - X_MIN_POS)
#define Y_MAX_LENGTH (Y_MAX_POS - Y_MIN_POS)
#define Z_MAX_LENGTH (Z_MAX_POS - Z_MIN_POS)
  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 15 minutes, philippem a dit :

non regarde dans les endstop tu as des lignes avec min max, et true ou false

Voila ce que j'ai ; que changer ? :/

// Uncomment the following line to enable CoreXY kinematics
// #define COREXY
 
// coarse Endstop Settings
#define ENDSTOPPULLUPS // Comment this out (using // at the start of the line) to disable the endstop pullup resistors
 
#ifndef ENDSTOPPULLUPS
  // fine endstop settings: Individual pullups. will be ignored if ENDSTOPPULLUPS is defined
   // #define ENDSTOPPULLUP_XMAX
   // #define ENDSTOPPULLUP_YMAX
   // #define ENDSTOPPULLUP_ZMAX
   // #define ENDSTOPPULLUP_XMIN
   // #define ENDSTOPPULLUP_YMIN
   // #define ENDSTOPPULLUP_ZMIN
#endif
 
#ifdef ENDSTOPPULLUPS
  #define ENDSTOPPULLUP_XMAX
  #define ENDSTOPPULLUP_YMAX
  #define ENDSTOPPULLUP_ZMAX
  #define ENDSTOPPULLUP_XMIN
  #define ENDSTOPPULLUP_YMIN
  #define ENDSTOPPULLUP_ZMIN
#endif
 
// The pullups are needed if you directly connect a mechanical endswitch between the signal and ground pins.
const bool X_MIN_ENDSTOP_INVERTING = true; // set to true to invert the logic of the endstop.
const bool Y_MIN_ENDSTOP_INVERTING = true; // set to true to invert the logic of the endstop.
const bool Z_MIN_ENDSTOP_INVERTING = true; // set to true to invert the logic of the endstop.
const bool X_MAX_ENDSTOP_INVERTING = true; // set to true to invert the logic of the endstop.
const bool Y_MAX_ENDSTOP_INVERTING = true; // set to true to invert the logic of the endstop.
const bool Z_MAX_ENDSTOP_INVERTING = true; // set to true to invert the logic of the endstop.
 
//#define DISABLE_MAX_ENDSTOPS
//#define DISABLE_MIN_ENDSTOPS
 
// Disable max endstops for compatibility with endstop checking routine
#if defined(COREXY) && !defined(DISABLE_MAX_ENDSTOPS)
  #define DISABLE_MAX_ENDSTOPS
#endif

Partager ce message


Lien à poster
Partager sur d’autres sites

Je toruve vraiment le problème curieux, J'ai changé le cable, le capteur, rien n'y fait. Donc peut-être que cela vient de mon cablage ?

Je vous mets en photo la notice (peu claire sur ce point, les schemas sont entre deux rangées de broches), et une photo de mon cablage. Est-ce que j'ai bien fait celui-ci ? :/ 

Merci beaucoup à ceux qui tentent de m'aider

bateau3.JPG

13702362_1474725445887128_1300144355_o.jpg

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 1 heure, legired a dit :

Euh, perso j'ai le kit emotion tech (que j'ai modifier par la suite) le capteur n'est pas du  tous la

https://data.emotion-tech.com/highlights_fr/Prusa_i3_Rework_rev1.5 - Notice assemblage.pdf 

 

page 77 

oui y'as pas une carte spécial pour l'inductif ?

Mais bon si il as un prob en Y ... essaye peut être de débranché le z et test le Y sans le capteur inductif ....

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 11 heures, legired a dit :

Euh, perso j'ai le kit emotion tech (que j'ai modifier par la suite) le capteur n'est pas du  tous la

https://data.emotion-tech.com/highlights_fr/Prusa_i3_Rework_rev1.5 - Notice assemblage.pdf 

 

page 77 

BIZARRE en effet ! Je n'ai aucune carte et ne me suis même pas posé la question car voila la notice fournie par mon vendeur :

http://pobo.lt/3Dinstructions/Prusa_i3_Rework_rev1.5 - Assembly instructions.pdf

page 73

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 9 heures, Patdemille a dit :

oui y'as pas une carte spécial pour l'inductif ?

Mais bon si il as un prob en Y ... essaye peut être de débranché le z et test le Y sans le capteur inductif ....

J'ai essayé sans succès :/ J'ai peur que la broche soit cramée sur la carte Ramps... Y a t-il un moyen de le mettre autrement ?

Partager ce message


Lien à poster
Partager sur d’autres sites
Invité
Ce sujet ne peut plus recevoir de nouvelles réponses.

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×