Aller au contenu

Filament ABS

ecran tft okay en mode marlin mais non connecté en mode touchscreen


Messages recommandés

déjà bonjour a tous ^^ j'ouvre ce topic parce que depuis 2 jour j'essaye de connectez mon écran btt tft 70 a ma carte btt skr2 et je n'arrive pas a la faire fonctionnez via la connexion rs232 (avec le power additionnel ) ca marche super en mode marlin comme dit dans le titre mais bon un écran 7" c'est déjà beaucoup mais alors pour juste le mode marlin 🤣

donc j'ai essayer :

-avec et sans les port exp connectez

 -avec et sans les pin power supplémentaire 

  -et échangeant les fils tx2 et rx2 

   - j'ai vérifier la continuité de mes câble c'est okay ( meme si le rx2 cote ecran est reliez au ground ..... je trouve ca bizarre mais j'ai pas vraiment les connaissance pour savoir si c'est normal ou pas )

   - et j'ai verifiez avec un doublon (erreur de livraison aliexpress on va pas ce plaindre ) et j'ai exactement le meme comportement que sur le premier 

 - et je vien de testez un tft 28 pareil marche pas 

 

j'ai du passez a cotez de quelque chose d'evident mais je voit pas quoi 

 

ps: j'ai oubliez de précisez avant mais j'ai suivie a la lettre près les instruction donnée par bigtreetech sur leur github et revérifiez ca au moins 3 fois (https://github.com/bigtreetech/BIGTREETECH-TouchScreenFirmware)

Modifié (le) par ikizami
Lien vers le commentaire
Partager sur d’autres sites

Salutation !

Tu a quoi comme port série de déclaré sous le marlin ? un truc comme cela ?

#define SERIAL_PORT -1 //TFT //USB
 
/**
* Select a secondary serial port on the board to use for communication with the host.
* :[-1, 0, 1, 2, 3, 4, 5, 6, 7]
*/
#define SERIAL_PORT_2 2 //USB //TFT

 

C'est ti comme avec un TFT35 tu clic long sur la molette et y a un menu pour choisir entre le mode marlin et le mode tft ?

Tu nous fait des photos de tes branchements ?

  • +1 1
Lien vers le commentaire
Partager sur d’autres sites

  • fran6p changed the title to ecran tft okay en mode marlin mais non connecté en mode touchscreen

Pour un TFT 7 avec carte BTT SKR2, d'après mon guide de référence : BTT TFT to BTT Mainboards 2021-May.pdf

La déclaration dans Marlin doit être :

Citation

#define SERIAL_PORT 1

#define SERIAL_PORT_2  -1

#define BAUDRATE 115200

🙂

Lien vers le commentaire
Partager sur d’autres sites

déjà merci @PPAC et @fran6p d'avoir répondu si vite mais ducoup je vais préciser un peu oui ppac c'est comme un tft 35 et oui j'ai suivi le meme guide de référence que toi fran6p il est sur le lien que j'ai mis dans mon premier post donc j'ai suivi ca en premier lieu et fait tous mes branchement innocemment pensent que c'etait okay (sur la mks sgen l v2 +tft35 e3 v3 c'etait aussi simple que ca en tous cas ) mais la big tree tech me rajoute toute la liste en lien de ce post 

 

et pour être sur ppac je t'ai fait un paint moche de mon câblage donc en intervertissant les câble pa9 pa10 ca change rien (sachant que je suis passez sur un connecteur jst propre en prime donc le cablage devrais pas etre un soucis)

 

 

tft70 doc 1.png

tft70 doc 3.png

tft70 doc 2.png

Modifié (le) par ikizami
Lien vers le commentaire
Partager sur d’autres sites

A tu bien le même baudrate entre le port ayant le numéro -1 du marlin

Ex si tu a 

#define SERIAL_PORT_2 -1 // -1 = TFT

alors il faut 

#define BAUDRATE_2 115200

 

et le baudrate de communication dans le firmware de l’écran ?

Pour le firmware de l'ecran pour modifier le baudrate : soit dans config.ini (si le même genre qu'un TFT35) ou via l'écran du tft en mode tft : Menu, Options, Connexion, Vitesse, et cocher 115200.

#### Baudrate / Connection speed
# This baudrate setting is used for serial connection to the printer and other serial hosts like ESP8266.
#   Options: [2400: 0, 9600: 1, 19200: 2, 38400: 3, 57600: 4, 115200: 5, 250000: 6, 500000: 7, 1000000: 8]
baudrate:5

Modifié (le) par PPAC
Lien vers le commentaire
Partager sur d’autres sites

oui oui sauf que j'ai pas changer baudrate_2 parceque j'en ai pas l'utilite pour l'instant et le baudrate de l'ecran aussi est bien défini j'ai vérifier ( j'ai passez deux jour a mouliner je compte meme pas le nombre de fois ou j'ai re-flasher rééditer vérifier sur l'ecran tous est okay normalement d'ou mon incompréhension ) 

ps: pour verifier si mes flash son bien pris en compte je fait truc un peu bidouiller je modifie la led du knob justement et pas de soucis peux re-flasher 3 fois de suite avec trois couleur defini dans config.ini tous s'applique bien pareil pour ma carte je joue avec les pin ventilo faute de led 

 

doc 4.png

je peux envoyer un lien google drive si jamais vous voulez y jetez un coup d'oeil aussi mais je prefererais en mp pas specialement l'habitude d'utiliser drive 

Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

  • YouTube / Les Imprimantes 3D .fr

×
×
  • Créer...