Aller au contenu

Filament ABS

Mach1

[RESOLU] blocage moteur avec G28 !?

Messages recommandés

Bonsoir les gens,

je post rarement parce que je cherche et lit beaucoup, malheureusement je trouve rien sur mon problème,  j'espère donc trouver de l'aide ici ! 

 

Voilà la situation, après bientôt 2 ans de bons et loyaux services de ma printeusse à base de prusa,  j'ai rencontré quelques soucis de différents ordres. Compte tenu des evolutions après une grosse révision d'ensemble,  je mets à jour le firmware marlin 1.1.0-RC7 et les softs qui datent de la fabrication de la machine. Je supprime le serveur octoprint pour prendre la main sur l'imprimante par RepetirHost 1.6.2.

 

Après quelques heures à etudier et régler le firmware tout bouge dans les bons sens, je refais une thermotable au degrés près du hotend, les origines de X et Y, bref tout gaz !

Sauf l'origine du Z, la apparaît un problème,  si j'utilise une commande G90 pour Z en monté ou descente, cela fonction parfaitement.  Si j'utilise un G28 pour trouver l'origine de Z les moteurs ce lancent et bloque comme ci il manquait de courants ! ?

Je controle et test des reglages différents de courant, rien ni fait. J'ai ralenti l'accélération de Z dans le firmware marlin, pas mieux ! Tout les problèmes que j'ai eu avant ne concernait que des jeux pris à force d'utilisations rien concernant le reglage de Z ou des moteurs.

 

Je pense donc a un soucis de paramètre dans le firmware, je suis en contacteur endstop et pas en autonivellement par capteur de proximité,  c'est certainement lié mais je ne trouve pas !?

Quelqu'un aurait il une idée ? 

Cordialement 

Mach1 

Modifié (le) par Mach1

Partager ce message


Lien à poster
Partager sur d’autres sites

T'as l'auto bed leveling ? (pas bien compris)
Je crois qu'il est activé d'office si mes souvenirs sont bon (à confirmer). L'erreur vient peu être de la ?
Tu peux mettre ton fichier configuration.h stp ? ;)
Sinon on va attendre les barbus !

Partager ce message


Lien à poster
Partager sur d’autres sites

on est encore la lo pas encore couché !

Autobed n'est pas défini par défaut, par contre si il est activé est que tu as un endstop mécanique il se peux que tu est un conflit

Pour une prusa, tu peux prendre le marlin rc qui est assez complet et stable

Modifié (le) par Morpheus

Partager ce message


Lien à poster
Partager sur d’autres sites

c'est le homing général des axes

quand tu fait un g28, les trois axes vont se positionner sur le min donc en endstop

Quand tu fait un homing si un endstop merde, les moteurs claques, car il n'a pas l'info de fin de manœuvre, et quand le z et en mécanique et que tu active l'autobed, tu peux mettre en conflit des paramètres, c'est déjà arriver

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon je confirme que le fait d'activer le Endstop ne suffit pas !

Il y a une ligne a de-commenter en début de l'autolevel pour l'activer en theorie, mais cela bug et rentre en conflit avec le endstop. J'ai commenter l'ensemble de la section autolevel et le problème est résolu !

 

Merci beaucoup pour votre réactivité

 

Bien à vous

Mach1

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut Morpheus,

Désolé je n'ai ni Tête de livre ou autre haut-parleur aiguë en folie ! (Pour vivre heureux .......).

Mais je vais traîner un peu sur le forum, j'ai vue une section CNC et je suis en train de ressusciter une "vielle" CNC qui tournait sous DOS !

Bien à toi

Mach1

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×