Aller au contenu

Filament ABS

denybear

Problème de mise à jour Firmware

Messages recommandés

Bonjour, j'ai une DE 200 et je n'arrive pas à la mettre à jour avec le dernier firmware.

J'ai fait mes essais sur PC Linux (ubuntu 16.04) en root, Dagom App (dernière version): l'imprimante est bien reconnue, j'utilise Dagom App pour régler l'offset Z. Par contre, j'ai le message   "La mise à jour a connu une erreur" après 30 secondes de logo Dagoma qui tourne...

Mes questions:

  1. Quelqu'un d'autre a-t-il eu le même problème ?
  2. Hormis Dagom'App, y a-t-il d'autres moyens de mettre à jour le firmware (via SD card, ou via un autre soft) ?
  3. Pour les personnes de Dagoma : Y a-t-il un moyen d'avoir une erreur plus précise que  "La mise à jour a connu une erreur" ? ou un fichier log ?

 

Je vais essayer en Windows 10 ce week-end, mais je suis pessimiste, la dernière fois que j'ai essayé, mon imprimante n'était même pas reconnue... pb de driver surement (je suis en admin).

Et pourtant mon imprimante fonctionne nickel !

Merci pour vos réponses.

  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Sur Windows 10, installez d'abord CuraByDagoma Easy 200 avant d'utiliser dagomApp. Cela installera tout les drivers nécessaire.

Mais pour l'erreur plus détaillée c'est noté.

Sinon vous pouvez toujours essayer avec Arduino mais c'est plus complexe. Le plus simple est d'essayer avec un autre ordinateur en vitesse ;D

Partager ce message


Lien à poster
Partager sur d’autres sites

bonjour,

il y a une heure, Tibus a dit :

Sinon vous pouvez toujours essayer avec Arduino mais c'est plus complexe.

Avec les vieux Marlin distribué au début par Dagoma, j'arrivais à flasher la melzi avec arduino 1.0.5 (la 1.0.6 était préconisé mais la 1.0.5 faisait le job)
Maintenant avec les nouveaux issus de http://dist.dagoma.fr/betagoma il faut arduino1.6 et + (j'ai 1.6.12) mais je n'arrive pas a flasher, la compilation se passe bien sans erreur mais le téléversement échoue.
J'utilise 1.6 avec une autre carte (un arduino uno) sans difficulté, mais pour la melzi ça coince chez moi, j'utilise le json recommandé pour "sanguino"
https://raw.githubusercontent.com/Lauszus/Sanguino/master/package_lauszus_sanguino_index.json
et la carte est pourtant bien reconnu.

Je creuse pour faire fonctionner la chose, car c'est frustrant de pouvoir flasher (désolé @denybear moi ça marche) les firmwares récents avec Dagom App, mais sans pouvoir les modifier ! (pour activer le software PWM par exemple...)
Au pis je vais chercher le hex produit par la compilation sous arduino 1.6.12 et tenter de le flasher via Dagom App.

@denybear Le wiki de ArchLinux est très fourni pour l'utilisation des arduinos, peut être peux tu y trouver des info utiles même pour ubuntu.

(Edite) en fait mon installation de arduino 1.6.12 ne marche plus avec mon uno aussi. C'est plutôt rassurant dans le fond cela plaide pour un pb de configuration globale à arduino IDE et pas un pb particulier pour la Melzi.

a+

  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

J'ai retenté une mise à jour sous Windows 10 et là, la mise à jour marche. Les pré-requis:

- Installer CurabyDagoma avant toute chose pour ne pas avoir de problème de driver.

- Lancer Dagom'App en tant qu'administrateur

 

Je vais re-essayer sous Linux pour voir si je trouve le problème...

Partager ce message


Lien à poster
Partager sur d’autres sites

Perso j'ai fait la mise à jour du firmware pour la DE200 avec Arduino 1.6.12 sous windows 7 sans pbs en selectionnant type de carte Arduino/Genuino Mega or Mega 2560 , processeur ATmega2560 et le bon port COM (COM3 pour moi)

  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Alors moi je viens d'avoir le meme problème, par dagom'app et arduino 1.6.12 ca me mettait respectivement La mise à jour a connu une erreur et time out. J'ai réessayé avec dagom'app en débranchant tout ce qui était branché sur la carte ( surtout l'écran) et la magie ca a fonctionné!

Partager ce message


Lien à poster
Partager sur d’autres sites

@denybear j'ai le même problème que toi. Je vais essayer le support dagoma sur dagomapp avant de passer en mode ninja avec arduino et avrdude et compagnie.

@Athon7913 cool, j'envisage de faire pareil, du coup tu as pas eu besoin de rajouter sanguino comme décrit http://blog.dagoma.fr/tutoriels/mise-a-jour-de-la-carte-electronique/ ? Bon, j'imagine que cela ne s'applique pas à la Discovery200...

Partager ce message


Lien à poster
Partager sur d’autres sites

avec ubuntu 16.04 j'ai utilisé IDE 1.6.10 sans problème.

Ne pas oublié de mettre son user dans le groupe dialout pour ne pas à avoir à passer en root. Je fais toutes mes actions avec mon user sans sudo.

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant


×