Aller au contenu

Filament ABS

Gazton

Plusieurs problème de débutant

Messages recommandés

Bonjour Tous,

Bon je suis prêt, ou presque. La control box, s'allume, j'ai installé le BLtouch en provisoire, mais sa tiens. Les moteurs tournent. J'ai plusieurs problème, j'en ai déjà résolu un, j'ai pu mettre à jour le firmware de ma Tevo BW comme indiqué sur ce PDF, et j'ai donc installé le Marlin _RC6_Black Widow-BL Touch.zip. Hors, malgré tout, l'axe Z ne va que vers le haut, à aucun moment il ne vas vers le bas. La tige du BLtouch sort, il monte sur quelques mm, se déplace, remonte sur quelques mm, se déplace, remonte sur quelques m, etc...etc... Jusqu'au point ou je dois l’arrêter sinon il taperais dans la barre du haut. Avec le firmware d'origine jamais le même problème, donc je me demande si ça ne serait pas matériel. Je vais quand même essayer de mettre le programme sans le BLtouch, juste pour voir.

Autre problème, je n'arrive pas a connecté la machine avec pronterface. J'ai fais tout comme il dit dans la vidéomais j'ai un message d'erreur qui parle de vitesse transmission :

messerreur.jpg

Si vous pouviez m'aider se serait gentil, car je manipule tout ça pour la 1er fois.

@+ Gazton

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut 

Pour l'erreur ponterface c'est la vitesse de transfert, le baudrate qui est mal configurer sur le port com. Le mettre à 115200 si ça passe pas en 250000. Tu peux le régler dans le logiciel me semble.

Pour le premier soucis, j'ai pas tout compris.

Modifié (le) par juanpa

Partager ce message


Lien à poster
Partager sur d’autres sites

Ou 250000 si tu es déjà à 115200 ^^

2016-11-13.png

Modifié (le) par meercura

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci @juanpa et @meercura, j'ai fait la modif en indiquant 250000 au lieu de 115200 et la connexion est établie, et ça marche, les axes bougent.

Pour ce qui est de mon autre problème, je vais essayé d'être plus clair. J'ai branché mon BLTouch, au vu des images sur la vidéo, j'avoue avoir un doute sur le sens des fils, mais j'ai essayé dans les 2 sens et le problème reste le même. Lorsque je lance le "Level Bed" comme c'est indiquer sur la machine, la buse ne descend pas pour aller palper le plateau, elle monte. Elle est sensé palpé plusieurs points sur la surface. Donc lorsque le programme commence, la buse se positionne en position X=0 et Y=0, le palpeur du BLtouch sort, et au lieu de descendre pour aller toucher le plateau, la tête monte de quelques mm, s'arrête puis se déplace au point suivant alors qu'elle n'a pas toucher le plateau. Elle s’arrête au  2eme point, pareil, le palpeur est déjà en position, elle monte au lieu de descendre de la même valeur que précédemment, s'arrête, et se déplace au 3eme point, et ainsi de suite. Je ne sais pas combien de point il y a au total car elle avait démarrer le cycle assez au haut et j'ai du l'arrêter avant qu'elle touche la traverse du haut.

Depuis j'ai installé le firmware pour l'utilisation sans le BLtouch, Et la ça marche, lorsque je lance le même programme, elle vient se mettre en position à faible hauteur du plateau, et me demande de régler la hauteur. Mais j'ai un nouveau problème, le réglage se fait en 9 pts, et les pt n° 4, 7, 8 et 9 sont en dehors du plateau, malgré le capteur en X. La je penche plus pour un problème de conf. Qu'en pensez vous ?

@+ Gazton

Partager ce message


Lien à poster
Partager sur d’autres sites

Je viens relire ce que tu as écrits , la je parle pour le Bl touch quand l'auto-leveling est activé.

Tu peu modifier les coordonnées de la zone palpation de Marlin et en dessous le nombres de points à palper. ( 2 = 4 points, 3 = 9 points ).

Mais un peu bizarre que tu es à modifier cela , vu que le fichier est pré-configurer pour ta machine .
 

2016-11-13 (1).png

Modifié (le) par meercura

Partager ce message


Lien à poster
Partager sur d’autres sites

Ton BLTouche sort du plateau:

Dans ton Marlin tu devrait aussi régler les offset X et Y du BLTouche en fonction de la buse. T'a peut être fait l'erreur de coordonnées positif et négatif. 

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 1 heure, meercura a dit :

Je viens relire ce que tu as écrits , la je parle pour le Bl touch quand l'auto-leveling est activé.

Tu peu modifier les coordonnées de la zone palpation de Marlin et en dessous le nombres de points à palper. ( 2 = 4 points, 3 = 9 points ).

Mais un peu bizarre que tu es à modifier cela , vu que le fichier est pré-configurer pour ta machine .
 

2016-11-13 (1).png

OK, pour le BLtouch, je vais contrôler les valeurs par rapport à la vidéo, effectivement il en modifie plusieurs, je vais comparer.

Il y a 1 heure, nicephore a dit :

Ton BLTouche sort du plateau:

Dans ton Marlin tu devrait aussi régler les offset X et Y du BLTouche en fonction de la buse. T'a peut être fait l'erreur de coordonnées positif et négatif. 

Ce n'est pas le BLtouch qui sort du plateau dans ce cas, car j'ai chargé le firmware sans BLtouch. Non c'est la buse qui est en dehors du plateau, je ne peux donc pas régler la hauteur. Je suppose que c'est aussi des les fichiers de conf, je vais jeter un œil.

@+ Gazton

Partager ce message


Lien à poster
Partager sur d’autres sites

Ça y est j'ai trouvé, je savais bien que c'était hardware. Les maudits débutants qui font attention à rien !! J'ai vérifié de nouveau mes branchements et je me suis aperçu qu'il fallait connecté le BLtouch sur la même broche que le capteur de limit de l'axe Z, du moins je pense que c'est celui-là, je n'ai pas suivi tout le fil. Donc maintenant, il descend bien :D. Il ne reste plus qu'un dernier détail à régler, sur la vidéo sont BLtouch s'illumine d'une loupiote verte alors que la mienne est rouge. Une fois régler ce dernier point de détail, cela devrait rouler.

@+ Gazton

  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour à tous,

Quelques nouvelles, les soucies de conf commencent gentillement à se régler, et mon BLtouch est maintenant pratiquement fonctionnel. J'apprend aussi a utilisé pronterface, qui est contrairement aux premiers abord, bien plus complet qu'il n'y parait. Ça me rappel mes années lycée et la programmation en num :P. Il a fallut décodé tout ça, mais bon ça vient doucement. J'ai reçu la pièce de @nicephore, et j'ai pu l'installer dès ce midi. Comme promis, j'ai fait plein de photos pour préparer mon tuto du montage de se sacrer BLtouch qui m'aura donné du fil a retordre. Il ne me reste plus qu'a trouvé un vitrage pour posé sur le plateau, parce que c'est juste pas possible (comme dirait ma fille) d'imprimé sur celui d'origine qui doit avoir pas loin d'1/2 mm de flambage.

Donc pour le moment plus de question, mais ça va sans doute revenir très rapidement :D.

@+ Gazton

  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut @nicephore, mon plateau fait 40x25 cm, ça va malheureusement être un peu juste.

D'ailleurs, un verre standard suffit ou il vaut mieux en prendre un trempé ?

@+ Gazton

Modifié (le) par Gazton

Partager ce message


Lien à poster
Partager sur d’autres sites

Yop tout le monde !

@Gazton Le top serait une plaque de PEI qui offre une excellente adhésion des pièces et un décollement facilité. Le seul véritable problème est de trouver à la dimension qu'il nous faut...

Concernant le BL Touch, chez moi il s'illumine également en rouge et à l'heure actuelle, toujours pas parvenu à le faire fonctionner...

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai eu le même souci que toi sur le réglage, je te rassure. Comme plusieurs attende avec impatience, je vais commencé mon tuto, si tout va bien ce soir.

@+ Gazton

Partager ce message


Lien à poster
Partager sur d’autres sites

C'est très sympa de ta part @Gazton pour le tuto !

Clair que c'est rageant de ne pas pouvoir lancer une impression avec la machine assemblée :S

Pourtant j'ai suivi à la lettre ce tutoriel vidéo mais malgré cela, ce que j'obtiens chez moi ne ressemble pas à la vidéo ! lol

Et je me demandais aussi s'il ne faut pas enlever le capteur de l'axe Z (qui est présent sur la vidéo) qui fait peut-être en sorte d'embrouiller la carte plutôt qu'autre chose ?...

Tu as du faire beaucoup de modifications pour parvenir à faire fonctionner ce BL Touch ?

Modifié (le) par Kharr

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 4 minutes, Kharr a dit :

Et je me demandais aussi s'il ne faut pas enlever le capteur de l'axe Z (qui est présent sur la vidéo) qui fait peut-être en sorte d'embrouiller la carte plutôt qu'autre chose ?...

Normalement c'est le BLTouch qui le remplace. Du moins c'est comme ça que fonction ces types de dispositif.

Partager ce message


Lien à poster
Partager sur d’autres sites

Arf! Voila !

C'est bien ce qu'il me semblait... certainement que le capteur de fin de course pour l'axe Z interfère sur le travail du BL Touch.

Je compte faire un essai en supprimant le capteur de fin de course, comme ça je serais vite fixé !

Merci pour ta réponse @nicephore.

Partager ce message


Lien à poster
Partager sur d’autres sites

Je viens de regarder la vidéo le paramètre Z_MIN_ENDSTOP_INVERTING est à passé à false (donc cpateur de type NC = fermé) alors qu'avant il était NO (ouvert). Vous l'avez bien changé ?

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 16 minutes, nicephore a dit :

Je viens de regarder la vidéo le paramètre Z_MIN_ENDSTOP_INVERTING est à passé à false (donc cpateur de type NC = fermé) alors qu'avant il était NO (ouvert). Vous l'avez bien changé ?

Oui, enfin, de mon côté j'ai bien changé cette valeur.

Bon, je viens de refaire un essai en débranchant le capteur de fin de course pour Z.

Sous Pronterface, un G28 et vers le milieu du plateau, le BL Touch a fait une palpation... il y a du mieux donc ! Par contre, la buse est encore venue se fourrer dans le plateau...

Modifié (le) par Kharr

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a une heure, Kharr a dit :

Yop tout le monde !

@Gazton Le top serait une plaque de PEI qui offre une excellente adhésion des pièces et un décollement facilité. Le seul véritable problème est de trouver à la dimension qu'il nous faut...

Concernant le BL Touch, chez moi il s'illumine également en rouge et à l'heure actuelle, toujours pas parvenu à le faire fonctionner...

Alors vu les caractéristiques du PEI, je pensé effectivement que sa serait bien, mais la plaque de 60x60 cm ep 1,6 mm, à recouper donc, au petit prix de 434€ la plaque. Ben ça fait un peu chère :P : Lien

Et effectivement, c'est bien le capteur qui gêne pour la BLTouch, j'ai trouvé l'astuce pas hazard, si ton capteur détecte qu l'air chose et ben c'est la memerde... Moi je l'ai légèrement descendu, je préfère le laisse quand même au cas où, mais je pense que tu peux l'enlever.

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×