Aller au contenu

Filament ABS

lgjean

[SmartrapCore] G29 autolevel teigneux !

Messages recommandés

Bonjour

 

Il se passe des choses étrange sur me Smartrapcore ! Je tranche avec Slic3r et Pronterface pour piloter la bécane...

Sur pronterface dans la fenêtre "manuel" je tape G28 x,y,z  puis G29. Aucun soucis, le home et l'auto level sont ok.

Je lance une impression d'un fichier issu de Slic3r , il me fait un home et probe bed, mais lors de ces derniers l'espacement des points sont bien plus grand et ça m'envoie le chariot taper le fond de l'imprimante !

Pourtant le GCODE généré par Slic3r le voici :

"""""
; generated by Slic3r 1.2.9 on 2017-03-24 at 17:23:38

; external perimeters extrusion width = 0.50mm
; perimeters extrusion width = 0.72mm
; infill extrusion width = 0.72mm
; solid infill extrusion width = 0.72mm
; top infill extrusion width = 0.72mm

M109 S200;set extruder temp and start heating
G28 X0 Y0 Z0;home X and Y and Z
G29 ;probe bed
G90; set absolute coordinates
G92 E0; reset extruder distance
G1 Z3 F3000; get out of the bed after probe
G1 X10 Y10 F3000 ; move to back right corner
G21 ; set units to millimeters
G90 ; use absolute coordinates
M82 ; use absolute distances for extrusion
G92 E0
M106 S204
etc...
"""""""""

La commande est la même, les home sont bien tous à zéro !
J'ai tenté de réduire la taille du bed dans Slic3r mais aucun effet, le GCODE est le même au début !

J'ai manifestement manqué un truc !
Pouvez vous me dire ce qu'il en est ?

Merci

Partager ce message


Lien à poster
Partager sur d’autres sites

Je viens d'essayer avec Repetier Host et j'ai le même phénomène ! Quand j'entre G29 en manuel c'est ok, quand je lance une impression (qui contient la même commande) les coordonnées sont très différentes, il y a même un offset au niveau du Z (il commence plus haut du bed).

Il y a un truc qui s'insère donc entre le GCODE du trancheur et l'Arduino !

:o

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai regardé les options, j'ai mis la taille de mon bed à 100mm et cela ne change rien !

J'ai lancé l'impression et j'ai vu qu'il me rajoute des commandes !

757840Sanstitre.jpg

 

J'ai regardé dans le firmware dans configuration.h je ne vois pas ces paramètres !

J'ai même re télégarger et ré installer le firmware c'est pareil O.o

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai bien ceci dans le fichier de config du firmware :

"""""
#define AUTO_BED_LEVELING_GRID
  // with AUTO_BED_LEVELING_GRID, the bed is sampled in a
  // AUTO_BED_LEVELING_GRID_POINTSxAUTO_BED_LEVELING_GRID_POINTS grid
  // and least squares solution is calculated
  // Note: this feature occupies 10'206 byte
  #ifdef AUTO_BED_LEVELING_GRID

   // reglage pour la prod
    // set the rectangle in which to probe
    #define LEFT_PROBE_BED_POSITION 10
    #define RIGHT_PROBE_BED_POSITION 130
    #define BACK_PROBE_BED_POSITION 160
    #define FRONT_PROBE_BED_POSITION 40
"""""""

Ca correspondrait, mais ça me parait lourd de devoir recompiler à chaque fois pour faire les réglages !
D'autant que dans tous les logiciel de pilotage il y a les paramètre du bed mais qui ne sont pas pris en compte !?

N'y aurait-il pas un firmware plus souple où on intervient seulement au niveau logiciel ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon je retrouve mes petits dans le fichier config. Je le sauvegarde et le bidouille par rapport à ma mécanique.

Si ça foire encore on se retrouve ici lol

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

si tu as modifier les valeurs dans cette section de Marlin tu auras juste modifier les valeurs de points de mesure pour l'autolevel

Partager ce message


Lien à poster
Partager sur d’autres sites

Coucou  8)

Je voudrais modifier l'offset de mon Z directement dans le cambouis.. heu pardon dans le fichier configuration.h (sans passer par l'EEPROM donc) mais je ne trouve pas la bonne ligne ! J'ai trouvé plein de chose intéressante mais rien sur ce maudit offset !

Merci

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×