Aller au contenu

Filament ABS

Kitetkat

Imprimante qui chauffe et s'arrête

Messages recommandés

Bonjour

J'ai l'imprimante (Discovery200) qui chauffe normalement puis se refroidit, se qui évidement, pose problème.

De quoi cela pourrait-il venir?

Je n'ai pas trouvé de sujet ce rapportant à ce problème.

Merci de votre attention

PS: Au vu de la date merci d'évité le poisson.

Kitetkat

Modifié (le) par Kitetkat

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour @Kitetkat, peux-tu en dire plus ?

J'ai eu un problème de ce genre, mais dans des circonstances très particulières, avec un cura 2.4 mal configuré par mes soins.
Mon problème venait du g_code de démarrage. Je l'avais récupérer sur le site de Dagoma dans la description de la configuration de cura 15.04 pour la discovery 200.
Mais entre Cura 15# et Cura 2.# les noms des variables utilisables dans le g_code ont changés.
Avec Cura 2.4 il ne faut plus utiliser {print_temperature} mais {material_print_temperature}, de même pour mon lit chauffant {print_bed_temperature} est a remplacer par {material_bed_temperature} et {travel_speed} par {speed_travel}.

Le fait que la variable {print_temperature} était inconnue définissait la consigne de chauffe à 0 degré en début d'impression, mais n’empêchait pas le chauffage initial.
L'impression (en usb) de la première couche démarrait correctement, mais comme la chauffe de la tête n'était plus assuré la sécurité contre l'extrusion à froid coupait assez rapidement l'extrusion quand la température de la tête finissait par descendre sous les 160 degrés.

a+

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut et merci du retour

En dire plus, je voudrais bien mais les symptomes sont ceux que tu d'écris.

J'ai juste un soucis avec la résolution car je n'ai rien touché.

Cura est le même et je n'ai pas téléchargé d'autre version que celle de Dagoma avec l'imprimante.

D'ailleurs j'ai repris d'autre fichiers gcode et même résultat.

Donc que dois-je faire ?

 

@+

Modifié (le) par Kitetkat

Partager ce message


Lien à poster
Partager sur d’autres sites

As-tu essayé d'envoyer un "M109 S210" (ordre de chauffe à 210 degré)  de manière interactive en usb via Pronterface ou repetier.
Tu pourras suivre la courbe de température et voire si la régulation est bonne.
Si cela ce passe bien, on peut sans doute exclure un problème matériel (alim, surchauffe d'un driver, câblage mal serré ou coupé, sonde...) ouvre avec un éditeur de texte un fichier g-code généré par ton cura pour un stl quelconque et regarde au début de fichier si tu y voie des M109 ou M104 suspect comme "M109 S0".
Je n'ai pas compris quel cura tu utilise Cura ou Cura par Dagoma ni en quel version.

Partager ce message


Lien à poster
Partager sur d’autres sites

Ha mais je ne suis pas en USB donc je ne peux rien changer

Et c'est cura by dagoma version de l'année dernière

Ok en editant

M109 = S180

M104 = S210

Elle chauffe et s'arrête ensuite

Par contre je vois un M106 = S255

Partager ce message


Lien à poster
Partager sur d’autres sites

Le M106 c'est pour le ventilateur.
Avec un cable usb c'est plus facile, mais tu peux aussi vider un fichier gcode et ne laisser dedans que
M106 S255; fan au max
M109 S180; chauffe a 180
 

Partager ce message


Lien à poster
Partager sur d’autres sites

Par contre pour mettre en USB c'est lequel de cavalier a bouger ?

Celui du milieu ou celui au centre ?

 

Ok j'ai trouver la réponse :)

Modifié (le) par Kitetkat

Partager ce message


Lien à poster
Partager sur d’autres sites

mettre a jour la mémoire flash de la carte électronique (melzi) avec une nouvelle version du firmware (Marlin).
On n'en est pas là !...

Partager ce message


Lien à poster
Partager sur d’autres sites

Dans un premier temps

installe pronterface (tu peux le telecharger chez dagoma dans la rubrique logiciel pour la discovery)
tu devras peux être avant installer des drivers... ils sont aussi sur le site de Dagoma
 

Modifié (le) par r2d2
ortograf !

Partager ce message


Lien à poster
Partager sur d’autres sites

- si nécessaire, installe les drivers de l'imprimante (https://dagoma.fr/tutoriels/logiciels-discovery200.html en bas de la page  aussi)
- met l'imprimante sous tension et branche la sur l’ordinateur avec un câble USB (pas besoin de bouger les cavaliers sur la carte électronique)
- démarre Pronterface

connexion.thumb.png.5227399c442700380645a0eeeaf69100.png

- Choisi le port qui correspond à l'imprimante (le nom peut être différent sur ton ordinateur, il peut y avoir plusieurs choix : trouve le bon !)
- choisi/saisi la vitesse 250000 (c'est ce qu'il faut pour la discovery)
- bouton : Connecter
connexion2bis.thumb.png.678465232f447f7461cc2a0ee86e994b.png

- si tous va bien, en bas à gauche des courbes se mettent à bouger, en haut à droite des messages apparaissent dans la console (se ne seront pas forcement les mêmes chez toi, il dépendent de la version de Marlin (le firmware dans la carte électronique)
- tu peux déplacer la position de la tête avec les flèches + et - X, + et - Y, + et - Z (éloigne la tête du plateau avec des +Z pour ne pas faire un trou dans ton buildtack si tu en as collé un sur le plateau)

connexion3bis.thumb.png.09bfa153981b6f1316ff2dc2464432fe.png

- démarre le ventilateur à fond en envoyant un "M106 S255" dans la zone de saisie en bas à droite avec le bouton Envoyer
- la courbe noir du ventilateur doit monter en flèche, en bas à gauche.
Garde à l’esprit qu'il ne faut pas faire chauffer la tête sans ventilation parce que le PLA se déforme dès 40°, alors si tu es amené à couper l'alimentation quand la tête est encore chaude, rallume l'imprimante et redémarre rapidement la ventilation pour poursuivre le refroidissement de la tête.

connexion4bis.thumb.png.a13bef7caef2ec3a51c5cecddeed1932.png
- démarre la chauffe de la tête a, disons 190°, avec un "M104 S190" la courbe bleu foncer indique la température cible, la courbe bleu clair l'évolution de la température de la tête. (la différence du M104 et du M109 c'est que le M109 ne rend pas la main tant que la température cible n'est pas atteinte, le M104 permet de donner d'autre ordre sans attendre la stabilisation de la température à la température cible)

connexion5bis.thumb.png.1ac5dbb7890e0d3a7fd731dfcf20d49e.png
 - si tout est OK les deux courbe se rejoignent, et restent superposées tant que tu ne change pas la consigne de chauffe.

connexion6.thumb.png.c7db9f7c16e3c44119df91db7b17a022.png
- pour arrêter la chauffe envoie "M104 S0" température cible 0
- attend que la température soit redescendue à température ambiante, puis tu peux éteindre l'imprimante.
Si tu as put aller jusqu'au bout ton imprimante n'a pas de pb, c'est plus un pb de configuration de ton cura by dagoma.

Dit moi à partir de quand cela coince pour toi.

Modifié (le) par r2d2
photo en double

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 23 heures, r2d2 a dit :

Avec un cable usb c'est plus facile, mais tu peux aussi vider un fichier gcode et ne laisser dedans que
M106 S255; fan au max
M109 S180; chauffe a 180
 

Je me corrige moi même !
C'est une mauvaise idée, car tu serais bien embêter avec les g_codes que j'ai donnés ci-dessus pour refroidir la tête...

Avec une temporisation ce serait mieux :

M106 S255; ventilateur au max
M104 S180; chauffe a 180
G4 P120000; attendre 120000 millisecondes que ca chauffe
M104 S0; chauffe à 0 pour laisser refroidir avec le ventilateur allume

cela permet d’arrêter la chauffe au bout de 2 mn en laissant tourner le ventilateur.
Ouf! :$

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut

J'ai mis en route Pronterface mais il me manque les 3 premières images dans ton post précédent.

Pas de connexion car il doit me manquer les driver mais je ne sais pas les prendre...

Ok j'avance doucement, j'ai FT232R USB UART avec "!" jaune donc manque le pilote faut trouver la bête donc.

Donc j'ai été ici -> https://www.dagoma.fr/installer-les-pilotes-de-votre-imprimante-3d.html

Ok ca y est :) j'y suis arrivé :) l'imprimante est deja en USB je continu.

 

Voilà j'ai une connexion maintenant avec l'imprimante dans Fronterface

Si je comprend et c'est ce que j'ai fait Je vois monter sur le graphisme comme tu as indiqué mais la buse reste froide*

Par contre je vois que tu as Fronterface en Français et moi celui de Dagoma en anglais; je vais déjà changer peut être cela pour plus de compréhension. Bon j'ai pas trouver en Français(pas grave)

Alors avec la carte flash, ça chauffe mais redescend et en USB là, pas de chauffe et il m'affiche M105 dès que j'envoie un code.

 

Avec un fichier voici le code

Traceback (most recent call last):
  File "printrun\pronterface.pyc", line 1132, in printfile
  File "printrun\gcoder.pyc", line 234, in __len__
TypeError: object of type 'NoneType' has no len()
Modifié (le) par Kitetkat

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant


×