Aller au contenu

Filament ABS

Murdock

Firmware MARLIN Standard pour Trigorilla

Messages recommandés

il y a 25 minutes, .AleX. a dit :

Bon, après avoir reparcouru le tuto, c'est tout sauf clair....   parce que sur les illustration c'est marqué de croiser Z et E1, mais d'origine, les moteurs sont déjà en Z/E1 ou est-ce que les 2 moteurs de Z sont sur le même driver avec sortie en parallèle Z et Z'  ???

Oui ils sont déjà comme cela (Z et E1),  mais si tu ne croise pas les moteurs, le endstop de droite coupe le moteur de gauche et inversement.

Partager ce message


Lien à poster
Partager sur d’autres sites

Et le reste...?

Après modif, capteur en D42 est à droite ou à gauche de la machine ?
Après modif, le moteur mis en E1 est à droite ou à gauche de la machine ?


 

Partager ce message


Lien à poster
Partager sur d’autres sites
youtube drone débutant
il y a 28 minutes, .AleX. a dit :

le endstop d'origine reste a sa place, et reste branché sur limit Z- ?

Ca c'est la question à 100€ on peut pas savoir les end_stops sont connectés sur la "carte de transfert" et celle ci est raccordé au connecteurs des endstops de la carte mère.

 

il y a 29 minutes, .AleX. a dit :

on ajoute un endstop, mais sur le moteur de gauche ou sur celui de droite...? (quand on est face à la machine)

Gauche

 

il y a 30 minutes, .AleX. a dit :

le second endstop se connecte en D42 (du coup, c'est celui correspondant au Z2)

Ouep mais il va y avoir du changement si on laisse ces noms de constantes il va falloir changer des truc directement dans le code de Marlin et c'est pas le but. J'ai un firmware qui tourne presque. Quand je serais certain de mon coup je mettrai a jour le fichier unifié.

il y a 32 minutes, .AleX. a dit :

Donc, le moteur associé au capteur branché en D42, il est connecté en Z ou en E1 ?

E1 

Partager ce message


Lien à poster
Partager sur d’autres sites

Pour mes tests j'ai tout remis dans un fichier qu'avec la version mega. Plus simple a debuger car moins d''interactions involontaires voulues. Pour l'heure cela donne ceci.

pins_TRIGORILLA.h

Modifié (le) par Murdock

Partager ce message


Lien à poster
Partager sur d’autres sites

Oki c'est bon pour moi.

Pour le capteur d'origine qui est relié à la carte fille, je suis sur que ça ne fait que transférer ses connections sur la Trigorilla, c'est juste pour avoir un bornier plus facile/accessible qu'ils l'on fait passer par là. A la limite, tu pourrais confirmer ce que ça dit avec M119 en appuyant sur l'un ou sur l'autre ;)

Modifié (le) par .AleX.
fil^fille

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 3 minutes, .AleX. a dit :

A la limite, tu pourrais confirmer ce que ça dit avec M119 en appuyant sur l'un ou sur l'autre ;)

J'ai déjà fait le test celui de gauche est appelé z2 dans le retour de l'imprimante

En revanche avec le firmware d'origine tu ne vois pas le capteur capacitif ... Mais à mon avis c'est normal. vu que la fonction de probe n'est pas activée.

Partager ce message


Lien à poster
Partager sur d’autres sites

Ok, j'ai tout pour continuer :

Config 'pas du dual endstop'
Moteur de droite branché en E1, moteur de gauche branché en Z (ceci dit, il sont très probablement permutables...)

Config Dual Z
Nouveau capteur branché en D42, nommé Z2, associé au moteur E1
Du coup, selon toute logique, capteur Z- associé au moteur branché en Z, et monté à droite

Là tout de suite je suis sur mon dessin support pour mes endstop optique (avec slot de guidage dans le profilé 2020 + centrage du rail + utilisation de la visserie d'origine...), mais j'ai tout pour poursuivre quand j'aurais les idées plus claires :D

Partager ce message


Lien à poster
Partager sur d’autres sites

Ouep ca semble bon. Je pense avoir une première version d'ici la fin du week-end. Après il faudra "Sniffer" les commandes sortantes du lcd et voir comment reproduire le comportement dans marlin. Gros boulot ça.

  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Tu as un FTDI qui traine.... ? Si la carte fille est branchée sur le connecteur UART3, ben y'a p't'être moyen... mais c'est une autre affaire, on verra ensuite.

Partager ce message


Lien à poster
Partager sur d’autres sites

Il y a aussi beaucoup de constantes qui ont changées de nom style SDCARDDETECT c'est maintenant SD_DETECT_PIN ...

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonne nouvelle ma Méga est en train de faire son premier print sous Marlin 1.1.4 !

@.AleX. J'ai pas mal de modifications à te donner car non seulement le datasheet de la carte est faux. (Si si ! Si tu regardes attentivement il y a deux ports D14 et deux ports D15)

mais en plus la sérigraphie sur la carte est fausse ! le port sérigraphié D42 est sur la patte D43 de l'atmega est inversement ...

Mais bon ca y est ca tourne !

Les fonctionnalités récupérées pour l'heure sont :

- Contrôles des moteurs.

- Endstops.

- Sondes de températures.

- Ventilation hotend.

- Ventilation du print.

- Ventilation de l’électronique.

- Dual Z-EndStop.

Prochaines étapes :

- Récupération du capteur capacitif/inductif.

- Mise en place de l'autobed en mode bilinéaire.

- Récupération des fonctionnalités de l'écran. (Bah oui car là mis à part de la lumière il ne fait pas grand chose)

- Récupération du fonctionnement du lecteur SD.

- Récupération du détecteur de fin de filament. (c'est presque fait)

 

Ah mon petit cube est terminé !

 

cube.jpg.e156d12feb75c46a275bc155d3d3d041.jpg

 C'est un petit cube pour la MEGA mais un pas de géant vers la liberté ! xptdr !!! :P

Modifié (le) par Murdock
  • J'aime 3

Partager ce message


Lien à poster
Partager sur d’autres sites

Je dit juste.....chapeau bas, messieurs ;)

Un grand merci pour votre travail, j'aiderais bien, mais j'y connais queudale en Marlin (malheureusement)

Je suis en tout cas vos travaux.

Bonne chance pour la suite.

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 9 heures, Murdock a dit :

Ca c'est la question à 100€ on peut pas savoir les end_stops sont connectés sur la "carte de transfert" et celle ci est raccordé au connecteurs des endstops de la carte mère. 

?? Tu es certain de ce que tu dis? Je suis en vacances et ne peux vérifier mais dans mon souvenir les endstops de la trigorilla ne sont pas raccordé et cela m'avait surpris qu il ne se servaient pas des ports classiques endstop sur la mega alors que j imagine sur la delta ils s en servent. A vérifier tout de même avec quelqu'un qui a une mega sous les yeux

Partager ce message


Lien à poster
Partager sur d’autres sites

punaise vs assurez les gars

avoir un marli officiel avec toutes les calibrations auto ça va etre  l extase

surtout que j ai pas mal de capteurs en rabe(ir,micro switch,capa,indu..)

par contre pour les fixer va falloir user d un foret et percer car il n y a plus la fixation d origine des anciens modeles sur la nouvelle serie

Partager ce message


Lien à poster
Partager sur d’autres sites

c'est vai que pour le moment on as 2 petits génies qui bosse dur ils vont bientôt nous sortir la i3 mega v3 open source 

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 2 heures, thsrp a dit :

?? Tu es certain de ce que tu dis? Je suis en vacances et ne peux vérifier mais dans mon souvenir les endstops de la trigorilla ne sont pas raccordé et cela m'avait surpris qu il ne se servaient pas des ports classiques endstop sur la mega alors que j imagine sur la delta ils s en servent. A vérifier tout de même avec quelqu'un qui a une mega sous les yeux

Alors j'ai eu un peu la flemme de démonter x fois la mienne cette nuit surtout que je devais flasher toutes les 5 min pour tester. Mais sur la photo que j'ai récupéré du post sur les tmc2100 on voit bien :

- Entourés en rouge les soudures des connecteurs qui vont de la cartes de transfert  vers les connecteurs "endstops" de la carte mère.

- Entouré en en vert le connecteur qui amène les endstop sur la carte de transfert.  (C'est ce point que je doit revalider par un nouveau démontage, mais j'en suis certain à 99.99%)

- Entouré en jaune le connecteur du endstop de l'axe Y relié au port D43 de la carte mère. (Sauf que le D43 est relié au D42 de l'atméga :P)

Je remet également la photo sans les cercles de couleur, tu verras on devine bien les pistes qui vont de la zone entourée en vert vers la zone entourée en rouge.

xfer2.thumb.jpg.c3c04b945c85b8aa6ab91b0b186293c5.jpg

 

imageproxy.thumb.jpg.87f1941570d3257a4073a78132b9028b.jpg

  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez poster un message et vous inscrire plus tard. Si vous avez déjà un compte, connectez-vous afin de poster avec.

Invité
Répondre à ce sujet…

×   Vous avez copié du contenu avec formatage.   Supprimer le formatage

  Only 75 emoji are allowed.

×   Votre lien a été automatiquement intégré.   Afficher en tant que lien à la place

×   Le contenu sauvegardé a été restauré.   Effacer l'éditeur

×   You cannot paste images directly. Upload or insert images from URL.


  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×
×
  • Créer...