Aller au contenu

Filament ABS

tamatoacoco

Commande M104 fait buguer l'imprimante

Recommended Posts

Bonsoir à tous,

je repost ici un commentaire effectué sur un autre thread où je n'ai pas trouvé de réponses;

Contexte, j'ai récupéré le gcode d'initialisation de @Huggy que j'ai adapté à mon imprimante, mais je rencontre un problème avec les commandes M109 et M104 : 

Citation

Bon sang, c'est incroyable, je pensais avoir résolu le soucis (qui est le même que @Augier) en lisant ce thread...
J'ai réussi enfin à régler l'offset correctement : la buse vient pil poil en contact avec le BlueTape puis se met à chauffer (M109 195) et ensuite ne démarre pas l'impression (plus de 10min d'attente), je remplace donc le M109 par un M104 et là par contre, la buse, au lieu de se régler aux quatres coins en descendant comme avant, elle ne fait que monter successivement aux quatres coins, l'impression se lance, mais à 7cm du BlueTape... wtf ? ^^

PS : voici mon gcode de début : 
 


G91        ;relative positioning
G1 Z7
G90        ;absolute positioning
G28 X  ; part en butee X (homing X fixe le X=0)
G28 Y ; part en butee Y (fixe le Y=200)
G1 X100 Y100 F3000
G28 Z  ; fixe le Z = 0 ca sert à descendre la buse pour le G29
G29; Detailed Z-Probe = palpage au 4 coins pour determiner l'inclinaison du plateau
G92 Z8 ; fixe une hauteur arbitraire (ici 10 mm) pour pouvoir descendre sinon le logiciel nous en empêche
G91  ; mode relatif
G1 Z-1.65  ; baisse la buse jusqu'a toucher le plateau A REGLER pas à pas
G90 ; mode absolu
G92 Z0 ; fixe la position du Zero qui colle pile-poil avec la buse qui touche le plateau

M104 S195

G21 ; set units to millimeters
G90 ; use absolute coordinates
M82 ; use absolute distances for extrusion
G92 E0
G1 Z5.350 F7800.000

 

etc...

Qu'en pensez-vous ?
Merci d'avance pour vos réponses.

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut Ioo, t'inquiètes pas, on va trouver une solution !
Un autre truc que j'ai remarqué, c'est que le M104, placé à différentes lignes dans le code provoque des résultats différents comme par exemple la buse qui ne s'ajuste plus juste en contact avec le BlueTape mais plusieurs millimètres voire centimètres trop haut.

Modifié (le) par tamatoacoco

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant


×