Aller au contenu

Filament ABS

Sigmawolf

Probléme steppers DRV8825

Recommended Posts

Bonjour à tous,

Je travaille sur une Geeetech Prusa I3 Pro X.

Je vous demande vôtre aide, car j'ai un soucis qui m’énerve depuis quasiment 10h.

Je m’explique, je viens de recevoir mes 4 steppers DRV8825 avec ma buse E3DV6 et l'extrudeur Titan.

Je suis arrivé à tous les régler pour ne pas que mes moteurs surchauffent, mais, mon extrudeur (E3DV6 avec le Titan) ne veut rien savoir et ne sort rien, pourtant, le reste semble bien fonctionner.

J'ai multiplier tout les pas par 2 dans le firmware comme conseiller avec ce type de steppers.

Donc, pourriez vous m'éclairer à ce sujet ?

Merci bien :)

17342933_10208529973463088_3142642426346209124_n.jpg

Partager ce message


Lien à poster
Partager sur d’autres sites

Si tu as doublé tes valeurs dans marlin pour tout passer en 1/32 tu dois également modifier la position de tes micro switch sur ta gt2560...

Après il est inutile de modifier l'extrudeur et le Z car cela n'apporte rien de plus, le X et le Y par contre là il y a une différence.

Regarde le post que j'avais fait :

  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 3 heures, Sigmawolf a dit :

J'ai multiplier tout les pas par 2 dans le firmware comme conseiller avec ce type de steppers.

Il n'y a pas de conseil particulier à apporter.

Pour le réglage de la Vref, il y a une formule de calcul simple à réaliser en fonction des caractéristiques du moteur concerné (et du type de stepper)

pour un DRV c'est assez simple c'est l'intensité nominale max du moteur divisé par 2 qui donne la vref .... par exemple pour 1.68 A  cela donne une vref de 0.84 volts (840 mV).

Pour les rapports de pas c'est une autre question.

Pour un extrudeur pas besoin d'avoir une definition trés élevée un rapport de 1/16 est largement suffisant ... il faut privilégié le couple

[edit]

Comme le dit @pascal_lb:$

Modifié (le) par La Bidouille
  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Dac, merci pour vos réponses :)

Pour ce qui est de multiplier, vu que mes ancien étais en 1/16, et mes nouveau en 1/32, j'ai vu que pour ne pas ce prendre la tête avec le firmware, juste multiplier les steps par 2 suffisais, c'est ce que j'ai fait, sa m'a l'air pas mal.

 

Et pour les Vref, je les ai réglées en faisant une impression à vide, et régler pour que les moteurs aient suffisamment de couple, ne chauffent pas trop, et soient silencieux.

 

Ha oui, j'ai trouver sa :

Turn   ON/OFF         Subdivision
MS1    MS2    MS3
OFF    OFF    OFF    full step
ON     OFF    OFF    1/2 step
OFF    ON     OFF    1/4 step
ON     ON     OFF    1/ 8 step
OFF    OFF    ON     1/16 step
ON     OFF    ON     1/32 step
OFF    ON     ON     1/32 step
ON     ON     ON     1/32 step

 

C'est pour mes jumpers, mais je n'arrive pas à comprendre pourquoi il y à différentes positions pour le même pas ...

Partager ce message


Lien à poster
Partager sur d’autres sites

La Vref avec les moteurs Pap est le résultat d'un calcul à appliqué selon le type de stepper et le moteur accroché dessus,  on ne peut pas le faire correctement à main levé.

Pour ton extrusion c'est aussi assez simple à régler et calculer.

[edit] j'ai modifié le paragraphe ci dessous car pas très clair (je me suis pris les pieds dans le tapis)

  • Tu demandes une extrusion de 100 mm (par exemple,en repérant cette longueur en amont de l'extrudeur. et sans tête/buse en aval. de preference.)
  • Tu contastes ce que l'extrudeur à réellement entraîné par exemple 90 mm
  •  Tu fais une règle de 3 par rapport à tes paramètres de pas/mm de ton FW
    • donc si tu as (valeur au hasard) 300 pas par millimètre déclaré dans ton Firmware
    • 90 mm (extrudé) pour 300pas/mm = 27 000 pas réalisés
  • Pour chaque pas (dans ta config) il est effectué une extrusion de 90 mm/27 000 pas=0.00333... mm pour 1 pas
  • pour arriver au bon nombre de pas souhaités pour faire 1 mm ....pour le réglage il te faut (dans l'exemple) ...
    • 1 mm / 0.00333... mm par pas = 333.3333... pas/mm ( soit 333 ou 334 pas par mm. donc, parce les décimales de pas ...je vois pas trop)

Si tu change la résolution de tes steppers ...ou un engrenage ..poulie ou autre ...tu refais ce calcul sans faire cas du matériel ou de ses caractéristiques

C'est pareil pour le déplacement des axes ..... tu demandes une distance de déplacement ...tu mesures le réel  et règle de 3

Il y a 2 heures, Sigmawolf a dit :

j'ai vu que pour ne pas ce prendre la tête avec le firmware, juste multiplier les steps par 2 suffisais, c'est ce que j'ai fait, sa m'a l'air pas mal.

 

Tu devrais ....c'est important de le faire pour le respect des cotes de tes pièces surtout pour tes 3 axes (plus important que pour l'extrusion au niveau précision et restitution)....

Si tu fais un cube de 20x20x20, par exemple, le résultat respecte t'il les cotes demandées ? (pour les binious "artistiques" cela ne se constate ou ne gêne pas trop..... mais pour les pièces demandant un assemblage c'est plus critique)

Il y a 2 heures, Sigmawolf a dit :

mais je n'arrive pas à comprendre pourquoi il y à différentes positions pour le même pas ...

C'est parce qu'ils ont bêtement continués la table des positions ... avec 3 bits (cavaliers) tu peux avoir une combinaison de 8 états 0 ou 1  (2*2*2) c'est tout....et 6 sont seulement utiles dans ce cas .....faut pas chercher  ... c'est uniquement un pb de présentation ;)

Modifié (le) par La Bidouille

Partager ce message


Lien à poster
Partager sur d’autres sites

Dac, je vais étudier tout sa, car je dois avouer que je suis un peut perdu ^^.

J'ai pu régler mes vref comme dis plus haut, juste en regardant et écoutant les moteurs, sa marche impeccablement.

Je devais normalement mettre 0.80v celons le calcul, mais mes moteurs sifflaient pas mal et chauffaient beaucoup, donc pour sa, c'est bon.

Pour ce qui est de l'extrudeur, j'ai remis l'ancien steppers et tout reparamétré dans Marlin, de nouveau tester à vide, c'est vraiment silencieux, plus qu'as attendre ma courroie GT2 pour pouvoir bouger ma buse et commencer mes nouvelle impressions avec mon E3D V6 Titan :D

Merci de m'avoir éclairé ;)

Modifié (le) par Sigmawolf

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai corrigé la bouillie que j'avais écrit 

il y a 44 minutes, Sigmawolf a dit :

Je devais normalement mettre 0.80v celons le calcul, mais mes moteurs sifflaient pas mal et chauffaient beaucoup, donc pour sa, c'est bon.

Je me pose des fois des questions quant a la fiabilité des caracteristiques fournies avec moteurs

il y a 5 minutes, Sigmawolf a dit :

Pour ce qui est de l’extrudeur, j'ai vraiment pas envie de démonter mon Titan pour calculer le nombre de dents et le diamètre de la couronne, je vais faire plusieurs test, et paramétrer en conséquence.

Tu n'as aucun besoin de démonter quoique soit .... ni de rien compter..... simplement mesurer

Modifié (le) par La Bidouille
  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Super ! Je comprend bien mieux, je viens également de faire un tour sur les tutos, et il y à également la même explication que tu m'as décrite.

Je viens de finir de tout régler, reste à vérifier cette chauffe de l'axe X, il me semble que je ne suis pas le seul dans cette situation.

Si je suis le tableau j'étais en 1/16 avec tout les cavalier sur "on", donc vu que je suis passé sur du 1/32, je n'ai pas besoin de modifier si je comprend bien.

Pour ce qui est de l’extrudeur, j'ai vraiment pas envie de démonter mon Titan pour calculer le nombre de dents et le diamètre de la couronne, je vais faire plusieurs test, et paramétrer en conséquence.

Désolé pour le petit hors-sujet :

Voila une ancienne impression, avec ma pro x quasi stock, j'en mettrais avec mon E3D pour que vous vous fassiez une idée de ce que donne cette merveille avec des pas plus précis ;)

PS : j'aime passer des heures à régler mon imprimante pour avoir une qualité au top, sa ce vois beaucoup dans mes impressions je pense :D

17039170_10208403586383490_6002180544212942557_o.jpg

 

Il y a 11 heures, La Bidouille a dit :

J'ai corrigé la bouillie que j'avais écrit 

Je me pose des fois des questions quant a la fiabilité des caracteristiques fournies avec moteurs

Je confirme, mais je viens de me rendre compte que mes moteurs sont à 1.0A, je devais donc mettre 0.5, mais j'ai dus baisser pour certain et monter pour d'autres au final ...

 

Il y a 11 heures, La Bidouille a dit :

J'ai corrigé la bouillie que j'avais écrit 

Je me pose des fois des questions quant a la fiabilité des caracteristiques fournies avec moteurs

Tu n'as aucun besoin de démonter quoique soit .... ni de rien compter..... simplement mesurer

Autant pour moi, je n'avais pas revu ta méthode, car il me semblais avoir vu sur le tuto que pour un extrudeur démultiplier comme le mien, il falais avoir le nombre de dents, ainsi que le diamètre de la couronne

  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 14 minutes, Sigmawolf a dit :

il falais avoir le nombre de dents, ainsi que le diamètre de la couronne

Absolument pas !

Ceux qui font cela ... c'est pour se faire plaisir à mon avis (ça fait plus tech/barbu ^^) tu n'as besoin que de connaitre 3 valeurs factuelles .... le nombre de pas par mm déclaré dans ton paramétrage de firmware ..... la mesure de ce que tu demandes et la mesure constatée ... point.

Et c'est la même chose pour les déplacements de tes axes

A l’extrême limite tu ne prends même pas en compte les nombre de pas de ton stepper... tu constates ... tu appliques

PS: fais gaffes au double post à la suite... tu vas te prendre un tir xD ... moi je pardonnerai car tu es nouveau 

Modifié (le) par La Bidouille
  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 10 heures, La Bidouille a dit :

Absolument pas !

Ceux qui font cela ... c'est pour se faire plaisir à mon avis (ça fait plus tech/barbu ^^) tu n'as besoin que de connaitre 3 valeurs factuelles .... le nombre de pas par mm déclaré dans ton paramétrage de firmware ..... la mesure que tu demandes et la mesure constaté ... point.

Et c'est la même chose pour les déplacements de tes axes

A l’extrême limite tu ne prends même pas en compte les nombre de pas de ton stepper... tu constates ... tu appliques

Dac, je vais étudier cela alors, je vais déjà tester quand ma machine seras prête, si je suis pas satisfait, je passerais au réglages fins ;)

Merci, tu m'as permis d'apprendre beaucoup de choses sur l'extrusion, pas des moteurs, steppers et autres !

 

Il y a 10 heures, La Bidouille a dit :

PS: fais gaffes au double post à la suite... tu vas te prendre un tir xD ... moi je pardonnerai car tu es nouveau 

J'en prend bonne note ;)

Partager ce message


Lien à poster
Partager sur d’autres sites

hello ..tiens ...cadeau :D (facile c'est pas de moi)

Calculateur...step...mm..poulie etc ...

58cafa570e6d6_2017-03-1621_46_22-RepRapCalculator.jpg.d5434c885bbd0674221f1a4110d034ea.jpg

Tu retrouveras dans  l'option "axis calibration" les mêmes éléments de calcul et résultat que dans l'exemple ci dessus (sauf que expliquer comment.. je trouve cela mieux)

58caf8874824b_2017-03-1621_38_51-.jpg.c65c66ad980b07032c52859aad78073c.jpg

Amuse toi bien ... et merci à Joseph PRUSA et Nathan ZADOKS pour le calculateur

 

Merci, aussi,  aux modos ...d'avoir réorganisé le post ;) ....

  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 14 heures, Sigmawolf a dit :

Super tout sa, merci bien :)

Hello ;)

Et bien mon soucis est résolu, mes steppers on l'air de super bien marcher, j'ai pu les calibrer nickel, et j'ai pu mettre le nombre de pas exacte qu'il me faut :)

Mais, moi qui ai toujours de la chance, viens un autre soucis, mais pas vraiment grave je pense.

Quand je demande un auto home de l'axe Z, je dois le faire 2 fois pour que l'axe remonte bien et ne fasse plus contact avec l'endstop.

Aurai - je mal entré mes valeurs ?

J'attend toujours cette satanée courroie GT2 pour pouvoir enffin imprimer avec mon E3D, pour le moment, mon axe X ne peut rien faire ...

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant


×