Aller au contenu

Filament ABS

Franlit

Palpeur bleu (branchement ?)

Messages recommandés

Bonjour

J'ai voulu remplacer mon capteur (bout blance) en prenant la référence citée sur le Forum

Le bout est bleu et il réagit à l'inverse (type NC au lieu de NO).

Que faut il faire ? modifier le branchemment ou changer des paramètres (si oui où et comment ?)

Merci de votre aide.

Partager ce message


Lien à poster
Partager sur d’autres sites

Je pense qu'il faut intervenir dans le firmware pour changer le type de capteur.

Y a t-il un tuto pour modifier celui de la DE200. Je me souvient l'avoir fait pour la D200 mais la carte n'est plus une arduino.

Il y a surement quelqu'un d'autre qui a commander ce capteur NC !

Help

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci pour ta réponse

Mais je ne suis pas très fort dans ce domaine, je ne vois pas où se trouve ce configuration.h.

Pas dans le XML à priori.

Faut-il modifier un fichier hex ? si oui avec quel programme ?

cordialement

Partager ce message


Lien à poster
Partager sur d’autres sites

il faut modifier le fichier configuration.h qui se trouve dans le dossier marlin ( firmware source)

pour ce faire il faut utiliser le programme arduino

puis quand la modif est faite, il faut compiler pour obtenir un fichier .hex

et ensuite il faut flasher la carte avec ce fichier .hex ( ne pas oublier de refaire l’offset )

( pour plus de précisions fait une recherche dans le forum " arduino marlin ...........) normalement tu trouveras tous ce qu'il faut pour y arriver

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon je ne trouve pas la ligne

#define Z_MIN_PROBE_ENDSTOP_INVERTING false

il y a uniquement #define Z_MIN_PROBE_USES_Z_MIN_ENDSTOP_PIN.

Chris peux tu me dire si je dois l'ajouter ?

Partager ce message


Lien à poster
Partager sur d’autres sites

la ligne    #define Z_MIN_PROBE_USES_Z_MIN_ENDSTOP_PIN. se trouve dans la partie    Z Probe Options du fichier configuration.h

la ligne a modifier    #define Z_MIN_PROBE_ENDSTOP_INVERTING false  se trouve dans la partie  Endstop Settings  un peu plus haut

si elle ne s'y trouve pas dis moi quel marlin tu utilises  je regarderai

Partager ce message


Lien à poster
Partager sur d’autres sites

ok j'ai trouve

en fait c'est const bool Z_MIN_PROBE_ENDSTOP_INVERTING = false; // set to true to invert the logic of the endstop.

j'ai changé en true mais maintenant j'ai un soucis pour compiler (désolé) , je ne pense donc pas pouvoir récupérer le ficher Hex que je ne vois pas dans la liste.

Ci dessous le détail : Erreur de compilation pour la carte Arduino/Genuino Mega or Mega 2560

C:\Program Files (x86)\Arduino\arduino-builder -dump-prefs -logger=machine -hardware C:\Program Files (x86)\Arduino\hardware -tools C:\Program Files (x86)\Arduino\tools-builder -tools C:\Program Files (x86)\Arduino\hardware\tools\avr -built-in-libraries C:\Program Files (x86)\Arduino\libraries -libraries D:\Documents\Arduino\libraries -fqbn=arduino:avr:mega:cpu=atmega2560 -ide-version=10801 -build-path C:\Users\Franzi58\AppData\Local\Temp\arduino_build_632274 -warnings=none -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.avrdude.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.avr-gcc.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.arduinoOTA.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -verbose D:\Program Files (x86)\Cura-by-Dagoma-Easy200\source\Marlin-Firmwares_E200_1486395042_3693ab75a05ca48acdb9d3a15d9fc431\Marlin\Marlin.ino
C:\Program Files (x86)\Arduino\arduino-builder -compile -logger=machine -hardware C:\Program Files (x86)\Arduino\hardware -tools C:\Program Files (x86)\Arduino\tools-builder -tools C:\Program Files (x86)\Arduino\hardware\tools\avr -built-in-libraries C:\Program Files (x86)\Arduino\libraries -libraries D:\Documents\Arduino\libraries -fqbn=arduino:avr:mega:cpu=atmega2560 -ide-version=10801 -build-path C:\Users\Franzi58\AppData\Local\Temp\arduino_build_632274 -warnings=none -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.avrdude.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.avr-gcc.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.arduinoOTA.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -verbose D:\Program Files (x86)\Cura-by-Dagoma-Easy200\source\Marlin-Firmwares_E200_1486395042_3693ab75a05ca48acdb9d3a15d9fc431\Marlin\Marlin.ino
Using board 'mega' from platform in folder: C:\Program Files (x86)\Arduino\hardware\arduino\avr
Using core 'arduino' from platform in folder: C:\Program Files (x86)\Arduino\hardware\arduino\avr
Detecting libraries used...
"C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics  -flto -w -x c++ -E -CC -mmcu=atmega2560 -DF_CPU=16000000L -DARDUINO=10801 -DARDUINO_AVR_MEGA2560 -DARDUINO_ARCH_AVR   "-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\cores\arduino" "-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\variants\mega" "C:\Users\Franzi58\AppData\Local\Temp\arduino_build_632274\sketch\Marlin.ino.cpp" -o "nul"
"C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics  -flto -w -x c++ -E -CC -mmcu=atmega2560 -DF_CPU=16000000L -DARDUINO=10801 -DARDUINO_AVR_MEGA2560 -DARDUINO_ARCH_AVR   "-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\cores\arduino" "-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\variants\mega" "C:\Users\Franzi58\AppData\Local\Temp\arduino_build_632274\sketch\Marlin.ino.cpp" -o "C:\Users\Franzi58\AppData\Local\Temp\arduino_build_632274\preproc\ctags_target_for_gcc_minus_e.cpp"
D:\Program Files (x86)\Cura-by-Dagoma-Easy200\source\Marlin-Firmwares_E200_1486395042_3693ab75a05ca48acdb9d3a15d9fc431\Marlin\Marlin.ino:52:110: fatal error: U8glib.h: No such file or directory

     #include <U8glib.h> // library for graphics LCD by Oli Kraus (https://github.com/olikraus/U8glib_Arduino)

                                                                                                              ^

compilation terminated.

exit status 1
Erreur de compilation pour la carte Arduino/Genuino Mega or Mega 2560

Partager ce message


Lien à poster
Partager sur d’autres sites

si tu as bien l'écran sur ton imprimante, c'est le bon fichier

pour l'erreur de compil, il te manque la bibliothèque U8glib

dans arduino, il faut ajouter la bibliothèque pour l’écran

menu croquis - inclure une bibliothèque - ajouter la bibliothèque.zip (à télécharger " je ne sais plus ou ")

Partager ce message


Lien à poster
Partager sur d’autres sites

Super

au cas ou U8glib est dispo sous :

https://bintray.com/olikraus/u8glib/Arduino

et la compilation fonctionne.

je trouve mon fichier .hex  :C:\Users\Franzi58\AppData\Local\Temp\arduino_build_632274/Marlin.ino.hex"

Il me reste plus qu'a flasher le firmware avec Dagomap. j'essaierais demain.

Merci déjà de votre aide.

Partager ce message


Lien à poster
Partager sur d’autres sites

Flute, j'ai bien flasher le nouveau fichier hex mais ça ne change rien. Z réagit toujours à l'envers.

mon code :

// Mechanical endstop with COM to ground and NC to Signal uses "false" here (most common setup).
const bool X_MIN_ENDSTOP_INVERTING = false; // set to true to invert the logic of the endstop.
const bool Y_MIN_ENDSTOP_INVERTING = false; // set to true to invert the logic of the endstop.
const bool Z_MIN_ENDSTOP_INVERTING = true;
const bool X_MAX_ENDSTOP_INVERTING = false; // set to true to invert the logic of the endstop.
const bool Y_MAX_ENDSTOP_INVERTING = false; // set to true to invert the logic of the endstop.
const bool Z_MAX_ENDSTOP_INVERTING = false; // set to true to invert the logic of the endstop.
const bool Z_MIN_PROBE_ENDSTOP_INVERTING = true; // set to true to invert the logic of the endstop.

//===========================================================================
//============================= Z Probe Options =============================
//===========================================================================

// Enable Z_MIN_PROBE_ENDSTOP to use _both_ a Z Probe and a Z-min-endstop on the same machine.
// With this option the Z_MIN_PROBE_PIN will only be used for probing, never for homing.
//
// *** PLEASE READ ALL INSTRUCTIONS BELOW FOR SAFETY! ***
//
// To continue using the Z-min-endstop for homing, be sure to disable Z_SAFE_HOMING.
// Example: To park the head outside the bed area when homing with G28.
//
// To use a separate Z probe, your board must define a Z_MIN_PROBE_PIN.
//
// For a servo-based Z probe, you must set up servo support below, including
// NUM_SERVOS, Z_ENDSTOP_SERVO_NR and SERVO_ENDSTOP_ANGLES.
//
// - RAMPS 1.3/1.4 boards may be able to use the 5V, GND, and Aux4->D32 pin.
// - Use 5V for powered (usu. inductive) sensors.
// - Otherwise connect:
//   - normally-closed switches to GND and D32.
//   - normally-open switches to 5V and D32.
//
// Normally-closed switches are advised and are the default.
//
// The Z_MIN_PROBE_PIN sets the Arduino pin to use. (See your board's pins file.)
// Since the RAMPS Aux4->D32 pin maps directly to the Arduino D32 pin, D32 is the
// default pin for all RAMPS-based boards. Some other boards map differently.
// To set or change the pin for your board, edit the appropriate pins_XXXXX.h file.
//
// WARNING:
// Setting the wrong pin may have unexpected and potentially disastrous consequences.
// Use with caution and do your homework.
//
//#define Z_MIN_PROBE_ENDSTOP

// Enable Z_MIN_PROBE_USES_Z_MIN_ENDSTOP_PIN to use the Z_MIN_PIN for your Z_MIN_PROBE.
// The Z_MIN_PIN will then be used for both Z-homing and probing.
#define Z_MIN_PROBE_USES_Z_MIN_ENDSTOP_PIN

// To use a probe you must enable one of the two options above!

// This option disables the use of the Z_MIN_PROBE_PIN
// To enable the Z probe pin but disable its use, uncomment the line below. This only affects a
// Z probe switch if you have a separate Z min endstop also and have activated Z_MIN_PROBE_ENDSTOP above.
// If you're using the Z MIN endstop connector for your Z probe, this has no effect.
//#define DISABLE_Z_MIN_PROBE_ENDSTOP

il aurait une autre ligne à changer ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Finalement, j'ai également changé la ligne

const bool Z_MIN_ENDSTOP_INVERTING = true; 

ce qui donne

// Mechanical endstop with COM to ground and NC to Signal uses "false" here (most common setup).

const bool X_MIN_ENDSTOP_INVERTING = false; // set to true to invert the logic of the endstop.

const bool Y_MIN_ENDSTOP_INVERTING = false; // set to true to invert the logic of the endstop.

const bool Z_MIN_ENDSTOP_INVERTING = false;

const bool X_MAX_ENDSTOP_INVERTING = false; // set to true to invert the logic of the endstop.

const bool Y_MAX_ENDSTOP_INVERTING = false; // set to true to invert the logic of the endstop.

const bool Z_MAX_ENDSTOP_INVERTING = false; // set to true to invert the logic of the endstop.

const bool Z_MIN_PROBE_ENDSTOP_INVERTING = true; // set to true to invert the logic of the endstop.

Et la curieusement ça fonctionne.

Merci à Chris de m'avoir mis sur la voie

Partager ce message


Lien à poster
Partager sur d’autres sites

Juste pour comprendre

Si Chris ou un autre spécialiste du code pouvait me confirmer que ce que j'ai fait est correct, j'avoue que j'ai du mal à saisir la logique.

Amicalement

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×