Aller au contenu

Filament ABS

vinsthemaker

Problème d' Update du firmware Freesculpt EX1

Messages recommandés

bonjours a tous

j'ai récemment acheter une Fresculpt Ex1 et maintenant j'ai l'erreur fireware error update qui s'affiche sur le LCD.

C'est arriver lorsque j'ai fait un test avec Repetier Host (logiciel dont je me sert pour mon autre machine et que je connais bien).

J'ai configuré (correctement) le logiciel pour la EX1 et tout fonctionner parfaitement au niveau des commandes manuelle etc.

c'est au niveau du Gcode qu’il y a eu un souci, a voir, enfin du coup j'ai du couper la machine, et paf le problème s'affiche.

D’après Myriwell cela peut arriver après une coupure de courant pendant l'impression (ce qui m'es arrivé) il suffit tout simplement de faire une Update du firmware.

Le problème c'est que l'update est impossible !

Quand je lance l'update ça m'affiche "file not found", l'imprimante est bien reconnue en port COM4 pas de problème, mais apparemment le logiciel ne trouve pas l'update .

Je précise que j'ai tout essayé la version 1.1/1.2/1.3/1.4 de Myriwell. j'ai même démonté la machine pour appuyé sur le bouton "reset" de la carte etc... sans aucun résultat.

J'ai trouvé le Myriwell assistant update version 2.0 sur le net, il est pas mal car on peut choisir son fichier directement sur son ordinateur, le problème c'est que le fichier du Firmware ou le fichier de l'update de la machine est itrouvable sur le net !

J'ai tout essayé, je suis a bout, si quelqu'un a une solution ou un firmware, je vous en conjure aidez moi !

Sinon je n'aurais pas d'autre solution que de changer la carte mère par une arduino atmega 2560 et une Ramps 1.4 et configuré mon firmware marlin moi même par exemple, au moins la, la machine sera exploité au maximum, mais si je peut évité dans un premier temps (je l'ai depuis une semaine)

Merci d'avances pour vos réponse les Makers

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour, je suis aussi dans l'impasse en ce qui concerne ce soucis de firmware, impossible d'en trouver une trace nulle part.

D'après ce que j'ai pu comprendre sur certains forum (Allemand, Anglais) il semblerait qu'en fait il n'est pas inclus dans les versions du logiciel, mais qu'il s'agit d'une connexion (bbs, ftp ?) vers un serveur, qui est sensé remonter le dernier firmware lors de la demande d'upgrade.

Et que, donc, ce serveur ne serait pas facilement accessible, et peut être même pas souvent activé.

Partant de ce fait j'ai contacté par l'intermédiaire de Facebook, le SAV de Pearl, qui m'a dit s'en occuper rapidement (que veut dire rapidement pour Pearl, là je suis dans le flou).

Quoi qu'il en soit si quelqu'un avait l'archive de cette mise à jour 1.3 Eng, ce serait sympa d'en faire profiter les pauvres malheureux que nous sommes :roll:

Partager ce message


Lien à poster
Partager sur d’autres sites

effectivement c'est vraiment dommage d'avoir une machine comme ça et pas les firmware pour les faire tourner correctement, je dirais même que c'est honteux.

Enfin bref ça commence a me gonfler alors je prend les devant .

j'ai a coter de moi une carte arduino mega 2560 et une ramps 1.4 je penser m'en servir pour autre chose mais bon .

Donc je me lance, je vais tout simplement remplacer la carte mère d'origine par la ramps 1.4 et l'arduino.

il y a du boulot , mais c'est faisable avec de la volonté ;-).

L'avantage c'est que je vais pouvoir configuré mon firmware perso (marlin je pense ou peut etre repetier) donc plus de problème de firmware, je vais donc pouvoir gérer ma machine comme bon me semble avec Repetier host et je l’espère obtenir de meilleurs resultat qu'a l'origine.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour, moi j'ai eu le problème de l'update firmware mais après plusieurs essais ça a marché, par contre j'ai des problèmes lorsque j'imprime des objets volumineux (programme long), l'impression s’arrête toute seule, je pensais avoir résolu le problème en installent les drivers prolifics mais ça continu, ce qui rend l'imprimante quasi inutilisable, du coup je veut faire comme toi (une carte arduino mega 2560 et une ramps 1.4) mais après mes premiers essais le seul résultat que j'ai c'est des moteurs qui "broutent".

Ça me rendrai vraiment service si tu me disait si tu est arrivé a un résultat concluant.

Merci

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut Matt 07600 

Je viens de terminer ma freesculpt version arduino et ramps 1.4 . Apres m'être battu de longues heures avec le firmware marlin, le calibrage et la machine, elle est belle et bien opérationnelle. J'ai supprimer l'écran LCD ainsi que le lecteur de carte sd (personnellement je m'en sert pas dutout) et j'ai rajouté des led qui s allumes au début et s'étreignent à la fin de l'impression ainsi qu'un refroidissement qui refroidit directement le dépôt de matière . je fait passer le filament au dessus de la machine et je suis en train de réhausser celle-ci avec du plexi glass . je la fait tourner avec repetier host et les premiers résultats sont vraiment concluant ! J'ai pris des photo et je vais faire un tuto sur le forum dans la partie dédié . je fournirais le firmware marlin que j'ai configuré pour la freesculpt . si tu à des question n'hésite pas en mp .

Modifié (le) par vinsthemaker

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir à tous,

Comme vous, j'ai connu pas mal de déboires avec les mises à jour pour cette machine. Je pense aussi avoir compris d'où vient le problème : le firmware ne se télécharge plus car le serveur l'hébergeant n'est plus accessible (ou pas assez souvent).

Si par hasard, quelqu'un a déjà réussi une mise à jour avec la Freesculpt EX1, je suis très intéressé par un zip de son dossier d'installation (Pearl, Myriwell ou autre, version 1.3 ou 1.4 si possible). Le firmware a peut-être été téléchargé par certains d'entre vous et se trouve dans ce dossier.

Mais je suis aussi très intéressé par ta solution Vins ! Si je peux libérer pas trop difficilement ma Freesculpt EX1 avec une nouvelle électronique, je fonce.

Merci pour vos retours.

 

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 8/10/2015 19:37:47, matt07600 a dit :

Bonjour, moi j'ai eu le problème de l'update firmware mais après plusieurs essais ça a marché, par contre j'ai des problèmes lorsque j'imprime des objets volumineux (programme long), l'impression s’arrête toute seule, je pensais avoir résolu le problème en installent les drivers prolifics mais ça continu, ce qui rend l'imprimante quasi inutilisable, du coup je veut faire comme toi (une carte arduino mega 2560 et une ramps 1.4) mais après mes premiers essais le seul résultat que j'ai c'est des moteurs qui "broutent".

Ça me rendrai vraiment service si tu me disait si tu est arrivé a un résultat concluant.

Merci

J'ai exactement le même problème avec mes impressions qui dépasse plusieurs heures, c'est super frustrant 

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

 

Impossible de mettre à jour l'imprimante, je suis dans le 1.2 de pearl, si quelqu’un a réussi, merci d'indiquer plus en détail... quelle OS , dossier install?...

Moi, dès que je clique sur upgrade, la machine redémarre et après dit pas de connexion. 

J’ai aussi des problèmes d’impression avec des gros fichiers et modelés complexes (l’impression s’arrête, et fait des mouvements aléatoires, voir continue à extruder pendant 10s arrêté dans le même point faisant une montagne de PLA) catastrophe.

 J’ai lutté contre les problèmes une semaine, et maintenant j’arrive à imprimer.

è Je utilise Cura

è Impression avec carte sd

è Changement dans le Gcode des commandes G0 par G1 (faire un find replace G0space par G1space) … Les G0 font parfois des mouvements aléatoires dans les pièces complexes.

è Génération des STL avec résolution non plus petit que 0.1 mm  et control de corde 0.1mm, si on génère des STL très « précis » le GCODE a trop des points proches, ça fait planter l’imprimante.

è J’enlève aussi les commentaires du Gcode et les lignes vides, ça je n’ai pas vérifié, mais ça doit aider la tache un peu J. Avec notepad++ sur le Gcode find replace regular expresion ^[#;].* par rien, puis \n\r par rien.

Voilà,

C

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour, je suis nouveau sur ce forum :)

J'ai aussi une freesculpt EX1 qui jusqu'à présent m'a amené (presque) que des problèmes.

Mais après un peu de patience et de recherche, je dois dire que je suis content du résultat :)

MERCI BCP à TOUS CEUX QUI CONTRIBUENT à PARTAGER L'INFO, C'EST TRèS TRèS APPRéCIé QUAND ON VEUT FAIRE les choses soi-même..

J'ai remarqué qu'avec CURA, on a en effet cette couche du milieu qui fait planter l'impression, c'est très ennuyeux..

quelqu'un a-t-il réussi à résoudre ce problème?

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant


×