Aller au contenu

Filament ABS

Wangee

Membres
  • Compteur de contenus

    9
  • Inscrit(e) le

  • Dernière visite

Réputation sur la communauté

0 Neutre

À propos de Wangee

  • Rang
    3D Newbie

Information

  • Imprimantes
    Alfawise U20

Visiteurs récents du profil

Le bloc de visiteurs récents est désactivé et il n’est pas visible pour les autres utilisateurs.

  1. Hi unhuzpt, Thanks for the reply. I tried your firmware and I got the very same result. When I do a G28, homing of X and Y are ok, then the head positions +/- on the middle of the bed then the Z homing starts, but the BL Touch remains stowed, then the head goes down and hits the bed. I got the little blue light that you talked about and from repetier host I can do M280 P0 S10 ; pushes the pin down M280 P0 S90 ; pulls the pin up M280 P0 S120 ;Self test –keeps going until you do pin up/down or release alarm M280 P0 S160 ; Release alarm I kep thinking it's not the firmware compilation and cabling not working. I start wondering if the BL Touch isn't defect on arrival. But I bought it at antclabs. This is very dissapointing. Anyway, I add my configuration.h for review. Configuration.h pins_LONGER3D_LK.h
  2. Ah oui pardon, j'avais oublié. U20, carte V0G et BL Touch antclabs.
  3. Bonjour, Toujours pareil pour moi. J'ai compiler et recompiler le FW, j'ai même pris le FW partagé par 3d92printer, et le résultat reste toujours le même. - A l'allumage, le BL Touch s'initialise (sort et rentre 2 fois puis lampe rouge reste fixe). - Dans Marlin, je peux tester le BL Touch (sort et rentre en boucle), je peux le reseter. Je peux faire aussi toujours depuis Marlin faire un deploy et un retract. Bref, à ce stade, le câblage ne peut pas être mis en cause. Lorsque je me connecte avec Repetier Host et que je fais un G29, l'imprimante va tester les interrupteurs de fin de course sur les axes X et Y, ensuite la tête se positionne au milieu du plateau et l'axe Z commence à descendre. Le BL Touch reste inexorablement rouge et rétracté jusqu'à ce que la tête aille taper le bed. J'ai lu tout le thread ici, j'ai testé toutes sortes de résistances, allant de 1k à 100k, rien n'y fait. J'avoue que là je suis vraiment à court d'idées. Peut-être les résistances qui ne conviennent pas. J'utilise des résistances tout ce qu'il y a de plus standard, série E12, 1/4 W.
  4. Salut Neolink, Merci pour la réponse rapide. Pour tout décrire : J'ai une U20 avec originellement une carte V07. Je me suis procuré une carte V0G chez CompoZan pour ne pas les citer. J'ai acheté un BLTouch V3.0, et un vrai de chez Antclabs. J'ai pris les dernières sources via GIT (git clone https://github.com/tpruvot/Marlin -b bltouch) Je compile via Visual Studio Code et PlatformIO. L'output de la compil est visible dans le fichier annexé compil_output.txt. Le flash fonctionne parfaitement. La connexion USB avec Repetier-Host est OK. Côté câblage, celui-ci a été vérifié, revérifié et re-revérifié. Pour la résistance, j'ai utilisé d'abord une 100 KOhm puis constatant mon erreur, une 10 KOhm pour ensuite passer à une 1KOhm. J'en suis à cette dernière actuellement. A l'allumage de l'imprimante, le BL Touch s'initialise correctement (le palpeur se déploie et se rétracte deux fois, puis lumière rouge et reste rétracté). Les 3 axes fonctionnent correctement, et les capteurs de fin de course X et Y fonctionnent également autant via Marlin que par l'interface de Repetier-Host. Lorsque je fais un G28, l'axe Z bouge un peu, genre 1cm vers le haut, puis plus rien ne se passe et quelques secondes plus tard, j'ai un message "Homing Failed PRINTER HALTED Please Reset" qui s'affiche sur l'écran (voir Photo1) et le même message sur Repetier-Host. (Voir photo2). Je joins mon configuration.h également. J'avoue que je sèche un peu, j'ai passé ma journée à chercher Compil_output.txt Configuration.h
  5. Bonsoir à tous, Y a-t-il un heureux possesseur de U20 qui ait su faire fonctionner ce foutu BL-Touch ? Eventuellement y aurait-il ici une ou plusieurs personnes qui seraient prêtes à collaborer ? Il faut reconnaître (et je ne jette la pierre à personne que ce soit clair) qu'entre les tutos, l'évolution de ce sujet, l'évolution des logiciels utilisés pour compiler le firmware, il y a de grosses différences qui font que c'est assez difficile de faire fonctionner le BL Touch. Bien sûr le but serait de clarifier un peu le how-to et que ce soit utile pour tout le monde, et (je pense) que ça retirerait un peu de poids sur les épaules de Cacaotor..
  6. Bonsoir, Problèmes similaires. A la mise sous tension, le BLTouch s'initialise correctement (sort/rentre/sort/rentre puis lumière rouge et pin rétractée). G28, il fait bien le homing X et Y, mais une fois le homing Z, la pin reste rétractée et la buse tape dans le bed. J'ai vérifié la modif du configuration.h, du pins_LONGER3D_LK.h ainsi que le platformio.ini dans visual studio. J'ai une U20 carte mère V07
  7. Merci pour la réponse. Peut-être est-ce un souci dans les sources. As-tu une U20 + BLTouch ? Si oui, je pourrais avoir une copie de tes sources ? Merci
  8. Bonsoir les makers. U20 (Motherboard L3DP04B01V07) avec BLTouch. A priori ce dernier fonctionne correctement. Mon problème se situe au niveau de la compil du firmware. Tout est commenté ou décommenté conformément au tuto. A la compil, tout a l'air de bien se passer. Jusqu'au linking et là c'est l'embardée. Je ne vois pas où chercher. Si quelqu'un a une idée pour m'aider à investiguer, je suis preneur. Merci d'avance.
×
×
  • Créer...