Aller au contenu

Filament ABS

Tios

Problème écran Anet A8

Messages recommandés

Bonjour à tous.

Après avoir voulu flasher mon Anet A8:

 en récupérant un des firmwares fourni dans le dossier telechargeable Skynet 2.3.2

l'imprimante fonctionne bien, répond mais l'écran ne fonctionne plus, il s'allume à la mise sous tension mais n'affiche que des "rectangles".

Quelqu'un aurait-il une solution pour remettre ça en état?

merci d'avance.

Partager ce message


Lien à poster
Partager sur d’autres sites

Modération :  @Tios j'ai déplacé ton post pour une meilleure visibilité

Partager ce message


Lien à poster
Partager sur d’autres sites

tu as choisi quel fichier? au passage skynet est obsolète, son développement a été arrêté, la référence maintenant c'est marlin.

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai pris le fichier "5 buttons KeyPad LCD no autolevel" présent dans le dossier Skynet 2.3.2, puis copié et collé le fichier en .h dans le skynet.ino avant de le téléverser.

le but était juste de changer les limites de température max de l'extrudeur et du lit chauffant. Maintenant, ça, ça fonctionne mais plus l'écran...

Partager ce message


Lien à poster
Partager sur d’autres sites

changer les temps max du lit et de l'extrudeur???? euh, comment dire, tu auras beau faire, le lit chauffant n'ira pas beaucoup au-delà de 100° si pas 90°, et ça ne vient pas d'une limitation du firmware. C'est le plateau lui-même qui est limité, et la température max dépend beaucoup de ta chance.

Partager ce message


Lien à poster
Partager sur d’autres sites

Oui, il n'y a pas de problème là dessus, j'ai monté une nouvelle machine qui récupère simplement la carte, l'écran et les steppeurs du kit Anet, mais monté dans un Carter étanche et un châssis métallique.

J'ai aussi une Anet A8 avec laquelle j'imprime depuis un moment.

Sur la nouvelle la cartouche de chauffe a été remplacée tout comme la sonde de température au profit d'un thermocouple.

Dans le Firmware d'origine, hormis le choix du matériel, tu as aussi les limites de températures, pour chaque extrudeur comme pour le lit. Inutile donc de monter un matériel permettant d'atteindre des températures plus élevées en gardant des limites tel que 90degres pour l'un et 275degres pour l'autre...

Les carters en inox et le bâtis en acier de cette machine n'étant pas encore terminés, j'ai simplement voulu flasher la machine déjà en service pour prendre en main le firmware et c'est là que les ennuis d'écran ont commencés...

Partager ce message


Lien à poster
Partager sur d’autres sites

Oui sans problème... Tout fonctionne correctement mis à part cet écran... De plus mis à part ces températures je n'ai touché à aucun autre paramètre, ce n'est pourtant pas la première foi que je met le nez dans de la prog avec Arduino... Cependant peut être suis je passé à côté de quelque chose...

Partager ce message


Lien à poster
Partager sur d’autres sites

Non pas bête, enfin en tout cas je partage l'idée car oui j'ai regardé.

J'ai trouvé des infos sur Google, je ne suis pas le seul à qui ça est arrivé. C'est dû  à une erreur d'upload du firmware... 

Bonne nouvelle, la cause est trouvée

Moins bonne nouvelle, la réparation semble fastidieuse, je vais m'y mettre dès que possible, il faut rebooter l'écran avec une carte Arduino, une Uno par exemple.

Partager ce message


Lien à poster
Partager sur d’autres sites

sauf que ladite erreur d'upload du firmware rend la carte totalement non fonctionnelle normalement, d'où ma question sur le fait que tu puisse imprimer.

En plus les cartes dans cet état ne sont plus détectées par l'ordinateur.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bin là pour le coup tout fonctionne et je te rejoind sur le fait que d'ordinaire, rien ne marche, d'où mon ouverture de post.

Partager ce message


Lien à poster
Partager sur d’autres sites

Et d'où ma question sur le fichier utilisé, j'ai cru que c'était un problème de déclaration de l'écran.

Tu peux joindre ton configuration.h que je le vérifie?

Modifié (le) par Maeke

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant


×