Aller au contenu

Filament ABS

Skaori

- autre - Problème TFT32 avec MKS SBASE 1.3

Messages recommandés

Bonsoir à tous,

Alors voilà, j'ai installé le firmware de ma MKS SBASE 1.3, je suis en train de connecter mon TFT32. Je l'ai donc branché sur le port AUX-1 de la MKS SBASE.

Seulement je n'ai aucune alimentation qui va vers l'écran. Rien du tout. Voici ma config smoothieware pour le panel.lcd (j'explore le wiki smoothieware pour comprendre comment le configurer mais j'avoue être un peu perdu...)

panel.enable                            true
panel.lcd                               reprap_discount_glcd
panel.spi_channel                       0                 # spi channel to use  ; GLCD EXP1 Pins 3,5 (MOSI, SCLK)
panel.spi_cs_pin                        0.16              # spi chip select     ; GLCD EXP1 Pin 4
panel.encoder_a_pin                     3.25!^            # encoder pin         ; GLCD EXP2 Pin 3
panel.encoder_b_pin                     3.26!^            # encoder pin         ; GLCD EXP2 Pin 5
panel.click_button_pin                  1.30!^            # click button        ; GLCD EXP1 Pin 2
panel.buzz_pin                          1.31              # pin for buzzer 1.31    ; GLCD EXP1 Pin 1
panel.back_button_pin                   2.11!^            # back button         ; GLCD EXP2 Pin 8
panel.external_sd                       true              # set to true if there is an extrernal sdcard on the panel
panel.external_sd.spi_channel           1                 # set spi channel the sdcard is on
panel.external_sd.spi_cs_pin            0.28              # set spi chip select for the sdcard (or any spare pin)
panel.external_sd.sdcd_pin              0.27!^            # sd detect signal (set to nc if no sdcard detect) (or any spare pin)

Modifié (le) par Skaori

Partager ce message


Lien à poster
Partager sur d’autres sites
youtube drone débutant

Oui oui, mais en fait je pense avoir compris, l'USB ne suffit pas à alimenter l'écran ? Il faut que le 12 Volts de la carte soit connecté pour que l'écran fonctionne non ?

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 52 minutes, Skaori a dit :

panel.enable                            true

ça tu peux le mettre à false, il n'y a rien à paramétrer dans le fichier config de la sbase, par contre il faut configurer le firmware de l'écran

pour l'alimentation, quand tu branches le 12v l'écran s'allume ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Pour le miens j’ai été obligé de rajouter un 5v sur la sbase car c’é trop limite avec tout les consommateurs 

Partager ce message


Lien à poster
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez poster un message et vous inscrire plus tard. Si vous avez déjà un compte, connectez-vous afin de poster avec.

Invité
Répondre à ce sujet…

×   Vous avez copié du contenu avec formatage.   Supprimer le formatage

  Only 75 emoji are allowed.

×   Votre lien a été automatiquement intégré.   Afficher en tant que lien à la place

×   Le contenu sauvegardé a été restauré.   Effacer l'éditeur

×   You cannot paste images directly. Upload or insert images from URL.


  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×
×
  • Créer...