Aller au contenu

Filament ABS

Wizzz

Err: Too far! cr 10s

Messages recommandés

Bonjour la communauté,

J'ai ce message depuis que j'ai appuyé sur : Préparer -> Régl. Décal. origine en voulant recentrer mes axes XY.

Depuis impossible de recaler mon imprimante. J'aimerai un conseil pour recalibrer ma zone d'impression.

Merci

Partager ce message


Lien à poster
Partager sur d’autres sites

En éteignant puis en rallumant le boitier, ça n'efface pas tes manipulations ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Hélas non, je pense que cela est écrit qque part.

Je vais imprimer une mire pour vérifier par rapport à mon plateau le décalage que j'ai.

Partager ce message


Lien à poster
Partager sur d’autres sites

Si ton imprimante est connectée en USB à un matériel informatique, en utilisant Repetier Host, Pronterface, Octoprint qui tous ont un terminal, tu peux lancer des commandes gcode. Celles à utiliser sont la série des commandes M500 à M503.

Tu peux récupérer les valeurs du firmware via un M502 qui va lire les données contenues dans le configuration.h pour les stocker en EEPROM. Puis un M500 pour les sauvegarder en EEPROM (mémoire non volatile).

Pour tester:

  • M503 va t'afficher dans le terminal les valeurs actuellement stockées dans l'EEPROM
  • M501 puis M503 => lecture des valeurs actuelles en EEPROM puis affichage
  • M502 puis M503 => lecture des valeurs du firmware puis affichage
  • M500 => sauvegarde les valeurs actuelles dans l'EEPROM
Modifié (le) par fran6p
erreur

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 2 heures, fran6p a dit :

Si ton imprimante est connectée en USB à un matériel informatique, en utilisant Repetier Host, Pronterface, Octoprint qui tous ont un terminal, tu peux lancer des commandes gcode. Celles à utiliser sont la série des commandes M500 à M503.

Tu peux récupérer les valeurs du firmware via un M502 qui va lire les données contenues dans le configuration.h pour les stocker en EEPROM. Puis un M500 pour les sauvegarder en EEPROM (mémoire non volatile).

Pour tester:

  • M503 va t'afficher dans le terminal les valeurs actuellement stockées dans l'EEPROM
  • M501 puis M503 => lecture des valeurs actuelles en EEPROM puis affichage
  • M502 puis M503 => lecture des valeurs du firmware puis affichage
  • M500 => sauvegarde les valeurs actuelles dans l'EEPROM

J'utilise la carte sd pour imprimer. Je vais récupérer ces infos avec un des terminaux dont tu m'as parlé en la connectant à un pc.

Merci pour ton aide

Partager ce message


Lien à poster
Partager sur d’autres sites

De rien. C'est le principe de ce forum: l'entraide 😉🙂

Partager ce message


Lien à poster
Partager sur d’autres sites

Voici les paramètres de la commande G503. Pour info j'ai suivi la customisation de marlin proposée par cr10.fr

Je décode certains paramètres mais n'identifie pas ce qui pourrait causer le décalage.

Je vais faire un test d'impression pour voir ou l'imprimante situe le centre.

15:26:46.960 : N18 M503*28
15:26:47.060 : echo:  G21    ; (mm)
15:26:47.060 : echo:  M149 C ; Units in Celsius
15:26:47.060 : echo:Filament settings: Disabled
15:26:47.060 : echo:  M200 D1.75
15:26:47.060 : echo:  M200 D0
15:26:47.060 : echo:Steps per unit:
15:26:47.060 : echo:  M92 X80.00 Y80.00 Z400.00 E95.00
15:26:47.060 : echo:Maximum feedrates (units/s):
15:26:47.060 : echo:  M203 X500.00 Y500.00 Z15.00 E25.00
15:26:47.060 : echo:Maximum Acceleration (units/s2):
15:26:47.060 : echo:  M201 X1000 Y1000 Z100 E5000
15:26:47.060 : echo:Acceleration (units/s2): P<print_accel> R<retract_accel> T<travel_accel>
15:26:47.060 : echo:  M204 P575.00 R1000.00 T500.00
15:26:47.060 : echo:Advanced: Q<min_segment_time_us> S<min_feedrate> T<min_travel_feedrate> X<max_x_jerk> Y<max_y_jerk> Z<max_z_jerk> E<max_e_jerk>
15:26:47.060 : echo:  M205 Q20000 S0.00 T0.00 X10.00 Y10.00 Z0.40 E5.00
15:26:47.060 : echo:Home offset:
15:26:47.060 : echo:  M206 X0.00 Y0.00 Z0.00
15:26:47.060 : echo:Auto Bed Leveling:
15:26:47.060 : echo:  M420 S0 Z0.00
15:26:47.060 : echo:  G29 W I0 J0 Z0.00000
15:26:47.060 : echo:  G29 W I1 J0 Z-0.12500
15:26:47.060 : echo:  G29 W I2 J0 Z0.17500
15:26:47.060 : echo:  G29 W I0 J1 Z0.32500
15:26:47.060 : echo:  G29 W I1 J1 Z0.10000
15:26:47.060 : echo:  G29 W I2 J1 Z0.27500
15:26:47.060 : echo:  G29 W I0 J2 Z0.32500
15:26:47.060 : echo:  G29 W I1 J2 Z0.22500
15:26:47.060 : echo:  G29 W I2 J2 Z0.40000
15:26:47.060 : echo:Material heatup parameters:
15:26:47.060 : echo:  M145 S0 H200 B60 F0
15:26:47.060 : echo:  M145 S1 H240 B90 F0
15:26:47.060 : echo:PID settings:
15:26:47.060 : echo:  M301 P17.42 I1.27 D59.90
15:26:47.060 : echo:  M304 P690.34 I111.47 D1068.83

Partager ce message


Lien à poster
Partager sur d’autres sites

Sur ta machine tu as un système de nivellement automatique (BLtouch, TouchMi, capteur inductif,...)?

Les valeurs retournées par le M503 (pas G503 !) sont correctes.

Par contre un certain nombre de commandes me sont inconnues (M206 pour ajouter des offsets aux réglages des end-stop alors que le Homing n'a pas encore été réalisé par une commande G28 qui devrait normalement être lancée avant un nivellement automatique via un G29...).

Bref, je ne crois / pense pas que le problème vienne du Marlin.

Si tu fais un M502 pour mettre en mémoire les paramètres stockés dans le firmware suivi d'un M500 pour enregistrer ces paramètres en EEPROM puis extinction de l'alimentation et rallumage, as-tu toujours cette erreur annoncée dans le sujet de ton post?

Quel trancheur (Cura, Ideamaker, MatterControl, Craftware, IceSL, Slicer, S3D,...) utilises-tu pour faire tes gcodes imprimés via ta carte SD? C'est dans ces logiciels que l'on déclare les dimensions d'impression et les suites de gcodes à lancer avant de lancer l'impression.

Là, honnêtement, je sèche. Espérons que quelqu'un ait des idées et des solutions (ou au moins un début de).

Partager ce message


Lien à poster
Partager sur d’autres sites

Pas de nivellement auto,

J'ai débranché rebranché les end stops, j'ai fait l'impression une croix centrée dans le slicer (simplify3D) qui est nettement décalée de + 0.5 cm en x et y.

En tt cas merci, j'ai découvert repetier qui me permet de mieux géré les envois commandes.

suite...

Après différents essais, le message n'apparait plus. J'ai modifié les startings scripts du gcode qui entrainaient un décalage. Mais pas de réponse claire sur tel ou tel paramètre pour remettre à 0 les x et y.

Je vais relancer l'impression du plateau de refroidissement mono ventilateur de l'alimentation qui est en limite d'impression de la cr10. Je te fais un retour après impression.

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×