Aller au contenu

Filament ABS

zephus77

M 851 = Z OFFSET PROBE dans MARLIN ????

Messages recommandés

Bonjour à Tous,

J'ai monté un capteur capacitif sur mon imprimante de type REPRAP. J'utilise ARDUINO=RAMPS avec SLIC3R.

En parcourant plusieurs tuto, plusieurs problèmes se sont confrontés à moi.

1er (résolu :-))))) si ca peut servir à d'autre) : lorsque j'ai branché mon capteur avec un pont de résistance.  La commande M119 me renvoyait toujours "z min OPEN" que la diode du capteur soit allumé ou pas. J'ai tenté le coup en supprimant le pont et là, miracle... le Z0 est bien détecté la buse s'arrête . OUF!!. J'ignore si c'est une bétise de brancher sans ce pont. Par sécurité, je vais tout de même commander une carte d'interface avec optocoupleur 12v/5v.

2ème soucis : Lorsque j'ai voulu régler mon z offset, j'ai descendu ma buse jusqu'à l'épaisseur d'une feuille. puis G12 X0 Y0 Z0 . ensuite j'ai déplacé mon capteur à cet emplacement et fait un G30. RESULTATS :  Z 3.12.       J'ai rentré la valeur -3.12 dans MARLIN... enregistrer... téléverser mais.... lors de l'impression, la buse est encore trop haute. J'ai l'impression que l'imprimante ne tient pas compte de cette valeur

Voici donc ma question: lorsque je fais un M503 est ce que cette valeur doit apparaitre en Z OFFSET ( j'ai z= 0) ? ou est-ce que je dois également enregistrer cette valeur avec un M851 Z -3.12, puis un M500 ? Je ne comprend pas trop car je pensais qu'il s'agissait de la même chose...

Merci d'avance

.

Partager ce message


Lien à poster
Partager sur d’autres sites
youtube drone débutant
il y a 53 minutes, zephus77 a dit :

quelqu'un aurait une idée ?

Bonjour, 

Personellement j'ai utilisé ce tuto pour configurer mon z offset sur mes anciennes imprimantes et il fonctionnait pas mal, essaye le

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour et merci smprofessionnel,

je vais regarder ton lien.... par contre je ne comprend pas pourquoi lorsque j'indique une valeur de z offset dans Marlin, il faut la remettre dans le slicer ...

C'est normal ou c'est la mise à jour qui ne se fait pas ?

Partager ce message


Lien à poster
Partager sur d’autres sites

ex : si Z offset= 2.5

dans marlin z offset -2.5 -----> j'obtiens z=0 dans slicer ou sur le lcd---> buse trop haute

dans slic3r, M851 Z - 2.5 -------> M503 m'affiche bien z offset -2.5 et idem sur lcd

A quoi ça sert de l'enregistrer dans MARLIN si, au final, on doit aussi le faire dans le Slicer ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez poster un message et vous inscrire plus tard. Si vous avez déjà un compte, connectez-vous afin de poster avec.

Invité
Répondre à ce sujet…

×   Vous avez copié du contenu avec formatage.   Supprimer le formatage

  Only 75 emoji are allowed.

×   Votre lien a été automatiquement intégré.   Afficher en tant que lien à la place

×   Le contenu sauvegardé a été restauré.   Effacer l'éditeur

×   You cannot paste images directly. Upload or insert images from URL.


  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×
×
  • Créer...