Aller au contenu

Filament ABS

webvince

Problème de capteur capacitif et autres petits soucis de mise en route

Messages recommandés

Premiers essais ce soir : ça maaarche !!!

Enfin presque : le capteur capacitif ne s'allume pas. Pourtant lorsque je le branche simplement sur une alimentation (sans le signal donc) il s'allume lorsque je l'approche de quelque chose et la vis de réglage modifie la distance d'allumage. J'ai aussi essayé avec un capteur inductif que j'ai eu avec la carte chez Emotiontech : pareil...

Ca viendrait donc de la carte d'interfaçage ? Quoique j'ai vérifié : sur les fiches de la RAMPS où se branche la carte d'interfaçage, je n'ai rien entre le GND et le VCC... Problème avec la RAMPS ? Quelque chose à activer au niveau du Marlin ?

J'ai bien fait gaffe au Marlin, j'ai une carte V2 et j'ai donc pris le Marlin adapté à cette carte...
Et j'ai vérifié : la config indiquée sur le site Emotiontech pour la carte d'interfaçage est bien celle que j'ai dans mes fichiers Configuration.h et pins.h...

Autre petit soucis : bien qu'ayant paramétré les dimensions de la machine dans Repetier en 300x300x300, tous les axes s'arrêtent à 200 de déplacement... C'est dans le Marlin qu'il faut changer quelque chose ?

Enfin j'ai manifestement un soucis de démultiplication sur le Z : quand je fais bouger de 10 mm dans Repetier, en fait j'ai un déplacement de plus de 4 cm !

Question subsidiaire : compte-tenu de la position de mon extrudeur (tourné vers la gauche), j'ai fixé la fin de course du X à droite (quand on regarde la machine de face). Y a-t-il quelque chose à modifier pour que le logiciel s'y retrouve, car du coup la surface d'impression est "inversée", non ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Problème de capteur capacitif résolu : en cherchant à comprendre comment marche la carte d'interface du capteur, je me suis rendu compte que les deux picots qui manquaient sur ma ramps 1.4, le 12V et GND aux, servaient aussi pour le capteur et pas seulement pour un éventuel ventilo ! Un p'tit coup de fer à souder pour ajouter ces deux pins et zou ça marche ! Pourquoi ces deux picots n'étaient pas sur la ramps, mystère, surtout qu'il y avait de la soudure dans les trous... Chinoiserie à 4 sous me direz-vous...:D En fait c'est éducatif les articles chinois, ils laissent des bugs ou des choses inachevées pour qu'on se donne la peine de comprendre pour réparer :D Le "finish yourself" :D

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant


×