Aller au contenu

GO Print

Début avec SR et Klipper


Greg33980

Messages recommandés

Salut à tous,

Depuis peu j’ai une SR et un Speeder Pad à la maison.

Je me lance dans l’impression 3D et c’est pas toujours simple mais on avance 😉

J’ai donc installé Klipper et tout semble fonctionner correctement.

Le Bed et le Z 0 sont réglés, la température de chauffe est calibrée et stable, la prochaine étape pour calibrer ce serait quoi pour vous?

Y’a tant de paramètres que je ne sais pas trop par quoi commencer..

Merci pour vos précieux conseils😉

Lien vers le commentaire
Partager sur d’autres sites

il y a une heure, Greg33980 a dit :

Salut à tous,

Depuis peu j’ai une SR et un Speeder Pad à la maison.

Je me lance dans l’impression 3D et c’est pas toujours simple mais on avance 😉

J’ai donc installé Klipper et tout semble fonctionner correctement.

Le Bed et le Z 0 sont réglés, la température de chauffe est calibrée et stable, la prochaine étape pour calibrer ce serait quoi pour vous?

Y’a tant de paramètres que je ne sais pas trop par quoi commencer..

Merci pour vos précieux conseils😉

Dans l'ordre des choses :

- Delta calibration

- Mesh Bed (avec plateau a 60°c)

- Z=0 (z-offset)

- Calibration des E-steps/mm de l'extrudeur

- Calibration du Pressure Advance

Lien vers le commentaire
Partager sur d’autres sites

Il y a 3 heures, Greg33980 a dit :

Petite question, pour le Z-offset pas besoin de faire chauffer quoi que ce soit?

Car je vois de tout… donc je me pose la question pour le faire bien..

Pour le Z-offset je le fait toujours a 60°c pour le bed environ et 200°c pour la buse cela permet d'ajuste le Z-offset dans les condition d'impression et comme y a dilatation de matière avec la chaleur surtout sur les pièces laitons ou alu donc c'est préférable. 

Lien vers le commentaire
Partager sur d’autres sites

Perso, vu qu’il y a une dilatation.. je ferais tout avec le bed et la buse de chaude..

Finalement c’est assez logique de se rapprocher d’une configuration en impression .

Mais comme je n’y connais pas autant que vous tous, je vais suivre tes conseils.

Merci!

Lien vers le commentaire
Partager sur d’autres sites

 
Alors ..
 
- Delta calibration ✅
 
 
- Mesh Bed (avec plateau a 60°c) ✅
 
(mon plateau est moche quand on regarde le résultat.. on voit que le plateau de verre colle trop…😋 Vivement que je reçoive le PEI..)

 

- Z=0 (z-offset) ✅

 

- Calibration des E-steps/mm de l'extrudeur ✅

(100,9mm à la mesure.. ensuite une fois le fichier modifié, j’ai 100mm tout pile, c’est satisfaisant 😬)

 

- Calibration du Pressure Advance

(Je vais attendre d’avoir mon PEI pour le faire)

 

2 petites questions svp :

Est ce qu’il est possible de re-niveller un peu le Bed ? Ou on s’en fiche car la calibration sert à corriger donc ça roule comme ça..

 

Maintenant que tout est ok ou presque, si je recalibre le Bed ou le Z_offset, par exemple, est ce que je dois refaire toutes les calibrations? Car lier entre elles.. ou pas d’ailleurs..

 

Merci pour vos lumières 😉

Lien vers le commentaire
Partager sur d’autres sites

Il y a 12 heures, Greg33980 a dit :
2 petites questions svp :

Est ce qu’il est possible de re-niveller un peu le Bed ? Ou on s’en fiche car la calibration sert à corriger donc ça roule comme ça..

 

Maintenant que tout est ok ou presque, si je recalibre le Bed ou le Z_offset, par exemple, est ce que je dois refaire toutes les calibrations? Car lier entre elles.. ou pas d’ailleurs..

 

Merci pour vos lumières 😉

La calibration des E-steps/mm ne sera plus a refaire sauf si tu touche a la vis de pression du filament ou modifie la tête ou l'extrudeur. Le pressure advance sera pas impacté non plus de trop

Par contre si tu met un PEI, que tu fait des ajustements de tension de courroie, il te faudra refaire Delta Calibration, Mesh Bed et Z=0

D'ailleur si tu utilise un PEI Double face avec 1 face lisse et 1 face texturé alors le Z=0 doit être ajuster quand tu utilise la face lisse ou texturé. Sur le PEI texturé la buse doit être un poil plus basse 😉 

Pour ce qui est de rattraper c'est compliquer surtout qu'avec un bed circulaire la déformation peu varié un peu en fonction de la dilatation, si la gueule du plateau est dans la mesure du raisonnable la correction de l'auto level est la pour corriger le tire 😉 

Modifié (le) par MrMagounet
Lien vers le commentaire
Partager sur d’autres sites

Ok super, au top MrMagounet😉

Au final, que ce soit le bed mesh, le z=0, la delta calibration ou même le PID c’est relativement simple à faire avec Klipper.
 
Faut juste penser à mettre le bed et/ou la buse en chauffe pour certaines procédures.
 
Concernant le réglage des courroies, y’a un truc pour faire ça bien?
Car je trouve que souvent ça a l’air au jugé.. et je suis pas fan..
J’ai vu un gars qui fait ça avec une appli de portable.. il fait vibrer la courroie pour atteindre 60Hz de fréquence.. un peu comme on accorde une guitare..
 
Je sais pas si c’est efficace ou pas..
Lien vers le commentaire
Partager sur d’autres sites

Il y a 3 heures, Greg33980 a dit :
Ok super, au top MrMagounet😉

Au final, que ce soit le bed mesh, le z=0, la delta calibration ou même le PID c’est relativement simple à faire avec Klipper.
 
Faut juste penser à mettre le bed et/ou la buse en chauffe pour certaines procédures.
 
Concernant le réglage des courroies, y’a un truc pour faire ça bien?
Car je trouve que souvent ça a l’air au jugé.. et je suis pas fan..
J’ai vu un gars qui fait ça avec une appli de portable.. il fait vibrer la courroie pour atteindre 60Hz de fréquence.. un peu comme on accorde une guitare..
 
Je sais pas si c’est efficace ou pas..

J'utilise la procédure suivante sur la SR. 

- Je défaits les Bras des chariot de rails linéaire

- Je place les chariot tous en haut des Axes X Y Z

- je desserre les les vis de reglage de tension de courroies

- Je prend mon smartphone et l'application CarlTune

- Un petit coup sur la structure de la SR avec le smartphone pour reveiller l'application et vérifier qu'elle capte bien les frequences

- Et je fait vibrer la courroie a mis hauteur pour voi quels fréquence j'ai sur les courroies

- Je règle la courroie a 46-47hz et je resserre les vis de tension de courroie de l'axe, je reverifie la frequence de ma courroir je dois avoir environ 52hz

- Et je fait pareil pour les 2 autres axes

Une fois cela effectué je refais les delta calibration, mesh, Z=0 et l'input shapper la resonnance 😉, et après quelques print je vérifie la tension de mes courroies voir si une des 3 c'est detentue et j'ajuste si besoin.

 

Lien vers le commentaire
Partager sur d’autres sites

J’aurais besoin d’une confirmation svp..

J’ai fait une tour de chauffage, pour pouvoir imprimer de la résine dans mon garage trop froid..

Ça fonctionne donc c’est cool! Mais je vois bien que j’ai un soucis sur les angles arrondis. Et j’ai même l’impression que ce qui a pu être imprimer avant influence la courbe de l’arrondis qui suit.. ( j’espère être clair🤪)

Je pense donc que je devrais faire la calibration Pressure Advance non?!

 

Si je ne dis pas de conneries.. je dois imprimer un cube spécial (j’ai déjà le STL) avec une vitesse de 100mm/s (ou peut-être encore mieux avec ma vitesse d’impression à moi?).

Il ne doit pas avoir de remplissage et une hauteur de couche de 0,3 si j’utilise une buse de 0,4..

Je dois également désactiver l’accélération dynamique de Cura et mettre en commande dans la console Klipper

SET_VELOCITY_LIMIT SQUARE_CORNER_VELOCITY=1 ACCEL=500

Puis ensuite comme je suis en Bowden je dois mettre cette commande

TUNING_TOWER COMMAND=SET_PRESSURE_ADVANCE PARAMETER=ADVANCE START=0 FACTOR=.020

Est ce que j’ai bien tout pigé?

Car la dernière fois que j’ai fais ça, j’ai cru que mon extrudeur allait mourir..🤣

mais je crois bien qu’en fait il faut arrêter le test quand il gratte trop car c’est normal..

 

Merci pour vos commentaires 😉

E1E85EAF-DB68-43B4-8446-E7D66B8AA803.jpeg

Modifié (le) par Greg33980
Ajout photo
Lien vers le commentaire
Partager sur d’autres sites

Petit Benchy imprimé ce soir, je suis assez content du résultat, c'est pas souvent..😅

 

Quelques défauts de coutures encore un peu visible, mais je ne sais pas trop sur quels paramètres je peux jouer pour corriger ça..

La roue libre n'a rien changé.. Je dois peut être cocher, "essuyer la buse entre les couches" ?

 

Voici des photos, imprimé en 0,2 avec 10% d'infill, une buse de 0,4, vitesse de déplacement 150mm/s, vitesse d'impression de la paroi externe 50 mm/s.

IMG_4366.JPG

IMG_4367.JPG

IMG_4370.thumb.JPG.a502f895dc8698656da250ad7c77899d.JPGIMG_4369.thumb.JPG.2fa4214a211b8aa3b2b8ee5c8beee6ed.JPGIMG_4368.thumb.JPG.0944a7eff33aa0b8d0e24fddf0f8f2f8.JPG

IMG_4373.thumb.JPG.e62372bf0ac467e2ded527e767e08406.JPGIMG_4372.thumb.JPG.6713a9eeebbb7056ba1eacf7ed642c19.JPGIMG_4371.thumb.JPG.e19aa65c32da620d0cc18e1edde9b80f.JPG

Lien vers le commentaire
Partager sur d’autres sites

Oui le pressure advance aide a imprimer proprement sur les changement de direction important comme les angles, donc je te conseille de bien le calibré en effet. Et oui tu peu être fier de ton benchy il est propre y peut être que la première couche qui n'est pas assez écraser. 

Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...