Aller au contenu

Anycubic Kobra 3 Combo

bug Alfawise U30


Michel012

Messages recommandés

Bonjour à tous, Depuis un moment  mon imprimante Alfawise U30 finie d'imprimer mes pièces mais au lieu de se dégagée de la pièce elle reste dessus un moment puis très très lentement elle se dégage en laissant quelques traces, puis soudain après quelques secondes la tête se dégage rapidement, que dois-je modifier pour que la tête se retire rapidement une fois l'impression terminée.

j'utilise cura 5

Lien vers le commentaire
Partager sur d’autres sites

Comme attendu, tu as récupéré un Gcode de fin fait avec les pieds 😩. Exemple à la fin de l'impression:

G1 Z+0.5 E-5 X-20 Y-20 F80 ;move Z up a bit and retract filament even more

la buse se déplace de -20m en X et -20mm en Y à 1.33mm/s. Tu m'étonnes que tu trouves le temps long 🤣

En passant, ton Gcode de démarrage n'est pas beaucoup mieux 🥴.

Je te conseille plutôt de remplacer tout ce bazar par ceux-ci:

Gcode de démarrage

; -- START GCODE --
G21 ;set units to millimetres
G90 ;set to absolute positioning
M106 S0 ;set fan speed to zero (turned off)
M201 Z10 ;acc for Z-homing
G28 ;home all axis
G92 E0 ;zero the extruded length
G1 Z2.0 F3000 ; Move Z Axis up little to prevent scratching of Heat Bed
G1 X0.1 Y10 Z0.2 F5000.0 ; Move to start position
G1 X0.1 Y190.0 Z0.2 F1500.0 E8 ; Draw the first line
G1 X0.4 Y190.0 Z0.2 F5000.0 ; Move to side a little
G1 X0.4 Y10 Z0.2 F1500.0 E16 ; Draw the second line
G92 E0 ; Reset Extruder
G92 E0 ;zero the extruded length again
; -- end of START GCODE --

Gcode de fin:

; -- END GCODE --
G91 ;set to relative positioning
G0 Z2 F600 ; move up 2mm
G1 E-10 F1000 ;retract the filament slightly
G90 ;set to absolute positioning
G28 X
G0 Y190 F3000
G92 E0 ;zero the extruded length
G1 E-10 F1000 ;retract the filament
M104 S0 ;turn off nozzle heater
M140 S0 ;turn off bed heater
;G0 Y280 F600 ;bring the bed to the front for easy print removal
M84 ;turn off stepper motors
; -- end of END GCODE --
Lien vers le commentaire
Partager sur d’autres sites

Merci pour ton travail, mais comment je modifie le fichier gcode, alors qu'il est crée par cura 5.1, je viens de faire un copier coller des modifs que vous m'indiquez pour les rentrer mais ou et comment avec quel logiciel. je n'y connait pas grand chose hélas.

j'ai dessiné ces petites pièces avec freecad en Stl puis j'utilise Cura 5.1 pour transformer le stl en Gcode et imprimer mes pièces

Lien vers le commentaire
Partager sur d’autres sites

il y a 7 minutes, Michel012 a dit :

alors qu'il (ndlr: Gcode de démarrage / fin ?) est crée par cura 5.1

tiens donc, c'est nouveau ça 🤔... pour info, ces "Gcodes" sont proposés par des utilisateurs et recopié sans vérification par Ultimaker, l'éditeur du logiciel. Il faut donc rester critique vis-à-vis de ces Gcodes.

Dans Cura, tu vas dans le menu préférences->Configurer Cura->Imprimantes->Parametres de la machine et tu remplaces le contenu des cases Gcode de démarrage et Gcode de fin par ceux que j'ai proposés. C'est fini 🥳

Modifié (le) par pommeverte
Lien vers le commentaire
Partager sur d’autres sites

Ce n'est pas un fichier télécharger,  ultimaker n'y est pour rien, je dessine moi même en 3D mes pièces dont j'ai besoin, cela je sais le faire,  je les sauvegarde en FCStd (format freecad), puis dans l'application je sélectionne les paramètres soit fusionnés ou pas, puis je clique sur fichier  en haut à gauche et sur exporter dans la colonne ouverte,  pour que je le sauvegarde  en fichier se transforme en STL, que je reprends ensuite avec cura 5.1 pour le transformer en Gcode, je le  transfert depuis cura sur une carde SD, qui donne à l'Afawise ou à mon imprimante Sidewinder X2 qui elle utilise une clef USB,  les instructions Gcode nécessaires.

Je vous remercie pour votre travail, et maintenant que vous m'avez expliqué comment modifier les paramètres de mon Alfawise U30 je vais exécuter les modifications

Joyeuse pâques Amicalement Michel

Je répète que ultimaker n'y est pour rien car au début l'Afawise U30 fonctionnait très bien  puis un jour elle m'a fait ce truc un bug qui est venu dieu sait comment.

Lien vers le commentaire
Partager sur d’autres sites

Il y a 1 heure, Michel012 a dit :

Je répète que ultimaker n'y est pour rien

dans ce cas, c'est toi 😁.

Il y a 1 heure, Michel012 a dit :

ce truc un bug qui est venu dieu sait comment.

Dieu n'y est pour rien 😜!

Pour info, les Gcodes de démarrage et de fin sont remplis automatiquement lorsque tu choisis l'imprimante pour créer ta configuration. Si tu as eu le comportement que tu as décrit, c'est que ces Gcodes ont été modifiés, par toi ou en changeant de version de Cura, peut-être.🤔

Dans tous les cas, cela n'a rien à voir avec le processus de création du fichier 3D (STL).😉

Bon, je viens de vérifier, ces Gcodes de démarrage et de fin sont bien ceux fournis lorsqu'on sélectionne l'imprimante Alfawise U30 🤬!!! Je peux donc désormais t'affirmer que le problème vient précisément de Mr Nicolas Nussbaum, qui est tellement fier de lui qu'il a signé son délit dans le fichier "C:\Program Files\Ultimaker Cura 5.1.0\share\cura\resources\definitions\alfawise_u30.def.json". Mais je persiste à dire qu'Ultimaker pourrait prendre 5min pour vérifier ce que propose les utilisateurs 😩

Joyeuses Pâques également 😁

 

Modifié (le) par pommeverte
Lien vers le commentaire
Partager sur d’autres sites

Dieu n'y est pour rien, je n'en suis pas sur,  mais peut être Cura car je suis passé de cura 3.x au 5.1,  en tout cas j'ai fait les modifications que vous préconisiez, et ça marche bien, la tête ne reste qu'une fraction de seconde puis elle s'écarte merci pour tout vos conseils et votre savoir faire.

Merci beaucoup  pommeverte

Cordialement Michel

  • Merci ! 1
Lien vers le commentaire
Partager sur d’autres sites

Slt Pommeverte je reviens vers vous, car il me reste un petit soucis, car mon Alfawise U30 se dégage maintenant rapidement, mais elle laisse un petit cône de fil fondu  sur mes pièces, pour les grosses pièces cela va bien mais les petites pièces fragiles c'est difficile à retirer.

Quelle ligne je dois modifier, si cela est possible je pense que l'arrêt du fil doit se faire juste avant le dégagement

amicalement Michel

 

Lien vers le commentaire
Partager sur d’autres sites

Salut,

Pour limiter le picot, tu peux remplacer les 3ères lignes du Gcode de fin par celui-ci (Gcode de fin partiel de la Ender3):

G91
G1 E-2 F2700 ;Retract a bit
G1 E-2 Z0.2 F2400 ;Retract and raise Z
G1 X3 Y3 F3000 ;Wipe out

Perso, je donne un petit coup de cutter 😅

Lien vers le commentaire
Partager sur d’autres sites

Oui moi aussi sur les grosses pièces j'utilise un cutter, mais sur les petites j'en n'ai cassé une,  je vais la réimprimer après la modif pour le  moment j'imprime des pièces plus importante je vous donnerais le résultat plus tard.

amicalement Michel

Lien vers le commentaire
Partager sur d’autres sites

  • 2 weeks later...

Bonjour pommeverte, j'ai exécuté les modifs  à partir de G 91 et  les 3 lignes suivantes, cela ne change rien j'ai toujours ce petit bourrelet qui casse mes petites pièces  quand j'essaye de l'enlever au cutter, alors ma solution,  j'utilise une lime bâtarde puis une  demie douce.

Si jamais vous trouver la solution faite le moi savoir

Amicalement Michel

 

 

Lien vers le commentaire
Partager sur d’autres sites

Salut,

Voici une photo du picot laissé à la fin de l'impression de ta pièce. Honnêtement, à l’œil, j'ai de la peine à voir le défaut. 😅

Citation

Photopicotfin(sanszoom).thumb.jpg.2e997c1b0f1891df3f7e01b04bdc0e1c.jpg

zone où a été prise la photo:

impressionAnglesouri.thumb.jpg.e1c57692602996f5f35c1717648a31c6.jpg

Le Gcode de fin est cependant légèrement différent:

Citation

; -- END GCODE --
G91 ;set to relative positioning
G1 E-4 F2700 ;Retract a bit
G1 Z0.2 F2400 ;Raise Z
G1 X3 Y3 F3000 ;Wipe out

Modifié (le) par pommeverte
Lien vers le commentaire
Partager sur d’autres sites

Slt  Pommeverte, j'ai exécuté  les modifs cela ne change rien, il reste encore se petit bec qui sur une grosse pièce ne me gène pas mas sur les petites pièces ce n'est pas la même chose, pour cet essai cela ne me gêne pas mais le guidon de ma moto au 1/10 em qui de fait que 2.025 mm, j'ai peur de le cassé rien quand enlevant ce bec.

Photo de gauche un essai photo de droite certaines pièces déjà réalisé ajouté au pièce perdu dans la boite.

Cordialement  Michel

IMG_20230428_130845.jpg

IMG_20230412_203717.jpg

Lien vers le commentaire
Partager sur d’autres sites

Salut,

Est-ce que tu peux recharger tes photos car elles n'apparaissent pas? 🤔

Edit: c'est dû à un bug qui vient d'être corrigé (voir ce sujet). Voici donc tes photos:

U30picot1.thumb.jpg.c529e1d9ded87486780107063cfaddf4.jpg

 

U30picot2.thumb.jpg.39f5044e7bd40fbda2d9d944676cd505.jpg

Il y a 8 heures, Michel012 a dit :

le guidon de ma moto au 1/10 em qui de fait que 2.025 mm, j'ai peur de le cassé rien quand enlevant ce bec.

Est-ce que tu peux fournir le fichier STL et Gcode de ton guidon? Il suffira peut-être de faire un mouvement final pour mieux écraser le picot 🤨

 

Modifié (le) par pommeverte
Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
  • Sur cette page :   0 membre est en ligne

    • Aucun utilisateur enregistré regarde cette page.
  • YouTube / Les Imprimantes 3D .fr

×
×
  • Créer...