Aller au contenu

Filament ABS

Problème de RepRap avec commande manuel


sdow

Messages recommandés

bonjour

Quand je essaye de commander manuellement mon imprimante 3D quand je click sur le bouton pour le déplacer l'axe x et y se déplacent en même temps ....comme si il sont brancher ensemble ....pourriez vous m,aider .

Merci

Envoyé de mon Tapatalk

Lien vers le commentaire
Partager sur d’autres sites

bonjour

....comme si il sont brancher ensemble ....

Tu as bien sure vérifié que ça n'était pas le cas ?

Tu as quels logiciels de commande ? (Marlin + Repetier ?)

Lien vers le commentaire
Partager sur d’autres sites

Si c'est pour une ramps 1.4 de reprap, je te conseil de suivre les infos à leur source : http://reprap.org/wiki/RAMPS_1.4

500px-Rampswire14.svg.png

Met toi dans cette configuration avec tous les fils de tes moteurs branchés. Pour Z, inutile de faire une jonction individuelle des 2 nappes de moteur, il y a déjà 2 connecteurs prévus à cet effet sur la carte.

Lien vers le commentaire
Partager sur d’autres sites

Le schéma que tu m'avait envoyé est pour les nema 17....moi je utilise des moteurs nema 23 avec des drives externes ...j'ai branché exactement comme le schéma que j'ai publié... J'ai juste déplacer des moteurs de y vers z. Car moi j'ai deux moteurs sur z et non sur y .....mais je viens de trouver le problème la commande core XY était activé.

Envoyé de mon Tapatalk

Lien vers le commentaire
Partager sur d’autres sites

voila le principe de ma machine : http://mchobby.be/wiki/index.php?title= ... g-xyz3.png

.... aide moi à configurer correctement les déplacement des axes ....je veux que la position home soit y et z : max x:min en se basent sur les repérés de images

// The pullups are needed if you directly connect a mechanical endswitch between the signal and ground pins.

const bool X_MIN_ENDSTOP_INVERTING = false; // set to true to invert the logic of the endstop.

const bool Y_MIN_ENDSTOP_INVERTING = false; // set to true to invert the logic of the endstop.

const bool Z_MIN_ENDSTOP_INVERTING = true; // set to true to invert the logic of the endstop.

const bool X_MAX_ENDSTOP_INVERTING = false; // set to true to invert the logic of the endstop.

const bool Y_MAX_ENDSTOP_INVERTING = false; // set to true to invert the logic of the endstop.

const bool Z_MAX_ENDSTOP_INVERTING = false; // set to true to invert the logic of the endstop.

//#define DISABLE_MAX_ENDSTOPS

//#define DISABLE_MIN_ENDSTOPS


// Disable max endstops for compatibility with endstop checking routine

#if defined(COREXY) && !defined(DISABLE_MAX_ENDSTOPS)

  #define DISABLE_MAX_ENDSTOPS

#endif


// For Inverting Stepper Enable Pins (Active Low) use 0, Non Inverting (Active High) use 1

#define X_ENABLE_ON 0

#define Y_ENABLE_ON 0

#define Z_ENABLE_ON 0

#define E_ENABLE_ON 0 // For all extruders


// Disables axis when it's not being used.

#define DISABLE_X false

#define DISABLE_Y false

#define DISABLE_Z false

#define DISABLE_E false // For all extruders

#define DISABLE_INACTIVE_EXTRUDER true //disable only inactive extruders and keep active extruder enabled


#define INVERT_X_DIR true    // for Mendel set to false, for Orca set to true

#define INVERT_Y_DIR true    // for Mendel set to true, for Orca set to false

#define INVERT_Z_DIR false     // for Mendel set to false, for Orca set to true

#define INVERT_E0_DIR false   // for direct drive extruder v9 set to true, for geared extruder set to false

#define INVERT_E1_DIR false    // for direct drive extruder v9 set to true, for geared extruder set to false

#define INVERT_E2_DIR false   // for direct drive extruder v9 set to true, for geared extruder set to false


// ENDSTOP SETTINGS:

// Sets direction of endstops when homing; 1=MAX, -1=MIN

#define X_HOME_DIR -1

#define Y_HOME_DIR -1

#define Z_HOME_DIR 1


#define min_software_endstops true // If true, axis won't move to coordinates less than HOME_POS.

#define max_software_endstops true  // If true, axis won't move to coordinates greater than the defined lengths below.


// Travel limits after homing

#define X_MAX_POS 400

#define X_MIN_POS 0

#define Y_MAX_POS 400

#define Y_MIN_POS 0

#define Z_MAX_POS 300

#define Z_MIN_POS 0


#define X_MAX_LENGTH (X_MAX_POS - X_MIN_POS)

#define Y_MAX_LENGTH (Y_MAX_POS - Y_MIN_POS)

#define Z_MAX_LENGTH (Z_MAX_POS - Z_MIN_POS)

//============================= Bed Auto Leveling ===========================

Lien vers le commentaire
Partager sur d’autres sites

tu as mis 6 endstop ?

Pour le reparamétrage, le mieux est encore de faire faire quelques mouvement à ta machine pour voir comment elle interprète les commandes que tu lui envoi. (Est-ce que +10 en Y déplace bien dans le sens +Y et non -Y par exemple) Après il te suffit d'inverser ou non les sens de direction en fonction de ce que tu veux.

Il te faudra aussi indiquer où tu veux faire ton homing (qui sert juste à trouver un point fixe à partir duquel les autres dimensions seront déduites)

Lien vers le commentaire
Partager sur d’autres sites

Oui j,ai 6 end stop .... E c,est la mon problème les axes ne vont pas dans le bon sens .... Quad je change le sens de Y. J,ai des bugs sur Z... Il faut absolument laisser à false la direction de Y. ....pouvez vous me dire X Y devront aller dans quel sens si je click sur +

Envoyé de mon Tapatalk

Lien vers le commentaire
Partager sur d’autres sites

Je suppose que les bugs sur Z sont une absence de mouvement.

En fait, tu ne peux te déplacer sur Z qu'après avoir fait un homing en X et en Y qui soit valide (sécurité je suppose). Lorsque tu inverse l'axe Y, cela inverse la position du endstop que ta machine s'attend à trouver. Par exemple si le homing était calé sur le endstop Ymax, inverser le mouvement fera aller ton plateau vers le endstop Ymin ; du coup, la machine ne trouvant pas le endstop Ymax, elle ne valide pas le homing sur Y et n'autorise donc pas les mouvements sur Z.

Donc si tu inverse le sens de déplacement d'un axe, pense à inverser les endstop associés, soit par Marlin en déclarant que le homing se fait maintenant sur le endstop min, soit physiquement en changeant la position de tes endstop. L'essentiel est de garder une cohérence dans l'ensemble (les endstop max à la position des axes max par exemple).

Personnellement, mon origine (0,0,0) est en bas à gauche. Je fait mon homing en Xmax, Ymin et Zmin. J'ai du inverser la logique de l'axe x car mes impressions étaient "miroitées".

Lien vers le commentaire
Partager sur d’autres sites

voila mon imprimante je veux que le home se fait en haut à gauche .... que je dois faire ..... je travaille sens problème avec mache3 pour cnc j'ai jamais eu des bugs de ce gendre ....maintenant le x et y vont dans le bon sens ..... mais bug avec Z

je fais refinance home pour x et y et z tout est ok

quand je veux descendre mon z .... je click sur les négatif -10 -100 et là le bug le z ne bouge pas .... le x et y commencent a bauger seulement quand je click sur les négatifs de Z

http://www.usinages.com/attachments/image-jpg.228246/

// The pullups are needed if you directly connect a mechanical endswitch between the signal and ground pins.

const bool X_MIN_ENDSTOP_INVERTING = false; // set to true to invert the logic of the endstop.

const bool Y_MIN_ENDSTOP_INVERTING = false; // set to true to invert the logic of the endstop.

const bool Z_MIN_ENDSTOP_INVERTING = true; // set to true to invert the logic of the endstop.

const bool X_MAX_ENDSTOP_INVERTING = false; // set to true to invert the logic of the endstop.

const bool Y_MAX_ENDSTOP_INVERTING = false; // set to true to invert the logic of the endstop.

const bool Z_MAX_ENDSTOP_INVERTING = false; // set to true to invert the logic of the endstop.

//#define DISABLE_MAX_ENDSTOPS

//#define DISABLE_MIN_ENDSTOPS


// Disable max endstops for compatibility with endstop checking routine

#if defined(COREXY) && !defined(DISABLE_MAX_ENDSTOPS)

  #define DISABLE_MAX_ENDSTOPS

#endif


// For Inverting Stepper Enable Pins (Active Low) use 0, Non Inverting (Active High) use 1

#define X_ENABLE_ON 0

#define Y_ENABLE_ON 0

#define Z_ENABLE_ON 0

#define E_ENABLE_ON 0 // For all extruders


// Disables axis when it's not being used.

#define DISABLE_X false

#define DISABLE_Y false

#define DISABLE_Z false

#define DISABLE_E false // For all extruders

#define DISABLE_INACTIVE_EXTRUDER true //disable only inactive extruders and keep active extruder enabled


#define INVERT_X_DIR true    // for Mendel set to false, for Orca set to true

#define INVERT_Y_DIR true    // for Mendel set to true, for Orca set to false

#define INVERT_Z_DIR false     // for Mendel set to false, for Orca set to true

#define INVERT_E0_DIR false   // for direct drive extruder v9 set to true, for geared extruder set to false

#define INVERT_E1_DIR false    // for direct drive extruder v9 set to true, for geared extruder set to false

#define INVERT_E2_DIR false   // for direct drive extruder v9 set to true, for geared extruder set to false


// ENDSTOP SETTINGS:

// Sets direction of endstops when homing; 1=MAX, -1=MIN

#define X_HOME_DIR -1

#define Y_HOME_DIR 1

#define Z_HOME_DIR 1


#define min_software_endstops true // If true, axis won't move to coordinates less than HOME_POS.

#define max_software_endstops true  // If true, axis won't move to coordinates greater than the defined lengths below.


// Travel limits after homing

#define X_MAX_POS 400

#define X_MIN_POS 0

#define Y_MAX_POS 400

#define Y_MIN_POS 0

#define Z_MAX_POS 300

#define Z_MIN_POS 0


#define X_MAX_LENGTH (X_MAX_POS - X_MIN_POS)

#define Y_MAX_LENGTH (Y_MAX_POS - Y_MIN_POS)

#define Z_MAX_LENGTH (Z_MAX_POS - Z_MIN_POS)

Lien vers le commentaire
Partager sur d’autres sites

Lorsque tu dis

je veux que le home se fait en haut à gauche
tu veux dire au fond à gauche du plateau avec Z au mini, ou Z au maxi (en haut)

Si tes axes bougent dans le bon sens, c'est déjà bien. Reste à régler le homing.

Tes paramètres indiquent que lors du homing tu vas actionner les endstop X mini , Y maxi et Z Maxi.

Assure toi donc que lors de ton homing, ce sont bien endstop X mini , Y maxi et Z Maxi que ta machine vient déclencher.

Lien vers le commentaire
Partager sur d’autres sites

Le choix de Z en haut ne me semble pas très pratique. En effet, le réglage de point 0 sur Z se fait (dans un premier temps) en positionnant très précisément le endstop de Z. Si tu fait ton home Z en haut et la vérification du point 0 de Z en bas (obligé) ça va te prendre un temps monstrueux rien qu'en déplacement.

Dans ton cas je testerai ceci dans un premier temps (je pense que plus tard il te faudra probablement inverser X ou Y à cause de l'effet miroir dont je t'ai parlé auparavant ; mais on verra ça plus tard) :

Pour X : Home en mini à gauche. (Vérifier que c'est bien le endstop mini qui est raccordé à cet endroit)

#define X_HOME_DIR -1
Pour Y : Home en mini (au fond. Vérifier que c'est bien le endstop mini qui est raccordé à cet endroit)
#define Y_HOME_DIR -1
Pour Z : Home en mini en bas (un home en maxi me semble vraiment inapproprié pour les raisons évoquées plus haut) (Vérifier que c'est bien le endstop mini qui est raccordé à cet endroit)
#define Z_HOME_DIR -1

Si le sens de déplacement de tes axes te conviens, ne change rien au reste.

Lien vers le commentaire
Partager sur d’autres sites

Il te faut des fichiers au format .stl ou .obj (il y en a à la pelle dans thingiverse).

Pour le reste, il te suffi de suivre n'importe quel tuto sur Repetier.

Par contre, si tu souhaite faire une simulation à vide, il se peux que tu rencontre des problèmes liés à l'absence de tête d'impression car un certain nombre de paramètres lui sont liés (comme la T° par ex.) et conditionnent l'exécution du Gcode de ta pièce.

Il y a une fonction de simulation sur Repetier, mais je ne sais pas comment elle fonctionne.

Lien vers le commentaire
Partager sur d’autres sites

Ok j'ai effacer les codes pour la température et ça marche plus tôt bien .

Par exemple est ce que les endstops devront limiter le mouvement de la machine....car en home ils vont bien et l,autre sens il ne se arrête pas au endstops ...

Envoyé de mon Tapatalk

Lien vers le commentaire
Partager sur d’autres sites

Pour les endstop max, je ne sais pas trop comment ils sont utilisés, je n'en ai pas sur ma machine. Ce qui limite les courses de tes axes c'est :

// Travel limits after homing

#define X_MAX_POS 400

#define X_MIN_POS 0

#define Y_MAX_POS 400

#define Y_MIN_POS 0

#define Z_MAX_POS 300

#define Z_MIN_POS 0
Cela signifie que tu autorise une de 400 mm sur X et sur Y ; et de 300 mm sur Z. Attention à bien faire la différence entre les dimensions théoriques de ta machine et les déplacement réels autorisés en fonction de l'encombrement de ta tête d'impression et de tout ce quelle trimbale. Je te conseil de réduire les dimensions à 300, 300 et 200 dans un premier temps. Une fois que tu vois que les déplacements sont correctes et que tu as installé ta tête d'impression, tu pourra récupérer les dimensions en t'assurant que rien ne vient en collision. En revanche, j'ai des doutes sur la pertinence des paramètres suivants :
// The pullups are needed if you directly connect a mechanical endswitch between the signal and ground pins.

const bool X_MIN_ENDSTOP_INVERTING = false; // set to true to invert the logic of the endstop.

const bool Y_MIN_ENDSTOP_INVERTING = false; // set to true to invert the logic of the endstop.

const bool Z_MIN_ENDSTOP_INVERTING = true; // set to true to invert the logic of the endstop.

const bool X_MAX_ENDSTOP_INVERTING = false; // set to true to invert the logic of the endstop.

const bool Y_MAX_ENDSTOP_INVERTING = false; // set to true to invert the logic of the endstop.

const bool Z_MAX_ENDSTOP_INVERTING = false; // set to true to invert the logic of the endstop.

Chez moi ils sont tous à TRUE ce qui signifie (je crois) qu'ils réagissent tous de la même manière. Je pense que le fait d'avoir inversé leur logique est peut être à l'origine de tes pb avec les endstop max. C'est toi qui a modifié ces paramètres ?

Lien vers le commentaire
Partager sur d’autres sites

  • 5 weeks later...

Bonjour

Je suis arrivé a connecter le chauffage d'extruder et le capteur ...quand je branche la machine dans électricité ... l'arduino allume le chauffage sens se arrêter la température de gauche augmente .... 20/0 ... 22/0 .... 160/0 ....170 /0 .... sens se arrêter ... J'ai regarder dans configurations ... le temp. min est à 10 et max 200.. ou est le problème ?

Merci

Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

  • YouTube / Les Imprimantes 3D .fr

×
×
  • Créer...