Aller au contenu

Filament ABS

pascal_lb

Bed qui n'arrète pas de chauffer...

Messages recommandés

Voilà je suis actuellement en train de changer plusieurs choses dont le bed, j'ai installé un MK3 à la place du MK2 d'origine

J'ai branché le négatif sur le 3 et le 2 et le positif sur le 1, j'ai conservé les fils d'origine

J'ai laissé la thermistance d'origine

Et là surprise le bed chauffe très bien... mais ne se coupe pas lorsqu'il atteint la température demandé, pourtant la température est bien détectée par la thermistance, j'ai vérifié avec un thermomètre, pour un réglage à 50° je monte à 90° et si je baisse la température à 30° ça continu à monter >:(

Au voltmètre j'ai 10,80 v sur le bed avec l'alim d'origine (15A)

Bon si vous avez une idée... je suis preneur...

Partager ce message


Lien à poster
Partager sur d’autres sites

Malheureusement je ne te serai d'aucune aide, sur ce coup. :/

Par contre tu pourras peut-être m'indiquer les différences entre le MK2 et le MK3 ? C'est peut-être naïf de ma part mais pour moi, un plateau chauffant, c'est un plateau chauffant... :P Donc quelque chose doit forcément m'échapper. :) 

Partager ce message


Lien à poster
Partager sur d’autres sites

Hello Pascal,

Comme tu as changé de bed je pense qu'il faut revoir les PID du bed dans Marlin.

Tu peux executer un autotun avec la commande suivante : M303 E-1 C6 S80

M303 = Gcode Autotun

E-1 = Bed

C6 = Nb cycles

S80 = Température

@+

Modifié (le) par DIYZaop
  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 43 minutes, Chris V. a dit :

Malheureusement je ne te serai d'aucune aide, sur ce coup. :/

Par contre tu pourras peut-être m'indiquer les différences entre le MK2 et le MK3 ? C'est peut-être naïf de ma part mais pour moi, un plateau chauffant, c'est un plateau chauffant... :P Donc quelque chose doit forcément m'échapper. :) 

La MK3 est en alu donc + rigide et normalement plus plate, on peut imprimer directement dessus (moi je vais quand même utiliser la vitre), elle consomme moins que la MK2 et une fois à température elle garde sa température + longtemps donc je pense économie d'énergie

il y a 27 minutes, DIYZaop a dit :

Hello Pascal,

Comme tu as changé de bed je pense qu'il faut revoir les PID du bed dans Marlin.

Tu peux executer un autotun avec la commande suivante : M303 E-1 C6 S80

M303 = Gcode Autotun

E-1 = Bed

C6 = Nb cycles

S80 = Température

@+

Oups pour l'instant ça c'est du chinois pour moi, merci DIYZaop je vais me documenter ¬¬ 

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour Pascal

Même problème que toi, j'ai réussi pour l'instant à solutionner le problème en utilisant la commande M303

Consulte cette page : http://3dprinting.forumactif.org/t226-reglage-du-pid-aux-petis-oignons

ça suppose qu'au préalable tu aies activé le PID du BED dans ton marlin.

De ce que j'en ai compris :

Sans PID ton bed chauffe et dès qu'il atteint la température ça s'arrête => fonctionnement en 0 ou 1, ça consomme plus et sollicite plus les MOFSET (composant à 3 pattes qui gère la chauffe du BED mais tu en as aussi un pour la hotend, un pour la ventilation), le mien était bouillant avec cette méthode et ne respectait pas la consigne, j'en ai déduis qu'il supportait pas le chaud.

Avec le PID, la régulation permet d'osciller autours de la valeur cherchée, c'est à dire que l'alimentation va envoyer des impulsions permettant de garantir la température, sans pour autant tirer au max sur le MOFSET

J'ai ajouté aussi des ventilateurs sur ma carte de contrôle, pour qu'il garde bien la tête froide.

Modifié (le) par yearzero
correction ortograf
  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites

ok apparemment c'est pour pouvoir renseigner ces lignes

    #define  DEFAULT_bedKp 10.00
    #define  DEFAULT_bedKi .023
    #define  DEFAULT_bedKd 305.4

Le problème c'est que je n'ai jamais réussi à connecter repetier sur la sanguinololu

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 4 minutes, pascal_lb a dit :

Le problème c'est que je n'ai jamais réussi à connecter repetier sur la sanguinololu

Ah oui ! problème de vitesse de l'interface Baud Rate ou le driver  ?FX4D12HIA592LHR.MEDIUM.jpg

Modifié (le) par DIYZaop

Partager ce message


Lien à poster
Partager sur d’autres sites

Super les gars, merci beaucoup :), effectivement la ligne //#define PIDTEMPBED est commenté, je vais commencer par la heureusement j'arrive à me connecter avec arduino IDE

ensuite test de connexion avec repetier, et si j'y arrive autotune

Avec vos liens effectivement c'est beaucoup plus clair :) :banana:

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon aujourd'hui 1er test plus rien ne chauffe coté bed et j'ai trouvé la cause, je crois que ça a un peu chauffé :emoji-E412: 

Heureusement il y a une semaine j'ai commandé une ramps 1.4 que je dois recevoir début de semaine prochaine

DSC05180.thumb.JPG.b5a87b5d275788456e50cf9a684417b9.JPG

Partager ce message


Lien à poster
Partager sur d’autres sites

Oh bah. Ca m'a l'air assez fréquent que ces trucs flambent, j'en ai déjà croisé une chiée sur le forum officiel GT. 

Partager ce message


Lien à poster
Partager sur d’autres sites

ouai j'ai déjà vu ça aussi, pourtant il doit pouvoir encaisser 60v et 30A mais comme ils sont en l'air et pas fixé sur un radiateur, dès que l'on demande un peu de puissance ils claquent

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 20 heures, yearzero a dit :

Sans PID ton bed chauffe et dès qu'il atteint la température ça s'arrête => fonctionnement en 0 ou 1, ça consomme plus et sollicite plus les MOFSET (composant à 3 pattes qui gère la chauffe du BED mais tu en as aussi un pour la hotend, un pour la ventilation), le mien était bouillant avec cette méthode et ne respectait pas la consigne, j'en ai déduis qu'il supportait pas le chaud.

Avec le PID, la régulation permet d'osciller autours de la valeur cherchée, c'est à dire que l'alimentation va envoyer des impulsions permettant de garantir la température, sans pour autant tirer au max sur le MOFSET

Effectivement j'ai testé cette après midi le système de PID sur l'extrudeur, lorsque l'on met la chauffe de l'extrudeur en route on a environ 12v sur la sortie de la carte, une fois la température atteinte on a 0v et ensuite quand la température redescend on a environ 2/3v pendant quelques secondes et ça permet de remonter de 1 ou 2 degrés sans mettre toute la sauce.
Quand je vais changer la carte pour une ramps je vais activer les PID sur le bed et comme sur la MK3 c'est une plaque d'alu de 3 mm elle gardera la température plus longtemps ça permettra d'avoir une consommation moins importante et une température + constante  et comme le dit @yearzero ça tirera moins sur les MOFSET

Modifié (le) par pascal_lb

Partager ce message


Lien à poster
Partager sur d’autres sites

P_20170201_150357.thumb.jpg.a84cbb0415335f6388387231220a5b2b.jpg

 

J'ai mis des ventilo en supplément sur ma carte histoire de bien refroidir l'ensemble.

 

J'ai trouvé le modèle sur thingiverse, tu recherches "toolson" si ça peut t'aider !

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 15 heures, yearzero a dit :

P_20170201_150357.thumb.jpg.a84cbb0415335f6388387231220a5b2b.jpg

 

J'ai mis des ventilo en supplément sur ma carte histoire de bien refroidir l'ensemble.

J'ai trouvé le modèle sur thingiverse, tu recherches "toolson" si ça peut t'aider !

Je pensais effectivement mettre de la ventilation sur la ramps et ajouter des petits radiateurs sur les MOFSET genre radiateur que tu mets habituellement sur le processeur des raspberry pi 

Tu n'as que 4 drivers sur ta ramps ? je pensais que l'on était obligé de mettre les 5... tu n'as pas de radiateur dessus ?

Partager ce message


Lien à poster
Partager sur d’autres sites

oui donc le 5eme driver on peut le mettre pour un deuxième extrudeur

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant


×