Aller au contenu

Filament ABS

Problème 3DTOUCH (HS ?)


Aragats

Messages recommandés

Bonjour,

Hier soir, j'ai enfin eut le temps pour installer mon 3DTouch sur ma Prusa i3 PRO B

J'ai pas mal galéré mais pour faire court, j'ai réussi à le faire fonctionner en :

- Utilisant le firmware "Marlin-bugfix-1.1.x_e16743d-PI3_Pro_B_3DTouch"  (préconisé par pas mal de monde sachant qu'avec ma version + modif du manuel, le 3DTouch restait en alarme)

- Modifiant SERVO0_PIN à 11 dans le fichier GT2560.h (aucune idée si utile vu qu'il y a des define de cette valeur un peu partout avec différentes valeurs)

- Modifiant la valeur de "#define INVERT_X_DIR" et la passer à FALSE (l'axe X bougeait dans le mauvais sens)

- Adapter avec mes EStep perso

Après tout cela, cela fonctionnait presque parfaitement sauf que lors du test "Level Bed", après avoir calibrer le centre ca allait trop à droite de mon imprimante

J'ai donc modifié les variables RIGHT_PROBE_BED_POSITION et LEFT_PROBE_BED_POSITION pour adapter comme il faut

J'ai réussi à faire 2-3 test complets mais où il fallait encore adapter le côté gauche.

Et c'est là que le "drame" est survenu lors du dernier tests qui se passait parfaitement (bonne distance à droite et à gauche), je me suis dit "j'ai enfin réussi" ...

Mais après le calibrage du centre, de la droite et de la gauche, il est revenu faire un test au centre et c'est là que sans raison apparente l'imprimante à continuer à descendre l'axe Z avec donc blocage moteur. J'ai coupé rapidement mais au rallumage le 3DTouch restait en alarme et lorsque j'ai monté l'axe Z, la sonde métallique est sortie du 3DTouch et est maintenant complètement désolidarisée :'(

Est-ce que quelqu'un a déjà eut le même problème ? Mon 3DTouch est HS ?

Une image de l'état de mon 3DTouch : http://hpics.li/e65fcc1

 

Il ne coute "que" 15€ donc ce n'est pas dramatique mais il va falloir encore patienter 2-3 semaines si j'en recommande 1 :(

Modifié (le) par Aragats
Lien vers le commentaire
Partager sur d’autres sites

Le pin en métal n'aimante plus dans le 3dtouch ?

Ton 3dtouch est un original geeetech ou une copie chinoise ?

 

Perso sur mon premier 3dtouch j'avais le fil blanc dessoudez sur le CI du coup il marchais à moitié, et mon axe Z montait au lieu de descendre lol...

Modifié (le) par nos68
Lien vers le commentaire
Partager sur d’autres sites

il y a 8 minutes, nos68 a dit :

Normalement il est aimanter grâce a la bobine...démonte le pour voir, sa te coute pas plus chère :P

Oui c'est prévu en rentrant du taf, je posterais ici le résultat

Lien vers le commentaire
Partager sur d’autres sites

Bon j'ai réussi (avec de l'aide extérieur) à le remettre d'aplomb

Il y avait le "support" qui était sortie de ca place : http://hpics.li/d4f023d

Je l'ai remis à sa place : http://hpics.li/7535c63

Et remonté sur l'imprimante : pas de mise en alarme, semble bien s'initialiser mais par contre quand je lance le teste il semble de pas détecter le min-Z puisqu'il continue de faire descendre l'axe Z alors qu'il est au bout ...

Modifié (le) par Aragats
Lien vers le commentaire
Partager sur d’autres sites

As-tu démonter le 3dtouch avec ces petite vis ? si oui à tu vérifier que les 4 câbles sont bien soudez sur le circuit imprimer ?

Car moi le blanc était hs, du coupe il écrasais le plateau..

Et attention à la bobine, je te conseil de mettre un scotch électrique autour..

Modifié (le) par nos68
Lien vers le commentaire
Partager sur d’autres sites

il y a 16 minutes, nos68 a dit :

As-tu démonter le 3dtouch avec ces petite vis ? si oui à tu vérifier que les 4 câbles sont bien soudez sur le circuit imprimer ?

Car moi le blanc était hs, du coupe il écrasais le plateau..

Et attention à la bobine, je te conseil de mettre un scotch électrique autour..

Tout est bien soudé (pour l'instant :p)
J'ai trouve le pb, j'utilise des cables dupont de 20 cm du coup obligé d'enchainer 4-5 entre eux pour faire mon cablage ... et je n'avais pas vu que sur le chemin un des cables orange s'était déconnecté ...

Faut vraiment que je me trouve du meilleur cable

J'attaque la partie calibration

Lien vers le commentaire
Partager sur d’autres sites

Perso vu que je fais du modélisme, j'ai utilisé des rallonges de servo (c'est des connecteurs dupons) du coup pour les fils 3 couleurs j'ai pris de la rallonge de servo de modélisme,

et pour le Z-min, j'ai utiliser le câble d'origine bleu du z-min, j'ai juste rallonger les câbles et une petite soudure et gaine thermo, car je préfère avoir la prise jst 2 pins,

que des dupons seul emboité sur la carte...

Content pour toi que tu ais trouver ton problème, de toute manière la plupart du temps ou le 3dtouch fonctionne pas, ou c'est un soucis de câblage.

Bref l'essentiel c'est que tu ais trouver le soucis.

Pour la calibration, perso j'ai fait un G28 dans repetier, et ensuite un G1 Z0 et la j'ai regarder la distance entre le lit et la buse, et j'ai affiner tout sa dans marlin

la ligne est : #define Z_PROBE_OFFSET_FROM_EXTRUDER -1.0

Pour moi -1.0 me fait passer la feuille en grattant, mais à toi d'affiner sa...jusqu'à que la feuille passe en grattant.

Mais a chaque fois que tu modifie la valeur, et balance le firmware dans la machine, tu fait un G28 et ensuite un G1 Z0 et tu verifie avec ton petit papier ;)

  Après ya d'autre technique mais bon moi j'ai fait comme sa.

Ensuite une fois réglé, dans ton Gcode d'impression, c'est G28 et ensuite G29

Toujours G29 après G28 sinon sa marche pas,

G29 te fait la mesure des 4 coins avant impression ;)

Amuse toi bien ;)

 

@+

Lien vers le commentaire
Partager sur d’autres sites

Merci 

J'ai utilisé le paragraphe sur la calibration du lien https://www.geeetech.com/wiki/index.php/3DTouch_Auto_Leveling_Sensor

Soucis c'est que 1 mm le pas est trop grand :)

-2.99 --> feuille bouge sans toucher

-3.99 -> feuille complètement bloqué

Je vais affiner ca mais je pense m'arrêter là pour ce soir, je suis déjà content que mon 3DTouch soit opérationnel, franchement à un moment donné j'avais même commencé à retirer tout le cablage et regardé pour en commander un autre :)

J'ai l'impression que mon G29 fait plus que 4 coins (12 points ?)

J'ai lancé l'impression d'un cube, j'en ai chié ... j'avais mis à jour Cura tout me semblait identique à la version précédente dans mon paramétrage mais j'avais de la sous extrusion jusqu'à que je remarque que le diamètre de mon filament était configuré sur 2.85 >:(

Je pense que mon offset Z est encore trop haut (-3 actuellement), j'affinerais ça demain !

 

Au niveau des câbles, j'ai trouvé ça : http://www.conrad.fr/ce/fr/product/223738/Cble-rallonge-servo-Modelcraft-223738-1x-JR-mle-1x-JR-femelle-014-mm-plat-500-mm?ref=searchDetail

Mais je n'ai pas l'impression que se soit bon pour le branchement côté ventilateur 

Lien vers le commentaire
Partager sur d’autres sites

si tu te débrouilles un peu en soudure, il est facile de rallonger les cables sans passer par des raccords source d'ennuis.

perso, j'ai dénudé une vieille rallonge péritel, et les cables que j'ai récupéré vont très bien...

Lien vers le commentaire
Partager sur d’autres sites

@tomg778Perso, les rallonges de servo sont des connecteurs dupont et vont très bien, je voie pas ou est la source d'ennuie la dedans...mais bon.

@Aragats tu peux affiner en baissant à -3.95 ou -3.90 ou -3.85 etc...encore une chose, pense à serrez au 3 quart tes ressort du plateau, comme sa il sont bien comprimer

et ne se desserrerons pas lors des vibrations ou autres...

 

@+

Modifié (le) par nos68
Lien vers le commentaire
Partager sur d’autres sites

ben si tu fais du modélisme, tu dois savoir que moins y a de raccords, moins y a de risques de faux contacts...

c'est pour ca qu'on ne met pas de fiches bananes sur des liaisons moteurs/variateurs, et encore moins sur les branchements récepteur/controleur de vol....

Lien vers le commentaire
Partager sur d’autres sites

Il y a 7 heures, tomg778 a dit :

ben si tu fais du modélisme, tu dois savoir que moins y a de raccords, moins y a de risques de faux contacts...

c'est pour ca qu'on ne met pas de fiches bananes sur des liaisons moteurs/variateurs, et encore moins sur les branchements récepteur/controleur de vol....

Je suis pas du tout d'accord, tout les hélico 3d et autres, on des fiches banane qui relie le moteur/esc (connecteur doré)

Imagine toi que tu règle ton hélico, la première chose est de déconnecter le moteur, pour des raisons de sécurité, et pour éviter de manger un démarrage de pale en pleine tête,

Et perso, j'ai pas encore vu de moteur/esc ou les câble sont soudez, etc..

 

Ces même connecteur sont utiliser aussi pour les prise de lipo par ex EC2 - EC3 etc...

Voir photo du connecteur :

3-5mm-banana-plug-gold-plated-banana.jpg

 

Et pour conclure sur les rallonges, par exemple on les utilises souvent sur des planeurs.

 

Moi de toute ma vie, je n'ais jamais eu aucun soucis...

@+

Lien vers le commentaire
Partager sur d’autres sites

Le 07/05/2017 at 09:34, Aragats a dit :

Il ne coute "que" 15€ donc ce n'est pas dramatique mais il va falloir encore patienter 2-3 semaines si j'en recommande 1 :(

Modifié (le) hier à 09:41 par Aragats

Bonsoir

Sur quel site trouves tu un 3Dtouch geeetech à 15€?

Lien vers le commentaire
Partager sur d’autres sites

il y a 39 minutes, patochefrench a dit :

Bonsoir

Sur quel site trouves tu un 3Dtouch geeetech à 15€?

En promo sur alienexpress

Vendeur = GETECH CO. LTD

Acheté par mobile (ptet que ca change le prix ?)

Lien vers le commentaire
Partager sur d’autres sites

C'est un faux vendeur, car les vrais s'appel GEEETech....c'est un clone, et les clone pose plus de problème que l'original ;)

Le vrais coute 49$ et il le solde a 29$ je crois encore sur le site officiel ou leur boutique amazon.

Lien vers le commentaire
Partager sur d’autres sites

Il y a 7 heures, nos68 a dit :

Je suis pas du tout d'accord, tout les hélico 3d et autres, on des fiches banane qui relie le moteur/esc (connecteur doré)

Imagine toi que tu règle ton hélico, la première chose est de déconnecter le moteur, pour des raisons de sécurité, et pour éviter de manger un démarrage de pale en pleine tête,

Et perso, j'ai pas encore vu de moteur/esc ou les câble sont soudez, etc..

 

C'est pas parce que "tous" les hélicos en sont pourvus que c'est bien...regarde chez les pros de la voltige 3D hélico, les prises sont soudées!

ces connecteurs sont source de faux-contact, et les vrais modélistes consciencieux ont des techniques et astuces pour que le moteur ne démarre jamais sans qu'on lui ai demandé...

 

bref, c'est mon avis, tu as le tien...je respecte, veux surtout pas m'engueuler pour des fiches banane...

moi, je disais juste que ca peut être la source de pb d'avoir 3 ou 4 rallonges raccordées les unes aux autres...

Lien vers le commentaire
Partager sur d’autres sites

Je comprend ton point de vue tom, mais perso je préfère débrancher mon moteur lors des réglages, car des fois l'électronique ne pardonne pas :P

J'aimerai bien connaitre leurs technique, car à part la coupure moteur sur la radio je voie pas trop, ya pas mille façons, si ?

J'adore le modélisme, j'ai arrêter la voiture rc pour faire de l'héli 3D depuis 5 ans, Mais l'impression 3D prend un peux le dessus ces dernier temps :P

Moi perso j'ai jamais eu de soucis depuis petit, mais comme dit avec l'électro sa tombe en rade quand sa veux..tout comme les voitures et autres objets lol...

Bref on part en hors sujet, revenons à nos mouton :P

Moi le 3Dtouch ma été offert part GEEETech officiel, voici leur lien ou il se trouve sur la boutique amazon :

https://www.amazon.fr/gp/product/B01LYSI636/ref=oh_aui_detailpage_o00_s00?ie=UTF8&psc=1

Compte 2 semaine si jamais tu le commande via le lien, en lettre suivie.

Ou 29$ Via leur boutique officiel en promo :

https://www.geeetech.com/index.php?main_page=product_info&cPath=24_109&products_id=1010&zenid=5t4lo8t51i0e4jn7q3oniqfue2

 

Il me semble que les clones c'est écrit BLTouch au lieu de 3Dtouch..

@++

Modifié (le) par nos68
Lien vers le commentaire
Partager sur d’autres sites

Ok, après j'en suis pas a 100% sur, mais pour 15 euro....

Car les gens ont eu beaucoup plus de soucis d'installation, pour installer le 3dtouch cloné, que l'original.

Lien vers le commentaire
Partager sur d’autres sites

Mon principal soucis (or le fait de devoir changer de marlin pour qu'il soit opérationnel) a été qu'à un moment donné l'imprimante à continuer de descendre sur le plateau (débranchement d'une rallonge ?) et que ca a fait sortir de sa place la tige métallique.

Le reste cela n'a été que du réglage

Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
  • Sur cette page :   0 membre est en ligne

    • Aucun utilisateur enregistré regarde cette page.
  • YouTube / Les Imprimantes 3D .fr

×
×
  • Créer...