Aller au contenu

Filament ABS

Philippe

delta et autoleveling a l'aide

Messages recommandés

Bonjour .
Mon imprimante Delta est terminée et fonctionne (presque) . je souhaite installer un autoleveling avec une sonde à induction.
La sonde est installée et detecte le lit en configuration manuelle . ( c'est à dire que quand j'approche la sonde du lit à quelques millimètres , elle s'allume) .
Sur la ramps 1.4 la sonde est branchée sur un port affecté au z min
Je précise que la sonde est connectée à la carte ramps via un petit module qui envoie du 5 volts sur le z min .  (sonde reprap-france.com)

Je sollicite l' aide d'un spécialiste de la delta et de l'autoleveling pour la configuration du firmware et les réglages finaux . je n'ai encore rien trouvé de probant sur le web qui corresponde à ma configuration ( delta + sonde inductive )
Merci à vous .
Philippe

Partager ce message


Lien à poster
Partager sur d’autres sites

Pout ton capteur :

Citation

 

Utilisation de la carte: 
Note au préalable: téléchargez le dernier firmware Marlin à l'adresse suivante: https://github.com/MarlinFirmware/Marlin
Généralement, le palpeur (Zprobe) utilise la broche Zmin de votre carte Ramps. Il vous faudra donc faire 2 manipulations:

  • Dans le configuration.h de Marlin: changer la ligne "const bool Z_MIN_ENDSTOP_INVERTING = true; // set to true to invert the logic of the endstop.
    Pour inverser le signal d'entrée logique de votre capteur.
  • Dans le pins.h de votre Marlin dans la section carte Ramps (généralement à la ligne 612)  réadressez le pin Zmin à l'entrée D12 en remplacant la ligne suivante:
     "#define Z_MIN_PIN          12 // replacement du port préconfiguré 18 en 12"


ATTENTION: il est important de bien adresser le port d'utilisation du capteur inductif en "entrée" si vous configurez vous-même votre microcontroleur.

 

 

Regardes ici pour le firmare Marlin :

https://github.com/RichCattell/Marlin

- https://github.com/RichCattell/Marlin/tree/master/example_configurations/delta

Modifié (le) par PoLoMoD

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour

 

quand ton capteur capte regarde bien que le module réagis (moi par exemple la led sur mon module est allume quand le capteur ne capte pas est s'éteint quand le capteur capte ) (regarde aussi avec la commande m119 si quand ton capteur capte la commande m119 est trigerred et quand il ne capte pas qu'il est sur open )

ensuite as tu bien redresser le port 18 en 12 et connecter ton capteur sur l'entrée 5v VCC et L'entree 12 v de ta carte ramps ( eviter de connecter ton capteur au z min de ta ramps avec ce type de module j'ai cramer un arduino en faisant ca je sais pas si c'etais du au fais que j'avais connecter le module au z min que ca la cramer mais depuis que je ne le connecte plus au z min mais au 5 v VCC et au 12 v je n'ai plus griller l'arduino enfin griller le bootloader )(si tu veux je te fais fais une photo de mon montage si ca peut t'aider dis moi)

 

cdlt

Modifié (le) par damdam2959

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×