Aller au contenu

Filament ABS

Cfirote

Moteur avec petit bruit et chauffe importante RAMPS 1.4

Messages recommandés

Bonjour :)

 

la carte mère de mon imprimante 3D Anet A8 à griller (de ma faute à jouer avec le filament dans le moteur d'extrudeur, elle n'a pas aimé le retour de courant ....)

du coup pour avoir moins de souci à l'avenir j'ai décidé d'acheter un kit RAMPS 1.4 avec des stepper drivers DRV8825.

 

lors de mes premier test (pour confirmer que tout est bien installé (alim, USB, et 1 moteur pour tester chaque axe individuellement) je me rend compte que le moteur fait un bruit continue (plus ou moins aigue ) après chaque mouvement.

 

le moteur se met alors à chauffer fortement et le DRV8825 aussi.

il y a un réglage à faire concernant ça ?

 

Cordialement.

Partager ce message


Lien à poster
Partager sur d’autres sites

je pense que les voltages envoyés à ton ou tes moteurs via les drivers sont mal réglé (trop ou pas assez)

Voici 2 articles qui te permettront de les régler er de comprendre le système :

https://www.genapart.com/2015/10/27/rôle-et-réglages-des-pilotes-moteurs-pas-à-pas/

https://www.genapart.com/2016/06/02/rôle-et-réglage-des-pilotes-moteurs-pas-à-pas-partie-2/

sinon n'hésite pas à nous recontacter sur ce post ;)

  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites
youtube drone débutant

Bonsoir,

 

c'est parfait, j'ai fini par calibrer correctement l'axe X et Y, il son maintenant silencieux et presque parfait l'impression est "réduite" sur ces axes

 

pour tester j'ai imprimer un cube de 20mm de coté

 

sur la hauteur j'ai 19.9mm

sur les coté (axe x et y) j'ai17.5mm (soit 12.5% de moins)

 

je pense que je doit mettre a jour le firmware Marlin 

 

la ligne : #define DEFAULT_AXIS_STEPS_PER_UNIT   { 100, 100, 400, 95 }

je la change par :

#define DEFAULT_AXIS_STEPS_PER_UNIT   { 112, 112, 400, 95 }, j'imprime un nouveau cube pour confirmer que c'était bien ça :)

 

Merci beaucoup de votre aide ^^

Partager ce message


Lien à poster
Partager sur d’autres sites

Pas de quoi, pour le calcul des axes tu peux utiliser ce calculateur

https://nathan7.eu/stuff/RepRapCalculator/RepRapCalculator.html#MotorStuffPrecise

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci :)

Bon il se trouve que finalement c'était bien 100, c'est juste que j'avais fait des ajustement directement dans Marlin via l'interface de l'imprimante car précédemment (avec des stepper A4988) l'axe Y faisait beaucoup de bruit (vibration) et j'ai tenté de modifier pas mal de réglage pour baisser ce bruit pour finalement griller une pièce de la carte mère en mettant mal un des stepper driver .....

 

donc je suis reparti de zéro avec un nouvel Arduino, une nouvelle Ramps 1.4 mais que avec des DRV8825 (même position de jumper etc...)

 

maintenant c'est parfaitement fonctionnel :) après tout les réglage (et tellement plus silencieux :D )

 

Merci de ton aide forte utile ^^

Partager ce message


Lien à poster
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez poster un message et vous inscrire plus tard. Si vous avez déjà un compte, connectez-vous afin de poster avec.

Invité
Répondre à ce sujet…

×   Vous avez copié du contenu avec formatage.   Supprimer le formatage

  Only 75 emoji are allowed.

×   Votre lien a été automatiquement intégré.   Afficher en tant que lien à la place

×   Le contenu sauvegardé a été restauré.   Effacer l'éditeur

×   You cannot paste images directly. Upload or insert images from URL.


  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×
×
  • Créer...