Aller au contenu

Filament ABS

Sebseb

Problème de calibration discoeasy 200

Messages recommandés

Bonjour,

J'ai un soucis sur ma discoeasy200, lors de la calibration sur dagom'app la buse s'enfonce dans le plateau et les moteurs forcent. J'ai essayé avec un autre palpeur seulement le problème est l'inverse, au lieux de se rapprocher du plateau, la buse s'éloigne.

Quelqu'un aurait une idée pour résoudre le soucis?

Partager ce message


Lien à poster
Partager sur d’autres sites

Hello,

Tu as un palpeur avec un comportement inverse de celui codé dans ton firmware:
le firmware pense que tu es en contact alors que tu ne l'es pas donc l'inverse de ce qui est attendu.

Il faut prendre le firmware qui correspond à ton capteur, en fonction de sa couleur!

Pierre

Modifié (le) par Walli

Partager ce message


Lien à poster
Partager sur d’autres sites
youtube drone débutant

Salut pour ton problème: 
Par contre, as tu fais une modif ou installer un autre firmware ?
Comment se problème est-il survenu ?

 

Dans marlin il faut éventuellement inverser la logique du capteur pour ton nouveau capteur:
Vers la ligne 464 #define Z_MIN_PROBE_ENDSTOP_INVERTING true/false a toi de mettre le bon


Pour ce faire fait des test sur Ponterface avec m119:
-> Relève ton chariot Z
-> tu lance une commande M119 le capteur Z doit retourner l'information "open"
-> Redescend ton plateau ou met un objet métallique sous ton capteur et relance M119 il faut qu'il retroune l'info "Triggered"

1) Si c'est l'inverse qui se produit:
                 - tu devras inverser dans marlin Z_MIN_PROBE_ENDSTOP_INVERTING à true ou false selon ta config.


2) Si il reste dans le même état ( "open" ou "triggered") dans t'es deux test quoi que tu fasse:
               - tu peux avoir un mauvais branchement sur ta carte,
               - une inversion des fils masse signal (bleu/noir)
               - si tu as une inversion du 5V  ta carte devrait reboot a chaque triggrer si c’était le cas
               - ton palpeur est pas adapter ou hs (ca m'est arrivé sur une commande)

Modifié (le) par As3uS

Partager ce message


Lien à poster
Partager sur d’autres sites

Voir le capteur s’il n’est pas simplement mort, quand la tête descend tu colles là spatules dessous avant que la tête s’ecrase.

Pour finir tu sors le capteur et tu regarde si une lumière s’eclaire au niveau du fil au moment d’une détection.

Si la tête ne s’arrête pas, si la lumière ne s’allume pas avec la spatule, alors capteur défectueux.

 

B7077148-087A-4A36-B88C-812510BF9B8E.jpeg

57E7E04E-2271-44C5-88C3-13188A24EA4D.jpeg

Partager ce message


Lien à poster
Partager sur d’autres sites

bonjour 

petite question il se trouve que j ai le meme problème que se qui se trouve plus du au téléchargement de la carte mère j ai fait les teste et le capteur indique ouvert quand il y a du fer devant et riggered quand il y e a pas 

je cherche ou je doit modifier le parramettre mais je trouve pas merci de votre réponse 

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour @jojo la 3D, dans marlin il faut inversé la logique du capteur.

Vers ligne 394 de configuration.h:
const bool Z_MIN_ENDSTOP_INVERTING = true ou false (selon ce que tu as sur ton fichier)

Partager ce message


Lien à poster
Partager sur d’autres sites

Ok mais on trouve sa où je suis plus que nul en informatique on fait comment pour rentrer les paramètres dans l imprimante PS mon ordi et un mac il faut un logiciel pour le faire merci 

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 09/03/2018 at 18:17, chikungunya a dit :

Voir le capteur s’il n’est pas simplement mort, quand la tête descend tu colles là spatules dessous avant que la tête s’ecrase.

Pour finir tu sors le capteur et tu regarde si une lumière s’eclaire au niveau du fil au moment d’une détection.

Si la tête ne s’arrête pas, si la lumière ne s’allume pas avec la spatule, alors capteur défectueux.

 

B7077148-087A-4A36-B88C-812510BF9B8E.jpeg

57E7E04E-2271-44C5-88C3-13188A24EA4D.jpeg

Salut @chikungunya,

Attention quand même avec ce diagnostic qui n'est qu'une première approche, et certains en déduisent que le capteur est hors de cause. Et c'est là l'erreur Je m'explique. Le capteur à 3 fils. Le +, le - et le signal. Si le fil du signal est cassé, la led sur le capteur va bien s'allumer et pourtant tu n'auras jamais l'information sur la carte.

Steam

Partager ce message


Lien à poster
Partager sur d’autres sites

Alors j ai de problème depui la mis à jour de mon imprimante la mis à jour et la dernière de chez dagoma non elle et pas d origine je n’ai pas remplacé le capteur et je suis sur mac pour l ordi  

Partager ce message


Lien à poster
Partager sur d’autres sites

ok, bon, le soucis, c'est que tu va devoir savoir ce qui a été modifier et les réglages appliqués suite à ces modifs,
ensuite installer le logiciel arduino
Et modifier le marlin avec les bon reglages,
mais si tu n'est pas du tout a l'aise avec l'informatique ça va être dur.

Si tu sais ce qui a été changé,  je peux éventuellement te faire un fichier firmware.bin pour que tu flash, mais il faut me dire quels sont les modifications, et si les branchements sont ceux d'origines.
 

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut, tu peux regarder l'explication l'ami @Zarrt je ne fais pas refaire un topic qui est déjà très clair.

 

en premier lieu télécharger et installer l'IDE Arduino ---> https://www.arduino.cc/en/Main/Software POUR TOI CE SERA MAC OS

Ensuite si vous avez un écran télécharger la bibliothèque pour le gérer ----> https://github.com/olikraus/U8glib_Arduino/archive/1.19.1.zip

pour installer la bibliothèque, dans l'IDE Arduino faire "Menu/Croquis/Inclure une bibliothèque/Ajouter la bibliothèque .ZIP..."

Télécharger les sources du Marlin "Dagoma" ----> https://dist.dagoma.fr/

 

Dans l'IDE Arduino configurer la carte et le port COM utilisé :

"Menu/Outils/Type de carte/Arduino/Genuino Mega or Mega 2560    (pour une carte MKS Base)

vérifier que le bon type de processeur soit renseigné.

"Menu/Outils/Processeur  ATMega2560 (Mega2560)

ensuite brancher la carte MKS à votre PC en USB

puis "Menu/Port" pour sélectionner le bon port (COM1/COM2/COM3/COM4 etc ...)

 

Une fois ces prérequis effectué ont est prêt pour modifier le firmware.

Dans l'IDE Arduino : "Menu/Fichier/Ouvrir"  chercher dans le répertoire ou vous avez télécharger les sources le répertoire Marlin puis ouvrer le fichier "Marlin.ino"

Le principal fichier à modifier pour une configuration de "base" est le fichier configuration.h

Partager ce message


Lien à poster
Partager sur d’autres sites

 Bon j’abandonne je suis une quiche en informatique sa dépasse mes capacités je n arrive pas j ai que des message d erreur  tu m’a proposé de me faire le fichier la  je suis preneur elle et d’origine niveau électronique h

349CC9D6-C9B3-4D76-8882-FEB49AFB232B.jpeg

D1B431F5-DFC1-44B9-B378-9F3D6F4FB4A4.jpeg

1627F12D-3831-4680-AB61-AE563F91D592.jpeg

Partager ce message


Lien à poster
Partager sur d’autres sites

Re, alors voila je t'ai fais un firmware avec la dernière version avec la modification pour la tête qui me semble être celle de dragon-shark.
En espérant que ça aille, fait bien attention quand tu flash ce n'est pas ma machine, et je ne l'ai pas vu.
Libre a toi de flasher le fichier que je t'ai donner a t'es risques et péril (un flash n'est pas anodin). 
je le fais pour te rendre service mais ça implique que tu devras faire des tests avant de lancer une impression, ne pas copier bêtement le fichier.
Il faudra aussi que tu refasse un réglage d'offset avec la dagom'app.

Le marlin est celui de dagoma complilé avec Arduino 1.8
-> Inversion de la logique du capteur
-> Reglage Decalage palpeur Dragon-Shark
-> Option de l’écran il me semble le voir aussi sur la photo de t'es branchements.

Je résume:
-> Tu Flash
-> Test ton palpeur M119
-> Test Homing G28
-> Test probe G29
-> Réglage Offset

En espérant que ca roule pour toi et que tu retrouve un imprimante que marche :)
Si ya des soucis de réglages reviens me le dire.
Tu peux aussi reflasher avec le marlin de dagoma si c'est dans les choux complet.

 

firmware-e200.hex

Modifié (le) par As3uS

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×