Aller au contenu

Filament ABS

Vanvan

32 bits Problème 3d touch et mks sbase v1.3

Messages recommandés

Bonjour,

je suis passé en mks sur ma prusa et il m'est impossible de faire fonctionner mon 3d touch, aucunes commandes ne le fais bouger, quand je branche un servo à sa place(en 1.23 pour la commande), le servo fonctionne très bien, quand je rebranche tout sur ma ramps mon capteur fonctionne très bien.

Mon capteur est branché comme : - sur gnd, + sur 5v, signal sur 1.28 et commande sur 1.23. Quand je fais les diverses commandes avec M280 S... rien ne se passe.

J'ai lu x forum et x tuto et toujours rien.

Merci pour votre aide avant que mon imprimante passe par la fenêtre :emoji-E412:

bltouch-pour-auto-leveling.jpg

config.txt

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 3 heures, Vanvan a dit :

Merci pour votre aide avant que mon imprimante passe par la fenêtre :emoji-E412:

dit moi ou tu habites que je me place sous ta fenêtre :D

je n'ai pas de bltouch pour te guider...

sinon as tu vu cette page http://smoothieware.org/zprobe#bltouch-or-servo-retractable-touch-probe

j'ai regardé ton fichier config, as tu encore ton endstop sur le Z ? car sinon il faut que tu changes la ligne

gamma_min_endstop                            1.28^!            #

en

gamma_min_endstop                            nc            #

car il est utilisé par la ligne

zprobe.probe_pin                             1.28

Partager ce message


Lien à poster
Partager sur d’autres sites

merci pour ta réponse, je l'ai mis en nc mais comme il ne sais plus ou aller le z home ne bouge plus donc encore mauvaise pioche pfff

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a une heure, Vanvan a dit :

il ne sais plus ou aller le z home ne bouge plus

là c'est normal car quand tu fais un G28 il fait juste le home de X et du Y ...

tu ne m'as pas répondu " as tu encore ton endstop sur le Z ?"

ton cavalier sous le Z+ est il sur 5v ?

Partager ce message


Lien à poster
Partager sur d’autres sites

non j'ai plus le endstop, j'ai la prise avec le fils blanc et noir du 3d touch en 1.28, le 5v est bien branché, lors du démarrage de la carte le capteur s'initialise bien.

Partager ce message


Lien à poster
Partager sur d’autres sites

le gnd du pin3 tu l'as banché ou ?

tu peux mettre une photo de ta carte ou on voit les branchement ?

Partager ce message


Lien à poster
Partager sur d’autres sites

j'ai regroupé mes 2 gnd sur le même pin, j'avais fais comme ça sur ma ramps en plus je viens de contrôler à l'ohmètre sur le capteur, la masse est déjà commune, ce que je comprend pas c'est qu'aucunes commandes ne font bouger le palpeur mais ça fonctionne avec un servo.

IMG_1607.JPG

Modifié (le) par Vanvan

Partager ce message


Lien à poster
Partager sur d’autres sites

fait un essai comme je te l'ai dit plus haut :

change

gamma_min_endstop                            1.28^!            #

en

gamma_min_endstop                            nc            #

car il est utilisé par la ligne ci-dessous et il y a risque de conflit

change

zprobe.probe_pin                             1.28

en

zprobe.probe_pin                             1.28^

et enlève les "#" devant ces lignes :

#leveling-strategy.three-point-leveling.enable         true        # a leveling strategy that probes three points to define a plane and keeps the Z parallel to that plane
#leveling-strategy.three-point-leveling.point1         100.0,0.0   # the first probe point (x,y) optional may be defined with M557
#leveling-strategy.three-point-leveling.point2         200.0,200.0 # the second probe point (x,y)
#leveling-strategy.three-point-leveling.point3         0.0,200.0   # the third probe point (x,y)
#leveling-strategy.three-point-leveling.home_first     true        # home the XY axis before probing
#leveling-strategy.three-point-leveling.tolerance      0.03        # the probe tolerance in mm, anything less that this will be ignored, default is 0.03mm
#leveling-strategy.three-point-leveling.probe_offsets  0,0,0       # the probe offsets from nozzle, must be x,y,z, default is no offset
#leveling-strategy.three-point-leveling.save_plane     false       # set to true to allow the bed plane to be saved with M500 default is false

et à ta place, même si c'est apparemment une masse commune je testerai de mettre la masse du 3pin sur ce pin

gnd.png.da9923e094d22e65fb27f27ff04faf18.png

peux tu faire un essai de palpage en activant manuellement le bltouch ?
 

Partager ce message


Lien à poster
Partager sur d’autres sites

Rien ne se passe même le Z bouge plus, je remet en pj mon fichier config, je comprends vraiment pas.

config.txt

Modifié (le) par Vanvan

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 13 heures, pascal_lb a dit :

peux tu faire un essai de palpage en activant manuellement le bltouch ?

si tu peux tire le palpeur à la main, tu fais ensuite un G28 l'axe X et Y vont venir en home mais pas le Z c'est normal apès tu fais un G32 normalement ça devrait faire un palpage.... garde le doigt sur le bouton on/off au cas ou...

ça permettra déjà de voir si le palpage se fait bien...

Modifié (le) par pascal_lb

Partager ce message


Lien à poster
Partager sur d’autres sites

Je viens de faire le test, G28 se met bien en home x et home y, g32 va pour une palpation mais rien se passe au capteur, j'ai essayé les commandes G28, G29 et les M280 et ça ne faisait rien non plus, je me pose vraiment la question si c'est bien compatible avec cette fameuse mks comme il y a le bl touch original et le miens le 3d touch une copie, j'ai lu à pas mal d'endroit que plusieurs personnes étaient comme moi et qu'ils ne trouvait pas trop de solution.

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 9 minutes, Vanvan a dit :

il y a le bl touch original et le miens le 3d touch

en effet c'est une possibilité, le bltouch à l'air de fonctionner au vu des différent posts que j'ai lu à droite ou à gauche...

à savoir que la commande G29 ne fonctionne pas très bien sur smoothieware, il est préférable d'utiliser G32

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon, je la jette par la fenêtre maintenant ou j’attends encore un peu ? :D

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 23 minutes, Vanvan a dit :

Bon, je la jette par la fenêtre maintenant ou j’attends encore un peu ? :D

garde l'imprimante mais jette le 3d touch :D sans vouloir t'influencer, regarde ce sujet si tu ne l'as pas vu...

Partager ce message


Lien à poster
Partager sur d’autres sites

j'avais lu un article sur ce genre de montage, avec marlin aucun problème, je trouve qu'avec smoothieware c'est pas la même chose, j'ai cru voir que l'on peux lui mettre marlin aussi ?

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 7 minutes, Vanvan a dit :

j'ai cru voir que l'on peux lui mettre marlin aussi ?

Les versions de marlin actuelle non, mais la version marlin V2 qui est en préparation devrait fonctionner sur les cartes 32bit mais c'est encore en développement...

Partager ce message


Lien à poster
Partager sur d’autres sites

je viens de faire un test avec G32 et un servo et un endstop, le servo ne bouge pas, est-ce normal ?

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 25 minutes, Vanvan a dit :

je viens de faire un test avec G32 et un servo et un endstop, le servo ne bouge pas, est-ce normal ?

le G32 c'est juste pour le palpage, pour le servo il faut faire un M280 S3.0

voir presque en bas de cette page http://smoothieware.org/zprobe

Partager ce message


Lien à poster
Partager sur d’autres sites

ok, je l'avais fais cette commande, je pensais que g32 le faisais aussi, merci.

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant


×