Aller au contenu

Filament ABS

icespring

home BL touch anet a8 pas centré

Messages recommandés

Bonjour à tous,

J'ai tenté de me dépatouiller seul avant de poster, mais la coupe déborde un peu là. Je fais court: Installation BL Touch (original) sur l'Anet A8, merci Maeke le tuyau était bon pour ce capteur. Quelques problèmes de montage (notices trouvées floues, inversions etc) mais ça c'est résolu. Problème résiduel: après avoir fouillé un peu partout, le home au G28 du bl touch ne se fait pas au x110 y110. Le LCD m'affiche bien ces valeurs mais visuellement c'est loin d'être le cas, ni pour la buse ni pour le probe. Le C++ ne me pose pas de blème (le G-Code si) mais faut savoir ou chercher. Comme je n'ai pas beaucoup de temps libre, de guerre lasse je soumets le problème (sûrement simple) à votre sagacité. De plus j'ai lu qu'il pouvait y avoir inter-actions entre les paramètres arduino-cura-pronterface si j'ai bien compris, et je me dis que ça sert à rien de s'obstiner à ramer quand on est sur la plage lol.

Pour info, j'ai suivi le tuto pour le décalage probe-buse et la rectification du configuration.h, mais apparemment tous les tutos partent ensuite du principe que le home est au centre quand on prépare l'offset Z. Bah dans mon cas, non, et je ne pige pas. Je ne parle même pas du test G29 qui commencerait en dehors du plateau si je ne coupe pas à temps.

Bons prints en attendant.

Partager ce message


Lien à poster
Partager sur d’autres sites

Normalement cela se configure dans le configuration.h du Marlin, voici les lignes concernées (elles débutent à la ligne 1025 pour moi):
 

// Use "Z Safe Homing" to avoid homing with a Z probe outside the bed area.
//
// With this feature enabled:
//
// - Allow Z homing only after X and Y homing AND stepper drivers still enabled.
// - If stepper drivers time out, it will need X and Y homing again before Z homing.
// - Move the Z probe (or nozzle) to a defined XY point before Z Homing when homing all axes (G28).
// - Prevent Z homing when the Z probe is outside bed area.
//
#define Z_SAFE_HOMING

#if ENABLED(Z_SAFE_HOMING)
  #define Z_SAFE_HOMING_X_POINT ((X_BED_SIZE) / 2)    // X point for Z homing when homing all axes (G28).
  #define Z_SAFE_HOMING_Y_POINT ((Y_BED_SIZE) / 2)    // Y point for Z homing when homing all axes (G28).
#endif

Pour activer l'option, il faut bien penser à décommenter le '#define Z_SAFE_HOMING', tel que dans le code ci-dessus.

On peut également définir un point personnalisé pour le safe homing, ou le laisser tel quel (il faut bien entendu avoir correctement définit les dimensions du plateau...).

 

J'espère avoir pu t'aider 😉

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci de ta réponse arno-p, je teste ça dès que je peux et je posterai le résultat. Je me doute que çest dans le configuration.h mais je n'avais pas trouvé les lignes qui impactent le home.

Bonne journée

Partager ce message


Lien à poster
Partager sur d’autres sites

Résultat des élections: voilà ce que j'avais déjà, et qui est conforme à ce que tu m'as envoyé:

#define Z_SAFE_HOMING

#if ENABLED(Z_SAFE_HOMING)
  #define Z_SAFE_HOMING_X_POINT ((X_BED_SIZE) / 2)    // X point(G28).
  #define Z_SAFE_HOMING_Y_POINT ((Y_BED_SIZE) / 2)    // Y point (G28).
#endif

J'avais même mis en direct 110 pour X et Y à la place de ((X_BED_SIZE) / 2)pour voir,  même si ça change rien étant donné que les variables taille plateau sont bien à 220x220.

Donc je continue, merci encore.

Partager ce message


Lien à poster
Partager sur d’autres sites

Suite et normalement fin jusqu'au premier print avec ce BL touch:

Préset Bl touch

#define X_PROBE_OFFSET_FROM_EXTRUDER -19   // X offset: -left  +right  [of the nozzle]
#define Y_PROBE_OFFSET_FROM_EXTRUDER -41   // Y offset: -front +behind [the nozzle]
#define Z_PROBE_OFFSET_FROM_EXTRUDER 0   // Z offset: -below +above  [the nozzle]
.......
// Set the boundaries for probing (where the probe can reach).
  #define LEFT_PROBE_BED_POSITION 19
  #define RIGHT_PROBE_BED_POSITION 180
  #define FRONT_PROBE_BED_POSITION 45
  #define BACK_PROBE_BED_POSITION 170
......
#define Z_SAFE_HOMING

#if ENABLED(Z_SAFE_HOMING)
  #define Z_SAFE_HOMING_X_POINT 148    // X point for Z homing when homing all axes (G28).((X_BED_SIZE) / 2)
  #define Z_SAFE_HOMING_Y_POINT 119   // Y point for Z homing when homing all axes (G28).((Y_BED_SIZE) / 2)
#endif

Voilà ce que j'ai du changer ---> Z_SAFE_HOMING_X_POINT 148 et Z_SAFE_HOMING_Y_POINT 119 pour avoir le home
 correct. Je sais pas si c'est très académique mais c'est ce que j'ai trouvé en attendant d'avoir un peu de temps.
Merci encore et bons prints arno-p

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×