Aller au contenu

Filament ABS

probleme configuration marlin 1.1.9 pour prusa i3


Messages recommandés

bonjour tout le monde antho.breizh, ma gentillement configurer un marlin 1.1.9 pour mettre dans ma prusa i3 avec carte gt2560 rev a+

 

 

sur la partie mecanique de base tout fonctionne, les moteurs se deplace bien, l extrudeur chauffe etc....

 

mais j ai un palpeur bl touch, et il n ' a pas su comment le configurer et tout est different par rapport au marlin de base

 

 

marlin de base:

2) Firmware for Prusa I3 X(GT2560)

I3_pro_X.zip
(295.69 KiB) Downloaded 21351 times

if you have upgrade your pro X into a dual extruder, please use this firmware

 

 

 

dernier marlin a jour 1.1.9

http://marlinfw.org/meta/download/

 

 

si certains se demande pourquoi, je suis passer sur le 1.1.9, la réponse est simple, le marlin de base necessitait l'ide arduino 1.0.1, et cette ide refusait de démarrer sur mon ordi, du coup assez compliquer pour le compiler et le televerser, et du coup je profite d'un marlin a jour

 

 

j'aimerais le partager avec vous une fois terminer, mais je voudrais juste finir de parametrer le bl touch, car pour le moment je ne peux pas utiliser la prusa

 

merci

Lien vers le commentaire
Partager sur d’autres sites

Le 14/10/2018 at 16:55, v tec a dit :

Le marlin 1.1.9 est top secret?

Absolument, d'ailleurs les documents "top secret / secret défonce" 😉 sont bien cachés dans Web obscur ici 😄

Lien vers le commentaire
Partager sur d’autres sites

bon alors, voici les modifs que j ai faite dans configuration.h

#define Z_PROBE_SERVO_NR 0   // adrien Defaults to SERVO 0 connector.
#define Z_SERVO_ANGLES {70,0}  // adrien Z Servo Deploy and Stow angles

#define BLTOUCH //adrien
#define SERVO0_PIN 11 //adrien
#if ENABLED(BLTOUCH) //adrien
  #define BLTOUCH_DELAY 375   // adrien(ms) Enable and increase if needed
#endif

#define X_PROBE_OFFSET_FROM_EXTRUDER -23  // adrien X offset: -left  +right  [of the nozzle]
#define Y_PROBE_OFFSET_FROM_EXTRUDER 0 // Y offset: -front +behind [the nozzle]
#define Z_PROBE_OFFSET_FROM_EXTRUDER -1   // Z offset: -below +above  [the nozzle

#define MULTIPLE_PROBING 2 //adrien

//#define MIN_SOFTWARE_ENDSTOPS  //adrien

#define Z_SAFE_HOMING //adrien

#define Z_MIN_ENDSTOP_INVERTING true // set to true to invert the logic of the endstop.  adrien

 

maintenant j envoi en televersement

Modifié (le) par v tec
Lien vers le commentaire
Partager sur d’autres sites

apres plein de tentative

 

j'arrive pas a uploader, je ne comprend pas pourquoi

 

j'ai plein d erreur de ce genre:

Error while detecting libraries included by C:\Users\adrien\AppData\Local\Temp\arduino_build_571543\sketch\stepper_indirection.cpp
"C:\\Program Files\\Arduino\\hardware\\tools\\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -Wno-error=narrowing -flto -w -x c++ -E -CC -mmcu=atmega2560 -DF_CPU=16000000L -DARDUINO=10807 -DARDUINO_AVR_MEGA2560 -DARDUINO_ARCH_AVR "-IC:\\Program Files\\Arduino\\hardware\\arduino\\avr\\cores\\arduino" "-IC:\\Program Files\\Arduino\\hardware\\arduino\\avr\\variants\\mega" "C:\\Users\\adrien\\AppData\\Local\\Temp\\arduino_build_571543\\sketch\\stopwatch.cpp" -o nul
Error while detecting libraries included by C:\Users\adrien\AppData\Local\Temp\arduino_build_571543\sketch\stopwatch.cpp
"C:\\Program Files\\Arduino\\hardware\\tools\\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -Wno-error=narrowing -flto -w -x c++ -E -CC -mmcu=atmega2560 -DF_CPU=16000000L -DARDUINO=10807 -DARDUINO_AVR_MEGA2560 -DARDUINO_ARCH_AVR "-IC:\\Program Files\\Arduino\\hardware\\arduino\\avr\\cores\\arduino" "-IC:\\Program Files\\Arduino\\hardware\\arduino\\avr\\variants\\mega" "C:\\Users\\adrien\\AppData\\Local\\Temp\\arduino_build_571543\\sketch\\temperature.cpp" -o nul
Error while detecting libraries included by C:\Users\adrien\AppData\Local\Temp\arduino_build_571543\sketch\temperature.cpp
"C:\\Program Files\\Arduino\\hardware\\tools\\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -Wno-error=narrowing -flto -w -x c++ -E -CC -mmcu=atmega2560 -DF_CPU=16000000L -DARDUINO=10807 -DARDUINO_AVR_MEGA2560 -DARDUINO_ARCH_AVR "-IC:\\Program Files\\Arduino\\hardware\\arduino\\avr\\cores\\arduino" "-IC:\\Program Files\\Arduino\\hardware\\arduino\\avr\\variants\\mega" "C:\\Users\\adrien\\AppData\\Local\\Temp\\arduino_build_571543\\sketch\\tmc_util.cpp" -o nul
Error while detecting libraries included by C:\Users\adrien\AppData\Local\Temp\arduino_build_571543\sketch\tmc_util.cpp
"C:\\Program Files\\Arduino\\hardware\\tools\\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -Wno-error=narrowing -flto -w -x c++ -E -CC -mmcu=atmega2560 -DF_CPU=16000000L -DARDUINO=10807 -DARDUINO_AVR_MEGA2560 -DARDUINO_ARCH_AVR "-IC:\\Program Files\\Arduino\\hardware\\arduino\\avr\\cores\\arduino" "-IC:\\Program Files\\Arduino\\hardware\\arduino\\avr\\variants\\mega" "C:\\Users\\adrien\\AppData\\Local\\Temp\\arduino_build_571543\\sketch\\twibus.cpp" -o nul
Error while detecting libraries included by C:\Users\adrien\AppData\Local\Temp\arduino_build_571543\sketch\twibus.cpp
"C:\\Program Files\\Arduino\\hardware\\tools\\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -Wno-error=narrowing -flto -w -x c++ -E -CC -mmcu=atmega2560 -DF_CPU=16000000L -DARDUINO=10807 -DARDUINO_AVR_MEGA2560 -DARDUINO_ARCH_AVR "-IC:\\Program Files\\Arduino\\hardware\\arduino\\avr\\cores\\arduino" "-IC:\\Program Files\\Arduino\\hardware\\arduino\\avr\\variants\\mega" "C:\\Users\\adrien\\AppData\\Local\\Temp\\arduino_build_571543\\sketch\\ubl.cpp" -o nul
Error while detecting libraries included by C:\Users\adrien\AppData\Local\Temp\arduino_build_571543\sketch\ubl.cpp
"C:\\Program Files\\Arduino\\hardware\\tools\\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -Wno-error=narrowing -flto -w -x c++ -E -CC -mmcu=atmega2560 -DF_CPU=16000000L -DARDUINO=10807 -DARDUINO_AVR_MEGA2560 -DARDUINO_ARCH_AVR "-IC:\\Program Files\\Arduino\\hardware\\arduino\\avr\\cores\\arduino" "-IC:\\Program Files\\Arduino\\hardware\\arduino\\avr\\variants\\mega" "C:\\Users\\adrien\\AppData\\Local\\Temp\\arduino_build_571543\\sketch\\ubl_G29.cpp" -o nul
Error while detecting libraries included by C:\Users\adrien\AppData\Local\Temp\arduino_build_571543\sketch\ubl_G29.cpp
"C:\\Program Files\\Arduino\\hardware\\tools\\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -Wno-error=narrowing -flto -w -x c++ -E -CC -mmcu=atmega2560 -DF_CPU=16000000L -DARDUINO=10807 -DARDUINO_AVR_MEGA2560 -DARDUINO_ARCH_AVR "-IC:\\Program Files\\Arduino\\hardware\\arduino\\avr\\cores\\arduino" "-IC:\\Program Files\\Arduino\\hardware\\arduino\\avr\\variants\\mega" "C:\\Users\\adrien\\AppData\\Local\\Temp\\arduino_build_571543\\sketch\\ubl_motion.cpp" -o nul
Error while detecting libraries included by C:\Users\adrien\AppData\Local\Temp\arduino_build_571543\sketch\ubl_motion.cpp
"C:\\Program Files\\Arduino\\hardware\\tools\\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -Wno-error=narrowing -flto -w -x c++ -E -CC -mmcu=atmega2560 -DF_CPU=16000000L -DARDUINO=10807 -DARDUINO_AVR_MEGA2560 -DARDUINO_ARCH_AVR "-IC:\\Program Files\\Arduino\\hardware\\arduino\\avr\\cores\\arduino" "-IC:\\Program Files\\Arduino\\hardware\\arduino\\avr\\variants\\mega" "C:\\Users\\adrien\\AppData\\Local\\Temp\\arduino_build_571543\\sketch\\ultralcd.cpp" -o nul

Modifié (le) par v tec
Lien vers le commentaire
Partager sur d’autres sites

La casse de tes lignes n'est pas bonne : pour decommenter une ligne utilise cette syntaxe " // "

 

#define Z_PROBE_SERVO_NR 0   // adrien Defaults to SERVO 0 connector.(celle ci je ne l'ai pas vue sur le tuto)
#define Z_SERVO_ANGLES {70,0}  // adrien Z Servo Deploy and Stow angles (celle ci je ne l'ai pas vue sur le tuto)

#define BLTOUCH //adrien
#define SERVO0_PIN 11 //adrien
#if ENABLED(BLTOUCH) //adrien(celle ci je ne l'ai pas vue sur le tuto)
  //#define BLTOUCH_DELAY 375   // adrien(ms) Enable and increase if needed(celle ci je ne l'ai pas vue sur le tuto)
#endif(celle ci je ne l'ai pas vue sur le tuto)

#define X_PROBE_OFFSET_FROM_EXTRUDER -23  // adrien X offset: -left  +right  [of the nozzle]
#define Y_PROBE_OFFSET_FROM_EXTRUDER 0 // Y offset: -front +behind [the nozzle]
#define Z_PROBE_OFFSET_FROM_EXTRUDER -1   // Z offset: -below +above  [the nozzle

#define MULTIPLE_PROBING 2 //adrien (celle ci je ne l'ai pas vue sur le tuto)

//#define MIN_SOFTWARE_ENDSTOPS  //adrien 

#define Z_SAFE_HOMING //adrien

#define Z_MIN_ENDSTOP_INVERTING true // set to true to invert the logic of the endstop.  adrien

#define NUM_SERVOS 3 // Servo index starts with 0 for M280 command adrien (celle ci je ne les pas vue sur le tuto)

Modifié (le) par Antho.breizh
Lien vers le commentaire
Partager sur d’autres sites

merci de toute façon j ai la pouasse , j ai pris ton configuration.h, j'ai juste changer le sens de direction des moteurs.... rebellotte plein d'erreur, là je viens de le refaire a l identique, il passe....

 

mais le probe ne marche toujours pas, je reçois le nouveau demain j en saurais plus

 

en tout cas merci de ton aide

Lien vers le commentaire
Partager sur d’autres sites

Au vue des erreurs de syntaxe et de ligne qui ne sont pas a modifier cela peu être normal prend ton temps de tout bien vérifier avant de compiler rien n'échappe a l'IDE un point ou un slash pas a ça place et sa plante ....

Ce n'est pas une question de pouasse mais de patiente ...

Modifié (le) par Antho.breizh
Lien vers le commentaire
Partager sur d’autres sites

bonjour, tout le monde le firmware va bientot etre pret pour le partage, il est fonctionnel a 99%

 

il me reste juste 2 paremetres a voir qui en marche pas

 

lui faire commencer la palpage a 10mm du bord et finir a 10mm de l'autre bord,j'ai une erreur

 

et lui faire faire 2 palpage ,1 rapide et 1 lent

 

pour le moment il en fait 2 mais en rapide..

Lien vers le commentaire
Partager sur d’autres sites

  • 4 months later...

Salut

Comme beaucoup de monde j'ai monter un bltouch voici un lien qui nous aide bien pour paramétrés la petite bête

http://fr.sixtek.com/2016/09/comment-lutiliser-installer-le-capteur.html

Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
  • Sur cette page :   0 membre est en ligne

    • Aucun utilisateur enregistré regarde cette page.
  • YouTube / Les Imprimantes 3D .fr

×
×
  • Créer...