Aller au contenu

Filament ABS

maya42

auto level

Messages recommandés

bonjour

voila j ai un petit probleme (bizarre non):D

j ai installer un auto level avec un contacteur  branche sur le fin de course z , le probleme c est que lorsque je lance l impression

la machine fait bien les contrôles de hauteur mais ensuite ne les prend pas en compte elle m affiche limite z atteint et fait l impression sans prise en compte des cotes du plateau mais bien du zero

 je ne sait pas ce qu il faut modifier pour remédier a cela

j espère que j ai été claire

maya42

Modifié (le) par maya42

Partager ce message


Lien à poster
Partager sur d’autres sites

salut,

vérifie si cette ligne est bien  décommentée dans le configuration.adv.h

#define ENDSTOPS_ONLY_FOR_HOMING // If defined the endstops will only be used for homing

 

Partager ce message


Lien à poster
Partager sur d’autres sites

me revoila

voila ce que me donne la modif

mais elle ne fonctionne pas la machine imprime dans de vide

meme en modifiant cette ligne

 #define Z_PROBE_OFFSET_FROM_EXTRUDER x en x j ai mis de -1 a 1 c est la meme chose elle n imprime pas (comme moi)

16:19:49.936 : Plateau x: 15.00 y: 20.00 z: -0.03
16:19:57.081 : Plateau x: 180.00 y: 20.00 z: 0.13
16:20:03.602 : Plateau x: 180.00 y: 180.00 z: -0.23
16:20:10.248 : Plateau x: 15.00 y: 180.00 z: -0.19
16:20:10.248 : Eqn coefficients: a: 0.00 b: -0.00 d: 0.04
16:20:10.248 : planeNormal x: -0.00 y: 0.00 z: 1.00
16:20:10.248 : ok
16:20:10.248 : echo:Fin de course atteint:  Z:-0.19
16:20:10.279 : ok

 si tu as une solution

merci

 

Partager ce message


Lien à poster
Partager sur d’autres sites

As tu vérifié la lige dans le config.adv ?

#define ENDSTOPS_ONLY_FOR_HOMING // If defined the endstops will only be used for homing

 

L'offset du palpeur, c'est en Z pour la hauteur, en X ou/et Y, c'est sa position par rapport a la buse

Modifié (le) par garcmi

Partager ce message


Lien à poster
Partager sur d’autres sites

oui je lai dé-commentée ensuite modifie la ligne   #define Z_PROBE_OFFSET_FROM_EXTRUDER avec différentes cotes mais elle est toujours au dessus du lit

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 11 minutes, maya42 a dit :

merci pour le dérangement

Pas de dérangement, un forum, c'est un peu fait pour ça ....

Partager ce message


Lien à poster
Partager sur d’autres sites

désoler c est pareille je suis au dessus du lit

je viens de mettre 0.05 sur la première couche dans cura est aucun résultat

faut peut être que je modifie Z_PROBE_OFFSET_FROM_EXTRUDER -1 et mettre 1 ou 0.5 a definir

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai eu ce problème avec ma sunhokey au début, j'ai été obligé de changer de marlin et ça a marché tout seul.

il semble que les firms sunhokey aient du mal avec l'autolevel mais je sais pas pourquoi.

Partager ce message


Lien à poster
Partager sur d’autres sites

ok  j avais un petit doute a ce sujet car depuis que je fais des modifs et tu as pris quel marlin compatible pour sunhokey car je ne suis pas un boss en firmware  et il me faut pas trop de modif pour la faire tourner

Partager ce message


Lien à poster
Partager sur d’autres sites

dans un premier temps j'ai pris ça et ça a marché

http://data.emotion-tech.com/ftp/Prusa_I3_Rework_et_Ordbot/Logiciels/Firmwares/Prusa_i3_Rework_rev1.5/Marlin_Prusa_i3_Rework_1.5.zip

J'ai changé ensuite pour d'autres raisons (gestion LCD et T° de ma nouvelle buse) par un marlin RC3

Partager ce message


Lien à poster
Partager sur d’autres sites

bonjour

voila j ai installe marlin RC3 fait les modif dans config.h mais maintenant c est le servo qui ne bouge plus

voila les lignes pour le servo

#define NUM_SERVOS 3 // Servo index starts with 0 for M280 command

// Servo Endstops
//
// This allows for servo actuated endstops, primary usage is for the Z Axis to eliminate calibration or bed height changes.
// Use M851 to set the Z probe vertical offset from the nozzle. Store that setting with M500.
//
//#define X_ENDSTOP_SERVO_NR 1
//#define Y_ENDSTOP_SERVO_NR 2
#define Z_ENDSTOP_SERVO_NR 0
#define SERVO_ENDSTOPS {-1, -1, 0} // Servo index for X, Y, Z. Disable with -1
#define SERVO_ENDSTOP_ANGLES {{0,0}, {0,0}, {90,0}} // X,Y,Z Axis Extend and Retract angles

si tu as un tuyaux c est bienvenu

Modifié (le) par maya42

Partager ce message


Lien à poster
Partager sur d’autres sites

Ben la je vais avoir du mal, j'utilise un palpeur capacitif, j'ai jamais utilisé un servo

Je vais regarder quand même pour voir.

Partager ce message


Lien à poster
Partager sur d’autres sites

ok 

as tu la carte mère d origine sur ta prusa c est a dire la MKS gen 2Z vers 1.2

peut être quel ne gère pas le auto level??

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

×