Aller au contenu

Filament ABS

Bosco2509

[SLS Scanner 3D] Mon Scanner 3D

Messages recommandés

Il y a 1 heure, Bosco2509 a dit :

je suis mort de rire... et à la fois de honte... car tu m'as dépassé... on voit bien les dents sur ton modèle... moi je piétine à tâtonner de mon côté en comparaison à toi...

on tâtonne tous autant qu"on est ,mais il y a des solutions ! à nous de trouver les réponses  ,puisque l'on sait que cela est possible .

je compte sur toi pour avancer .

je vais me renseigner sur cette histoire de "bruit numérique"

mais j’aimerai bien savoir comment ils font pour scanner des objets avec autant de précision??????

Partager ce message


Lien à poster
Partager sur d’autres sites

voila ce que j' obtiens  en photogrammetrie du même modèle et pourtant le système par lumière structurée devrait donner de meilleurs résultat.....

franchement je ne sais plus quoi penser🤨🤪

 

modelejpg.jpg

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 8 heures, @pascal@91 a dit :

Voila ce que j' obtiens  en photogrammetrie du même modèle et pourtant le système par lumière structurée devrait donner de meilleurs résultat.....

😲
Tu m'en bouche un coin (comme dit le dictons).

2 Questions indiscrètes :

1. Quel logiciel de photogrammétrie as-tu utilisé pour arriver à un tel résultat ? Meshroom ou un autre ?
2. Quel caméra ou appareil photo as-tu utilisé ? la même que le scanner ?

Après... il ne faut pas oublier que la Photogrammétrie a toujours été plus "adapté" qu'un scanner 3D sur certains objets.

Il y a 9 heures, @pascal@91 a dit :

je compte sur toi pour avancer

Comme dit le dictons : J'avance doucement, mais sûrement, à mon rythme. ☺️

Aujourd'hui... je vais essayer de m'y mettre sérieusement.

Il y a 9 heures, @pascal@91 a dit :

mais j’aimerai bien savoir comment ils font pour scanner des objets avec autant de précision??????

+1
J'ai beau suivre à la lettre les instructions existantes... je suis très loin de la précision que "HP" montrent que cela soit dans les PDF que sur les tutoriels vidéos.

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a une heure, Bosco2509 a dit :

1. Quel logiciel de photogrammétrie as-tu utilisé pour arriver à un tel résultat ? Meshroom ou un autre ?
2. Quel caméra ou appareil photo as-tu utilisé ? la même que le scanner ?

pour le logiciel j'utilise agisoft photoscan , il est simple d'utilisation et très efficace , par contre ça met des plombes pour avoir ce résultat .

meshroom me donnait un résultat inexploitable

j'ai utilisé mon smartphone tout simplement ( un galaxy  s7 ) 190 photos sur trois axes.

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a une heure, @pascal@91 a dit :

meshroom me donnait un résultat inexploitable

+1
Meshroom et HP David Scanner... fréquemment sont... en le disant gentillement : Ils sont 2 logiciels capricieux.
Exemple concret : Le "dragon" précédemment testé... si je reprend les mêmes photos faites précédemment, je n'arrive même plus à obtenir un modèle exploitable... c'est à rien n'y comprendre.

Je suis en train de "tester une autre méthode" (de mon invention) : Tourner autour du modèle avec le scanner, et sans utiliser le logiciel David Scanner.
Pour expliquer un peu plus en détail :

1. Télécharger des images "structurée" : des damiers, des formes géométriques, des images uniquement en Noir & Blanc.
2. J'ai mis ces images sur une carte mémoire, que j'ai inséré dans le vidéoprojecteur.
3. Je projette les images une à une sur mon modèle tout en tournant autour, et en faisant une vidéo avec la caméra.

4. Je passe la vidéo dans 3DF ZEPHYR FREE.

Résultat (encore brut) :

309279739_Capturedcran(407).thumb.png.790949b8ba6b4015880861cf60aa3139.png

Inconvénient lors de ce test : J'ai fait cela à bout de bras (pour faire vite, en 5 minutes).
Donc... pas très stable... et je n'ai pas beaucoup de photos "prises en compte" par le logiciel... mais je vois la figurine... donc c'était pas une tentative inutile.
Je vais essayer de "bricoler" un "bras" pour y fixer le scanner, et ce "bras" sera fixé sur un plateau tournant, pour tourner "uniformément" autour du modèle.

Cela va être un "travail de titan" de bien trouver et saisir le coup à prendre.

Pour l'instant mon avis "à chaud" : Je note que le pour le côté "Plug & Play", on repassera, et la maitrise du scanner, c'est "HARD" en terme de difficulté à prendre en main. Je trouvais la photogrammétrie beaucoup plus facile à prendre en main tout compte fait.

PS : Je note un détail : Cela a mieux scanné la pièce que le modèle. 😅
Sur cela... j'y retourne...

Partager ce message


Lien à poster
Partager sur d’autres sites

A tu essayé d'imprimer sur une feuille A4 des motifs qui sont pas répétitif (histoire d'avoir des points de repère pour meshroom) et la placer sous l'objet ?( en gros comme sur certaine plateau de scanner 3D)

Dans ce style : http://www.semageek.com/wp-content/uploads/2012/10/diy-fabriquer-un-scanner-3d-a-bas-prix-avec-un-arduino-et-un-appareil-photo-01-960x640.jpg

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 1 heure, Nenex a dit :

A tu essayé d'imprimer sur une feuille A4 des motifs qui sont pas répétitif

le plus simple est de coller sur le plateau une page de ton journal ou de ta revue préférée😉

  • +1 1

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 2 heures, Bosco2509 a dit :

Pour l'instant mon avis "à chaud" : Je note que le pour le côté "Plug & Play", on repassera, et la maitrise du scanner, c'est "HARD" en terme de difficulté à prendre en main. Je trouvais la photogrammétrie beaucoup plus facile à prendre en main tout compte fait.

+1

Partager ce message


Lien à poster
Partager sur d’autres sites

[Début HS]

Scanner 3D... et Photogrammétrie en "PAUSE"... en raison d'un gros problème de "matériel informatique".
Le soucis est le suivant : Crash à répétition - Blue Screen Of the Dead (Ecran Bleu de la Mort)  sur mon PC de bureau.
Tout cela sans trouver la vrai origine du problème... les investigations sont en cours, et j'ai déjà réinitialisé le PC 2 fois, mais sans résultat.
C'est complètement aléatoire... parfois l'ouverture d'une simple page internet fait planter le PC... et d'autres fois, c'est même rien du tout.
Un peu dégoûté d'avoir investit plus de 2000€ de renouvellement de matériel/Configuration de mon PC, pour le voir se bloquer sans raison.

Donc tout est en "PAUSE" le temps de résoudre cet épineux problème.

[Fin du HS]

Comme indiqué dans le HS... je n'ai pas pût utiliser longuement mon Scanner ces derniers jours.
Ajouté à cela... j'ai commencé à travailler sur l'éventualité de reconvertir le scanner dans un dispositif de photogrammétrie (une Caméra rotative autour d'un plateau, avec vidéoprojecteur d'éclairage)... mais dispositif en "Pause" en raison du problème cités plus haut.
Mes plus sincères excuses.

Partager ce message


Lien à poster
Partager sur d’autres sites

@Bosco2509 j'ai eu un pc qui plantait aléatoirement.  Chipset Intel avec Intel hd en processeur vidéo + carte ati jesaispluquoi corei7 9ème 64 go ssd etc bref une bete de course. 

J'ai désactivé dans le bios le Intel hd vidéo.  Du coup dans le gestionnaire de périphérique il ny avait plus qu'une seule carte vidéo (ati) install des pilotes ati et plus de soucis 

  • Merci ! 1

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 30 minutes, Titi78 a dit :

@Bosco2509 j'ai eu un pc qui plantait aléatoirement.  Chipset Intel avec Intel hd en processeur vidéo + carte ati jesaispluquoi corei7 9ème 64 go ssd etc bref une bete de course. 

J'ai désactivé dans le bios le Intel hd vidéo.  Du coup dans le gestionnaire de périphérique il ny avait plus qu'une seule carte vidéo (ati) install des pilotes ati et plus de soucis 

Merci de ta sollicitude.

J'ai pas mal cherché... essayer plusieurs choses... etc... et je pense avoir trouver  les 3 points qui me bloquaient tout :

1. La dernière mise à jour de Windows 1909 de Novembre > elle est incompatible avec 2 cartes graphiques différentes (dans mon cas une RTX2060 + une GTX1060) gérer par le même driver, cela a pour effet de créer une erreur/bug fatal "Matérielle" dans Windows, qui fait croire à Windows qu'il y a des multitudes de carte graphique... et forcément le système (Windows) plante irrémédiablement.
Je l'ai vu de mes yeux, dans le gestionnaires de périphériques, par moment l'erreur faisait apparaître plus d'une vingtaines de cartes graphique.
Le problème est connu de Microsoft, mais aucune mise à jour ou correctif n'est prévu dans l'immédiat.
Les solutions : Retirer la 2e carte, et procéder à une réinstallation propre de Windows. Ou installer 2 cartes graphique identiques et connectés en SLI, dans le cas contraire l'erreur/bug peut apparaitre (sauf qu'une RTX2060 ne peut pas être connecté en SLI, en tout cas pas la mienne).
Une autre solution m'a été proposé, si je veut garder les 2 cartes, c'est de réinstaller Windows mais me restreindre à la version 1809.

2. Un disque dur défaillant > j'avais un disque dur qui "se mettait en erreur". Cela plus le 1er point... cela fait encore plus de dégâts.
Solution : Retirer le disque dur. Avant cela... j'ai dû sauvegarder son contenu, près de 2000To, ce qui m'a pris du temps à envoyer ailleurs, surtout avec des crash à répétitions. Cela m'agace un peu de virer un disque dur qui fonctionne mais si il provoque des erreurs
... pas le choix faut le supprimer.

Pour info : Avec le logiciel Cristaldiskinfo, ce disque dur est indiqué en "jaune". Donc pas bon signe.

3. Un driver en doublon > Dans le gestionnaire de périphériques, j'avais 2 fois la même carte son, avec 2 drivers "différents". Cela étant dû à une erreur "humaine" (moi), en mettant à jour les drivers sans être passer par le site du fabricant de la carte mère. Cela m'a installé un 2e drivers différents... mais en gardant le précédent. Résultat : des problèmes là aussi.
Solution : On m'a recommandé de "Réinstaller Windows 10", car toutes mes tentatives de désinstaller le second drivers, se soldait par un échec, car Windows finissait par le réinstaller.

Donc j'ai  d'abord essayer de réinstaller Windows 10, en version 1809 :
Cela aurait été trop beau si cela avait fonctionné... car le problème est que Nvidia me refuse l'installation des drivers pour la RTX2060,  avec un Windows en 1809.
J'obtenais un vilain affichage "basse résolution".
En conséquence, je ne voyais plus qu'une réinstallation "propre" de Windows pour me sortir de là.

Donc finalement... après avoir sauvegardé tout mes fichiers sur des supports externe par précaution... j'ai retiré la carte GTX1060, puis j'ai formaté le disque SSD (où j'ai l'OS Windows 10)... puis j'ai réinstallé Windows 10 1909... installation qui s'est terminé, il y a 1-2 heures. Je viens de finir de réinstaller les drivers, uniquement ceux fourni par MSI.
J'ai passé ma journée à cela pour info... 😅

Le seul micro-soucis : Je n'arrive pas à installer la dernière mise à jour du driver de la carte wifi (fourni par MSI). L'installation me signale que j'ai déjà un drivers plus récent.
Si il le dit tant mieux... mais je trouve cela byzarre, étant donné que le drivers installé est daté de Mai 2019, et que le dernier que j'essaie d'installer est de Janvier 2020.
Mais du moment que le PC fonctionne tout va bien... détail : Je suis connecté à internet via câble RJ45, je me fout un peu du wifi.

Là... je commence seulement à réinstaller tout les logiciels.
Cela prend du temps à les télécharger un à un (eh oui, je n'ai pas encore la fibre).
Pour l'instant... tout fonctionne normalement. Pas de bugs bizarre... d'écran noir... de crash... ou de BSOD.
Donc tout est OK pour l'instant... 2 heures bientôt que le PC tourne, sans aucun crash.

[Fin du HS]

Partager ce message


Lien à poster
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez poster un message et vous inscrire plus tard. Si vous avez déjà un compte, connectez-vous afin de poster avec.

Invité
Répondre à ce sujet…

×   Vous avez copié du contenu avec formatage.   Supprimer le formatage

  Only 75 emoji are allowed.

×   Votre lien a été automatiquement intégré.   Afficher en tant que lien à la place

×   Le contenu sauvegardé a été restauré.   Effacer l'éditeur

×   You cannot paste images directly. Upload or insert images from URL.


  • Sur cette page :   1 membre est en ligne

×
×
  • Créer...