Aller au contenu

Filament ABS

Raidzer

Plateau qui "ignore" le endstop - Prusa i3 rework 1.5

Messages recommandés

Bonjour,

Je rencontre quelques difficultés lors de la finalisation du paramétrage de mon imprimante dont un auquel je n'arrive pas a trouver la source du problème.

Sur Repetier-Host, lorsque je clique sur la flèche pour déplacer le plateau ,celui-ci force sur son endstop, mais ne recule pas après l'avoir touché.

J'ai vérifié les branchements du moteur et du endstop sur la ramps, tout m'a l'air correct. 

Auriez-vous une idée ?

 

Merci !

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 13 minutes, Donovan-88 a dit :

Niveau Firmware, tu as réglé le endstop?

Non je n'ai pas réglé le endstop a ce niveau là, car jusqu'à présent tout fonctionnait bien, mais j'avoue que j'ignorais qu'on pouvait régler ceci au niveau du firmware, comment procède-t-on a ce réglage ?

Merci

Partager ce message


Lien à poster
Partager sur d’autres sites

Step 8: Position of endstops

If your limit switches (endstops) are the root cause when sends the printer to Home which in this case will be: X = 215mm (MAX), Y = 0 mm (MIN) and Z = 0 mm (MIN).

So the code to be applied is:

#define X_HOME_DIR 1
#define Y_HOME_DIR -1
#define Z_HOME_DIR -1

Where 1 is the maximum position of the X -1 and the minimum Y and Z.

source

 

J'ai trouvé ceci mais j'avoue être un peu perdu niveau programmation

Partager ce message


Lien à poster
Partager sur d’autres sites

Tu as regardé dans les lignes la :

#ifdef ENDSTOPPULLUPS
  #define ENDSTOPPULLUP_XMAX
  #define ENDSTOPPULLUP_YMAX
  #define ENDSTOPPULLUP_ZMAX
  #define ENDSTOPPULLUP_XMIN
  #define ENDSTOPPULLUP_YMIN
  #define ENDSTOPPULLUP_ZMIN
#endif

// The pullups are needed if you directly connect a mechanical endswitch between the signal and ground pins.
const bool X_MIN_ENDSTOP_INVERTING = true; // set to true to invert the logic of the endstop.
const bool Y_MIN_ENDSTOP_INVERTING = true; // set to true to invert the logic of the endstop.
const bool Z_MIN_ENDSTOP_INVERTING = false; // set to true to invert the logic of the endstop.
const bool X_MAX_ENDSTOP_INVERTING = true; // set to true to invert the logic of the endstop.
const bool Y_MAX_ENDSTOP_INVERTING = true; // set to true to invert the logic of the endstop.
const bool Z_MAX_ENDSTOP_INVERTING = true; // set to true to invert the logic of the endstop.
//#define DISABLE_MAX_ENDSTOPS
//#define DISABLE_MIN_ENDSTOPS

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Le problème a été résolu... par magie, je pense que c'était au niveau hardware, j'ai débranché puis rebranché le moteur du plateau et du endstop.

Merci Donovan de t'être penché sur mon problème :) 

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×