Aller au contenu

Filament ABS

IDEAMAKER : Pré-chauffage extrudeur inactif ne fonctionne pas


Messages recommandés

Bonjour,

Pour une impression avec deux extrudeurs séparés, Ideamaker permet de gérer la température de l'extrudeur inactif.

J'ai activé l'option "Refroidir l'extrudeur inactif" et ça semble fonctionner puisque au début de mon GCODE j'ai bien mon T0 à 205° pour imprimer et mon T1 qui est programmé à 180° par un M104 T1S180

Mais j'ai aussi activé l'option "Préchauffer l'extrudeur inactif avant la reprise" avec une "Préchauffe en avance" de 40s. D'après la doc et ce que j'en comprends, ça devrait anticipé l'utilisation du T1 pour le remettre en chauffe à 205° 40 secondes avant d'en avoir besoin.

Sauf que dans le GCODE l'anticipation ne fonctionne pas. Le T1 est programmé à 205° juste au moment de son utilisation pour l'impression.

J'ai comparé les 2 gcodes, avec et sans l'option d'anticipation, et IDEAMAKER me rajoute bien une ligne M104 T1 S205 mais il la mets juste avant le changement d'extrudeur. Ce qui n'apporte rien en gain de temps bien entendu !

Vous avez une idée ?

 

Reglages avances.jpg

UE-Compare.jpg

Lien à poster
Partager sur d’autres sites

J'ai trouvé pourquoi ça ne marche pas, pour moi c'est un bug.

En fait pour faire mes essais, je prenais un STL unique que je découpe dans IDEAMAKER avec l'option découpage libre. Pour créer deux modèles que j'affectais à un extrudeur chacun.

Et pour ne pas me prendre la tête je laissais une coupe à plat. Donc le changement de couleur (et donc d'extrudeur) se fait d'une manière totale. C'est à dire que le layer 167 s'imprime totalement avec un extrudeur et le layer 168 avec un autre extrudeur. Et dans ce cas l'anticipation ne marche pas, la chauffe du second extrudeur commence juste au début du layer 168.

Par contre si je fais une découpe en biais ca crée des layers bicolors, et là si je demande d'anticiper la chauffe ça marche mais sans anticiper au dela du layer en cours.

Si par exemple sur le layer 168 le second extrudeur doit imprimer la seconde partie, l'anticipation de la chauffe se fait avec le temps que l'on a mis mais sans jamais remonter jusqu'au layer 167 pour commencer la chauffe.

Donc si on a mis pré-chauffe de 40secondes, mais que à peine 5 secondes après le début du layer il faut changer d'extrudeur, la préchauffe ne sera que de 5 secondes.

Fonction pratique, mais pas aboutie à mon avis ... ou bug.

Lien à poster
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez poster un message et vous inscrire plus tard. Si vous avez déjà un compte, connectez-vous afin de poster avec.

Invité
Répondre à ce sujet…

×   Vous avez copié du contenu avec formatage.   Supprimer le formatage

  Only 75 emoji are allowed.

×   Votre lien a été automatiquement intégré.   Afficher en tant que lien à la place

×   Le contenu sauvegardé a été restauré.   Effacer l'éditeur

×   You cannot paste images directly. Upload or insert images from URL.

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

  • YouTube / Les Imprimantes 3D .fr

×
×
  • Créer...